-   Slackware (
-   -   Broadcom NIC driver compile error (

cyberwiz 06-26-2006 07:01 AM

Broadcom NIC driver compile error
I'm trying to compile the tg3 driver from Broadcom on a Slackware (2.4.31) but I always get the following error message during compile:

In file included from /lib/modules/2.4.31/build/include/linux/spinlock.h:6,
from /lib/modules/2.4.31/build/include/linux/module.h:12,
from tg3.c:27:
/lib/modules/2.4.31/build/include/asm/system.h: In function `__set_64bit_var':
/lib/modules/2.4.31/build/include/asm/system.h:190: warning: dereferencing type-punned pointer will break strict-aliasing
/lib/modules/2.4.31/build/include/asm/system.h:190: warning: dereferencing type-punned pointer will break strict-aliasing
In file included from tg3.c:77:
tg3.h: At top level:
tg3.h:234: error: redefinition of `if_mii'
/lib/modules/2.4.31/build/include/linux/mii.h:149: error: `if_mii' previously defined here
make: *** [tg3.o] Error 1

Any idea what is going wrong?


J3N7iL 06-26-2006 07:51 AM

As much as I hate to try solving an issue by not solving the issue, I have to say that Broadcom does not release any info about thier drivers and all attempts to date to reverse engineering have left the users pissed.

I have a broadcom wireless adapter in my Acer Laptop, and have been using the ndiswrapper to use the windows drivers for it. It also works for non-wireless drivers as well. You can find out how to configure it at gentoo-wiki. It's really a peice of cake. Im at work right now otherwise could post my home made batch script for setting it up. If your interested let me know and I'll post it when i get home.

cyberwiz 06-26-2006 08:23 AM

Thanks for the hint. I'll check the gentoo wiki. However I need the tg3 compiled for a specific reason (ZenWorks imaging kernel module). In the meantime I have tried to compile the tg3 using the 2.4.28 as well but no progress :(
I'll try to check out with the Broadcom support as well.


cwwilson721 06-26-2006 11:50 AM

I had the same problem. Here's the solution:

Forget broadcom. Go to

Their drivers work (kinda. At last try I had, it would only give me 'b' speeds, and no power/strength levels, but it would connect). Read their forums, too.

J3N7iL 06-26-2006 11:55 AM

Im not sure if the TG3 is wireless, I think its a gigabit LAN, could you clearify for us cyberwiz.

cwwilson721 06-26-2006 12:17 PM

You are correct.

I'm not sure either. I saw Broadcom and Network, and assumed.

If it is wireless, or the 'rt' chipset, my post is ok.

If not, please ignore it. Then whip me.

cyberwiz 06-26-2006 01:07 PM

It's gigabit LAN. But thanks for the suggestions guys. I'll remember them in case I get stuck with the wireless version some day

cwwilson721 06-26-2006 01:12 PM

I was reading in this thread about something else, and tg3 popped up...

Originally Posted by Chinaman
...I wish it worked back in Slackware-9.1 for my Broadcom Gigabit NIC ... back then I just didn't get on, until I uncommented "tg3" in /etc/rc.d/rc.modules or rebuilt the kernel afterwards.

Duh. Why didn't I think of that?

cyberwiz 06-27-2006 07:51 AM

cwwilson thanks for your input. At the moment I am recompiling the kernel with the tg3 module and will try to use the whole new thing as my ZenWorks imaging kernel. I was just dazzled that the module supplied by Broadcom did not compile :confused: However i can try compiling it on Gentoo box and see what is going on there but if it works I will be very surprised as usually my Slak box is fit for the purpose.



cwwilson721 06-27-2006 11:52 AM

Broadcom.....What can I say? I've never had any luck with them for anything....

Let us know if you resolve your issue. I'm sure there are plenty of others who are in the same boat, and need your 'paddle'...

ExplodingTurnip 06-29-2006 02:58 AM

Hmm, that's odd. The only problem I've ever had with a Broadcom Gigabit NIC was on an IBM server running Slack 10. I had to compile the module from the IBM drivers CD. From Slackware 10.1 and up, though, the network portion of Slack's setup automatically detects the NIC and adds the TG3 module. I'm not sure whether it actually transfers data at or near Gigabit speeds, though. All of the network switches where the server is located are still 10/100.

The card is a Broadcom NetXtreme Gigabit ethernet NIC, BTW.

davidsrsb 06-29-2006 05:00 AM

Have you tried the 2.6 kernel, Gigabit nic support in 2.4 is patchy.

cyberwiz 06-29-2006 07:04 PM

Final solution: just upgraded the other system to 2.4.31 and no more problems with tg3 :D
davidsrsb: I agree totally with you re 2.6 but unfortunatelly it is not an option for me yet.

All times are GMT -5. The time now is 06:24 PM.