Welcome to the most active Linux Forum on the web.
Go Back > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Slackware This Forum is for the discussion of Slackware Linux.


  Search this Thread
Old 10-22-2013, 01:10 AM   #1
LQ Newbie
Registered: Feb 2011
Location: Mexico
Distribution: Slackware
Posts: 29

Rep: Reputation: 0
Question Brightness does not change in KDE after upgrade Slackware 14.1 RC2

Hi everybody, I update to Slackware 14.1 RC1 a few days ago (and to RC2 today) using slackpkg and since then there is an issue that i can't solve.
I use KDE and my energy settings do not apply, I mean the brightness of my laptop's screen (an Asus X401A) doesn't change from 100% under any condition (plugged in, low battery, etc).

It doesn't bothered me until now because I was using Windows the most of the time, but now I'm using Slackware more time at day an my eyes are burning.

I use grub and tried to edit the file /etc/default/grub to:

GRUB_CMDLINE_LINUX_DEFAULT="quiet acpi_osi=Linux acpi_backlight=vendor resume=/dev/sda9"
And then run:

grub-mkconfig -o /boot/grub/grub.cfg
But still not changing the brightness. Also my user is in the "power" group (I read in a thread that was a solution).

BTW: the Fn keys (Fn + F5 for brightness down and Fn + F6 for up) does not have any effect in the brightness.

Thanks in advance.
Old 10-22-2013, 02:27 AM   #2
Registered: Feb 2003
Location: Almere, Netherlands
Distribution: slack 7.1 till latest and -current, LFS
Posts: 356

Rep: Reputation: 145Reputation: 145
Hi EcoSlacker,

you can try the following:

Xbacklight -dec 50

the 50 is percentage.
Old 10-22-2013, 09:28 AM   #3
Senior Member
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 4,950

Rep: Reputation: 1702Reputation: 1702Reputation: 1702Reputation: 1702Reputation: 1702Reputation: 1702Reputation: 1702Reputation: 1702Reputation: 1702Reputation: 1702Reputation: 1702
The fundamental problem is broken hardware. The details and some other workarounds can be accessed from here.
Old 10-25-2013, 12:03 AM   #4
LQ Newbie
Registered: Feb 2011
Location: Mexico
Distribution: Slackware
Posts: 29

Original Poster
Rep: Reputation: 0
I get nothing by running:

xbacklight -dec 50
But... I just try the solution in this page:

and edit the file
with vim to add the option "quiet acpi_osi=":

Then run, as root:

grub-mkconfig -o /boot/grub/grub.cfg
Reboot and the brigthness changes now even with the Fn keys, but the Fn+F2 option (wifi) is now broken as expected.

Old 11-10-2013, 11:55 AM   #5
Registered: Aug 2012
Posts: 75

Rep: Reputation: Disabled
Smile you need to find how to put this at the booting using a script.

nano /sys/class/backlight/acpci_video0/brightness/

set the 8 to 4. then save.

thanks to me later | happy hacking |


brightness, laptop, linux, slackware -current

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to authenticate/execute the action (Code 4) KDE 4.8.5 Slackware 14 RC2 32 bit ecoslacker Slackware 2 08-24-2012 02:23 PM
[SOLVED] Brightness set to zero: moved to Z0K4 Linux - Laptop and Netbook 5 09-15-2011 10:09 AM
Upgrade KDE and Slackware adrian2009 Slackware 3 04-05-2010 07:59 AM
Upgrade MDV RC2 FredGSanford Mandriva 1 11-04-2008 03:32 AM
Mandrake 9.1 rc2 upgrade advice please robertn Mandriva 1 05-02-2004 09:41 AM > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 12:33 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration