LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 11-05-2004, 10:39 PM   #1
Only1Abhi
LQ Newbie
 
Registered: Nov 2004
Posts: 9

Rep: Reputation: 0
Both Kernels Wont Boot! HELP!!


Hi, first post here. And I'm in serious trouble.

I have slack10.0. installed it, everything working fine. then i added another kernel 2.6.8, and also 2.6.7.

I edited lilo.conf just as DaOne suggested in his sticky thread: compile guide for newbies.

I edited the lilo.conf file and the Makeconfig files of each kernel, trying out 2.6.8 first, then 2.6.7.. and now back to 2.6.8 (for the new "Linux" kernel).

I think maybe i should have uninstalled a whole kernel rather than letting it sit there in the /usr/src folder.

Another mistake was to go into make menuconfig of my current (old) stable kernel, edited a few settings to include battery, blah blah, and did all the make dep, make clean, make bzImage, make, make install, make modules, make modules_install.


Now, the problem is:

The old stable version wont show anything on screen (when booting the kernel u know u get that black screen with lots of wriitng showing whats being loaded... that's what i'm talking about). ALL I see is a black screen with a white cursor flashing in the middle, that something moves to the right and comes back to the initial left position.

This lead me to believe that the kernel is booting, but just not showin me on screen whats booting. but then i waited for like 20 minutes and the login screen still didnt come.. i tried Ctrl + Alt + F7 (or F6, whichever loads the GUI login screen) but that didnt work either.


On my new kernel, i can see all this writing, but when booting, it looks for a Iee1394 (firewire) thing, it says something like:
ieee1394: /some/directory/ firewire iniitialised
_

that cursor that u see on the line above.. it flashes.. but doesnt go any further than that..


So both kernels dont work... what should I do people?


Someone suggested that I should boot the kernel from the install CD1. If I do this, what will I have to change, and WHERE??? (i suppose the lilo.conf file, but anything else? what about the symm links? could they be the problem? (i'm talking about the vmlinuz thing.. the links!)


Please help me, i dont know what to do. i've need the work on that linux partition, thats why i dont want to do a CLEAN install over that!


Many many thanks in advance.

Regards,
Abhi.
 
Old 11-06-2004, 01:10 AM   #2
Matir
LQ Guru
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 125Reputation: 125
Probably you need to rebuild your kernels and re-run lilo. Maybe just re-run lilo. You'll need to boot from a cd, mount the drive, chroot into your linux install, and then do the work. If you have an old config or kernel somewhere, it might help.
 
Old 11-06-2004, 01:40 AM   #3
ViN86
LQ Newbie
 
Registered: Mar 2004
Distribution: Slackware 10.0
Posts: 25

Rep: Reputation: 15
boot from the CD. heres an entry from my lilo.conf
check it out:

image = /boot/bzImage-2.6.7
root = /dev/hda1
label = Linux-2.6.7
read-only

i named the bzImage that was created bzImage-2.6.7 when i cp'd it to /boot/
the root entry is the hard drive it is loaded from, usually the drive with lilo on it (hda1)
and the label is whatever you want it to be. if you want spaces, use quotes
and read-only is pretty self explanatory

also, you mentioned putting your kernels in separate folders. when you tar -xjvf your *.tar.bz2 file, it should go into its own folder, ie linux-2.6.7. therefore, all files from different kernels should be separated. make sure your bzImage files have different names in the /boot/ folder. sounds like thats a possibility for your errors.

i would suggest deleting the linux-2.6.7 folders and re-extracting the files, then re-compiling the kernel and installing it. hope all goes well.
 
Old 11-06-2004, 09:25 AM   #4
Only1Abhi
LQ Newbie
 
Registered: Nov 2004
Posts: 9

Original Poster
Rep: Reputation: 0
when i create a bzImage on any of my kernels,

all i do is:

make bzImage


so how will the computer know which bzImage is supposed to be in which /boot image?


is there a way of specifying this?


Thanks

Abhi
 
Old 11-06-2004, 09:30 AM   #5
Only1Abhi
LQ Newbie
 
Registered: Nov 2004
Posts: 9

Original Poster
Rep: Reputation: 0
I think the problem is that my /boot images are all over the place


How do i sort this out people?
 
Old 11-06-2004, 09:35 AM   #6
Only1Abhi
LQ Newbie
 
Registered: Nov 2004
Posts: 9

Original Poster
Rep: Reputation: 0
i used the install cd to boot linux.


and recompiled my new (2.6.8) kernel to disable IEEE. it worked.

But my old kernel I recompiled aswell to disable IEEE, but now that checks for IEEE aswell..

So new kernel is ok, but old (stable) kernel looks for IEEE at boot. What do i do?
 
Old 11-06-2004, 09:41 AM   #7
mdarby
Member
 
Registered: Nov 2004
Location: Columbus, Ohio
Distribution: Slackware-Current / Debian
Posts: 795

Rep: Reputation: 30
cd /path/to/linux/kernel/source

make menuconfig
make bzImage && make modules && make modules_install

cp arch/i386/boot/bzImage /boot/bzImage-"kernel version"
cp System.map /boot/System.map-"kernel version"

pico /etc/lilo.conf

Add new listing for your new kernel (copy and paste existing listing, and change top line to point to your new kernel)

/sbin/lilo

reboot

Last edited by mdarby; 11-06-2004 at 09:58 AM.
 
Old 11-06-2004, 11:00 AM   #8
Only1Abhi
LQ Newbie
 
Registered: Nov 2004
Posts: 9

Original Poster
Rep: Reputation: 0
thanks man
 
Old 11-06-2004, 11:08 AM   #9
mdarby
Member
 
Registered: Nov 2004
Location: Columbus, Ohio
Distribution: Slackware-Current / Debian
Posts: 795

Rep: Reputation: 30
Let me know if this works for you
 
Old 11-06-2004, 11:46 AM   #10
Only1Abhi
LQ Newbie
 
Registered: Nov 2004
Posts: 9

Original Poster
Rep: Reputation: 0
I have 2 problems now:

1. On my new kernel 2.6.8, when loading/booting, it stops on: Mounting remote (SMB) file systems: /sbin/mount -a -t
then it askes for a password. i dont want this password thing.. i want it to skip this. It does go past this if i enter incorrect or any password, but it just slows bootup time, i wanna get rid of this.

2. When i load my slack.old kernel from Lilo bootup screen, it doesnt load the old 2.4.26 kernel, it loads 2.6.8.
How can I solve this ?
 
Old 11-06-2004, 11:51 AM   #11
mdarby
Member
 
Registered: Nov 2004
Location: Columbus, Ohio
Distribution: Slackware-Current / Debian
Posts: 795

Rep: Reputation: 30
Quote:
Originally posted by Only1Abhi
I have 2 problems now:

1. On my new kernel 2.6.8, when loading/booting, it stops on: Mounting remote (SMB) file systems: /sbin/mount -a -t
then it askes for a password. i dont want this password thing.. i want it to skip this. It does go past this if i enter incorrect or any password, but it just slows bootup time, i wanna get rid of this.

2. When i load my slack.old kernel from Lilo bootup screen, it doesnt load the old 2.4.26 kernel, it loads 2.6.8.
How can I solve this ?

1. You can enter your password in /etc/fstab under the listing for the smb mount:
//server/share /mnt/tmp smbfs username=urban,password=xxx 0 0

2. Did you modify the orginal listing in /etc/lilo.conf? There should be two listings, your original listing, and the new listing for the new kernel; something like:


prompt
timeout=50
default=2.6.8.1
boot=/dev/hda
vga=775

image=/boot/vmlinuz
root=/dev/hda1
label=2.4
read-only

image=/boot/bzImage-2.6.8.1
root=/dev/hda1
label=2.6.8.1
read-only
 
Old 11-06-2004, 12:07 PM   #12
Only1Abhi
LQ Newbie
 
Registered: Nov 2004
Posts: 9

Original Poster
Rep: Reputation: 0
Here's my lilo.conf file: Also, when lilo loads, if nothing is pressed on keyboard, it loads the default partition (windows) after 2 minutes. i want it to load after 10 seconds, i changed timeout to 100 but that didnt work. anyway, that is not a major problem.


#
# Start LILO global section
boot = /dev/hda
message = /boot/boot_message.txt
prompt
timeout = 1200
# Override dangerous defaults that rewrite the partition table:
change-rules
reset
# VESA framebuffer console @ 1024x768x256
vga = 773
# Normal VGA console
# vga = normal
# VESA framebuffer console @ 1024x768x64k
# vga=791
# VESA framebuffer console @ 1024x768x32k
# vga=790
# VESA framebuffer console @ 1024x768x256
# vga=773
# VESA framebuffer console @ 800x600x64k
# vga=788
# VESA framebuffer console @ 800x600x32k
# vga=787
# VESA framebuffer console @ 800x600x256
# vga=771
# VESA framebuffer console @ 640x480x64k
# vga=785
# VESA framebuffer console @ 640x480x32k
# vga=784
# VESA framebuffer console @ 640x480x256
# vga=769
# End LILO global section
# Windows bootable partition config begins
other = /dev/hda1
label = Windows
table = /dev/hda
# Windows bootable partition config ends
# Linux bootable partition config begins
image = /boot/vmlinuz
root = /dev/hda5
label = Linux
read-only
# Linux bootable partition config ends
#Old Linux bootable partition config begins
image = /boot/vmlinuz.old
root = /dev/hda5
label = slack.old
read-only
#Old Linux bootable partition config ends
 
Old 11-06-2004, 12:12 PM   #13
mdarby
Member
 
Registered: Nov 2004
Location: Columbus, Ohio
Distribution: Slackware-Current / Debian
Posts: 795

Rep: Reputation: 30
Did you happen to copy over vmlinuz.old with the new kernel by accident?

A timeout of 150 should give you a timeout of around 10 seconds (50 give me about 3 seconds), make sure to run /sbin/lilo everytime you modify /etc/lilo.conf!
 
Old 11-06-2004, 12:19 PM   #14
Only1Abhi
LQ Newbie
 
Registered: Nov 2004
Posts: 9

Original Poster
Rep: Reputation: 0
thanks a lot man
The SMB fileserver thing loads from bootup now, so no need to do:
mount -t smbfs //MYNETWORK/myfolder /mnt/temp

all the time now.

And the password thing went from bootup aswell. genuis



Now 2 problems:
1) Yeh the vmlinuz.old may have been overwritten by accident. how can i change this back?

2) On bootup it askes searches for floppy, i dont have any floppy drives on my laptop. i wanna disable this, so i went into /etc/fstab and commented the following line:

#/dev/fd0 /mnt/floppy auto noauto,owner 0 0

But still at bootup it searches for floppy, how can i turn this off?


MAny thanks man, i really REALLY appreciate yr help!
 
Old 11-06-2004, 12:31 PM   #15
Only1Abhi
LQ Newbie
 
Registered: Nov 2004
Posts: 9

Original Poster
Rep: Reputation: 0
THE TIMEOUT THING WORKED. THANKS

Also, if u have a quick solution, on bootup, the longest thing now is:

Update shared library links: /sbin/ldconfig

how can i make this run in the background?

And FINALLY:
On my gnome2.6 toolbar, there is a battery monitor thing for my laptop.
Next to the battery meter is a power connection status (shows whether power is battery or AC plug). when i remove the ac adaptor or insert it, the status doesnt change to battery or back to AC adaptor from battery.

Only when i logg off or reboot the system, it shows what the power connection status is. The meter is working fine, its just i want the power connection status to be more responsive.

If you could help me with any of these, that would solve all my problems..
MANY MANY THANKS MAN!!!!!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
after compiling 2.6.11.7, none of the kernels will boot hubabuba Fedora 1 05-02-2005 12:31 PM
GRUB dual boot with two diff kernels fails at boot mosquito_dk Linux - Software 3 09-06-2004 10:18 AM
install Suse, xp wont boot, repair xp suse wont boot Tangz Linux - Newbie 10 07-16-2004 06:37 PM
Suse 9, RH9 wont install properly. Mandrake 9 wont boot properly? Help. l2ich84 Linux - Newbie 1 01-31-2004 12:02 PM
different kernels use the same boot.b? gsbarry Linux - Software 5 07-24-2003 08:47 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 02:28 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration