-   Slackware (
-   -   Bootsplash in Slackware ! (

Cdzin 08-11-2003 04:28 PM

Bootsplash in Slackware !
Hello ! I've visited the homepage and i think it's pretty cool. So now i want to implant it in my Slackware 9.0 using the default kernel ( 2.4.20 ). First, does this kernel have support for bootsplash ? And how would i do it ?

320mb 08-11-2003 07:02 PM

Oh, yes. you can change the bootsplash screens for root and user, these are the little screens you see while KDE loads up right?
root location..../opt/kde/share/apps/ksplash/pics
user " ..../home/user directory/.kde/share/apps/ksplash/pics

*now remember, the users directories are Hidden!! you have to unhide them to access......IE in kong window, click View and show hidden files*

Cdzin 08-11-2003 08:29 PM

Hehe ! I already changed the KDE splash screen ! Actually i'm talking about the image of Tux when you inicialize the Slack. =| Any tip ?

windrose 08-11-2003 08:59 PM

Sure you can do it, and I have done it on my slack 9.0.
Good news : there's a slack-packaged bootsplash at , just do some little search. :)

Cdzin 08-12-2003 06:13 PM

Thank you windrose. Will work on it =].

BigBadPenguin 08-13-2003 09:19 AM

Also, when you get it, there's a gap in the documentation (at least the stuff i read, at the bootsplash website). When you get to the point of changing lilo.conf, you have to add "initrd=/boot/initrd.splash" in the linux bootable bit.

h1tman 08-21-2003 06:57 PM

i cant get that to work

Cdzin 08-21-2003 07:12 PM

Actually ! I haven't tried this at all since i'm too busy to recompile my kernel ! I think i will wait until the Slackware come with a kernel that already support bootsplash. If anyone knows another way to do this i would be grateful ! Thank you all =]

quietguy47 08-21-2003 09:20 PM

BigBadPenguin 08-22-2003 04:54 AM

h1tman, where's the problem exactly? I think actually the initrd stuff might have to be in the global section actually, by all the append stuff. Try that. Did you follow the instructions on the site? There are lots of them. Any error messages, or log stuff?

h1tman 08-22-2003 09:58 AM

i reinstalled slack, so when i try again i will give more info on my problems, but i followed the instructions exactly on the site. so it stumped me.

LSD 08-22-2003 10:43 AM

Bootsplash can be a pain to get going, even if you're running a kernel with the appropriate patches already applied. Here is the thread I used to help me get Bootsplash support on my Gentoo install:

The basic steps will probably work on Slack except of course you'll have to apply the bootsplash patch by hand and install the bootsplash packages using Slacks own tools.

sofanuladi 03-02-2004 08:29 AM

i have been configured bootsplash at slackware 9.0, my kernel is 2.4.22 and i have patched that , and i have configured all (splash config, lilo config)

it doen't work!
after booting , my initrd.splash didn't work

i have add "initrd=/boot/initrd.splash" to lilo.conf

any solution?
i really confused y'know:confused:

moonloader 03-02-2004 08:34 AM

boot splash comes with KDE 3.2 by default.if you upgrade to current,then you will have it.

asklepios 03-02-2004 12:06 PM

yeah setting up bootsplash is a real pain in a$$. i have tried it three time and have stopped trying now. i did all those steps the site mentions and even added that initrd line (it was so obvious) but didn't work.
moonloader: he is not talking about splash screens of KDE, rather it is bootsplash. a screen similar to what you see when you boot Win XP. upgrading to current will certainly not give him bootsplash. btw i m running current.

All times are GMT -5. The time now is 03:57 PM.