-   Slackware (
-   -   Booting Slackware 9.1 from VIA VT8237 SATA RAID1 array (

thefiddler 03-28-2004 12:10 PM

Booting Slackware 9.1 from VIA VT8237 SATA RAID1 array
Hi everyone,

I'm having problems booting an installation of Slackware 9.1 from a VIA VT8237 SATA RAID1
array. I'll describe what i've done up to this point and then describe the problem.
Any help/suggestions would be very much appreciated!

ASUS A7V600-X mobo with VIA VT8237 SATA RAID
2x 120Gb SATA disks running as RAID1 array (I think this is set up in the VIA bios ok)
OS is Slackware 9.1 (kernel 2.4.22)

Right... First off I installed Slack from CD ISOs on a temporary IDE drive in the same machine and
downloaded and compiled the VIA SATA RAID drivers. Ended up with a object module "viamraid.o"
which was then copied to a floppy. Unplugged the IDE drive and booted back from the Slack CD
and used "insmod viamraid.o" to load module into kernel (seemed to work ok, 120Gb raid array
appeared on /dev/sda). Then partitioned /dev/sda using "fdisk" (setting /dev/sda2
as root) and installed Slack on /dev/sda using "setup".

This is where things get interesting...

I setup the MBR with LILO using:

Now, I know this isn't going to work because the viamraid.o module needs to be loaded before so the
drives can be recognised. There are only two ways I can think of doing this, either using initrd to load
viamraid.o (This is the way the readme that came with the driver sources describes for other distributions,
but Slack doesn't use initrd, and doesn't have a mkinitrd script), or by somehow compiling the
viamraid driver into the kernel (I can't find a kernel patch from VIA, is there any way of making a patch
from the source already obtained?) or linking viamraid.o into the kernel during compilation.

I'd love it if someone could walk me through making and using an initrd image to load viamraid with
Slackware, but any new ideas and other help would be great as well.

When I fix this i'm going to write a how-to an post it on the web to save others frustration!

I've also posted in the forums, but i'll follow it up
here as well if the problem gets fixed!

Thanks for any help,


thefiddler 04-01-2004 08:14 AM

Hi everyone,

I've now resorted to a more fundamental solution.

An IDE drive has now been put in on which the operating system is
installed, with 'modprobe viamraid.o' and 'mount /dev/sda1 /home' in
rc.modules to give me VIA RAID support with the array mounted on

Not an ideal solution, I think you will agree. I'd still be interested in
any ideas others would care to offer.



TomG22 08-05-2005 11:43 AM

I have a Asus A8V Deluxe mobo and I'm trying also to install Linux (Fedora Core 4) on the VIA VT8237 SATA RAID1 (2x 80 GB disks).

I've downloaded this driver package (the first one).

Unzipped it, and read the file driverdisk.txt:
I used the procedure descripted for RedHat 9, I think it has to work with (the newer) Fedora too?


1). RedHat 9.0
There is a standard way to create RedHat driver disk, I've put it
into a script,, which has been mentioned in the readme.txt.
a). run ./, you will get a image file named viamraid.img
b). Insert a blank floppy, and run
#dd if=driverdisk/viamraid.img of=/dev/fd0
the driver disk is ready.
c). Install RedHat9.0, boot from RH9.0 cd, when it prompt: "boot:",
type "linux expert", then following the install instructions.
First of all, running the script gave me a lot of errors. I saw there is already a pre-compiled floppy image (in dir DriverDisk), so I used this one to write the floppy.

When I boot of the FC4 installation dvd, I type "Linux expert" at the boot prompt, but nothing seems to happen. By default, the FC4 setup loads die via_sata drivers, so both drives are reconized seperately.

I rebooted again with the FC4 dvd and typed now "linux dd".

Indeed, now I was prompted in the setup for a driverdisk. But the installation setup said me there was no device found for the driver disk. But I could manualy choose the driver, called something like Raid via (viamraid).
But no disks nor raid 1 setup was reconized by the system.

Someone? :(

vultus 06-20-2009 09:06 AM

no booting Via tech VT 8237 sata raid
I am having troubleshhoting when i open win xp.It conitues to reboot several times. I also tried to boot from F8. Like using last known configuration , command promt , etc..... but no success. The main problem it is showing that when i siwtch the pc on it starts booting and shows me that Serial_Ch0 Master NO Drive,
Serial_Ch1 Master NO Drive, I tried to using VIA Serial ATA RAID BIOS Setting Utility v1.00 but the command are not responding except esc to exit. Can i boot my pc from win xp cd ??

All times are GMT -5. The time now is 09:40 PM.