-   Slackware (
-   -   boot process hangs at audio driver, no sound (

hajatvrc 07-13-2010 01:43 PM

boot process hangs at audio driver, no sound
When my system boots it hangs at

HDA Intel 0000:01:00.1: PCI INT B-> GSI 17 (level, low) -> IRQ 17
(HDA Intel is my sound card) and eventually moves on after it times out at 120 seconds. It then continues the boot process until it reaches

triggering udev events: /sbin/udevadm trigger --type=failed
and hangs for another 120 seconds. In X11 I have no sound at all even after running alsaconf with no errors. My sound works perfectly in Ubuntu, so it's not a hardware problem. Are the two problems related or are they two separate things? Any help here would be hot.

allend 07-13-2010 06:10 PM

My dmesg ouput shows:

HDA Intel 0000:00:1b.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
HDA Intel 0000:00:1b.0: irq 27 for MSI/MSI-X
It may be that your hardware has problems with Message Signaled Interrupts.
Try using the 'pci=nomsi' kernel parameter.

ljb643 07-13-2010 06:12 PM

You probably have a device that is seriously upsetting udev. But I'm guessing it isn't the HDA Intel sound chip. Whatever message appears after the HDA Intel one might help, but again that might not be the actual cause. Can you see a message right after it stops hanging the first time?

I had something exactly like this happen with an older CD-RW drive on an older motherboard. It started with a udev upgrade in Slackware 12.something. The cause was the cdrom_id script it used to probe the device. It hung once early in the boot process, then again at "udevadm trigger". Same 120 second hangs, twice.

hajatvrc 07-13-2010 06:58 PM


Try using the 'pci=nomsi' kernel parameter.
Sorry I'm kind of new at this, how do I do this?

Can you see a message right after it stops hanging the first time?
I don't know, it goes by really fast. Is there some file that serves as a log for bootup time so I can copy-paste it?

allend 07-13-2010 10:54 PM

As you are also using Ubuntu, then you are probably using GRUB as your bootloader.
If you are chainloading Slackware with LILO on the Slackware root disk, add the string ' pci=nomsi' to the 'append=' string in your /etc/lilo.conf.
Perhaps some helpful person who uses GRUB can suggest an alternative?

hajatvrc 07-14-2010 02:35 PM

Actually, I use lilo exclusively. I added

append = "pci=nomsi"
to my lilo.conf and the boot process doesn't hang anymore. BUT, there is still no sound. Any other suggestions? I have had this problem in the past where my sound would work right after I installed slack and then it would mysteriously stop working when I rebooted my system. I did a very limited number of things in that time including updating my 64-bit libs with multilib versions and installing gtk-qt-engine. I don't think either of these would cause my sound to stop working. I can't think of anything else that I've done.

allend 07-14-2010 08:03 PM

Glad the boot process has been sorted.
For sound, have you worked through this?

hajatvrc 07-15-2010 01:26 PM

I have read the page you linked to and no luck. alsaconf recognizes my hardware just fine and, when I run it, it tells me "Now ALSA is ready to use." I use alsamixer to adjust the volume and then try to play sound in at least 3 different applications with no success.

allend 07-15-2010 07:31 PM

By default the snd-hda-intel module tries to automatically determine your hardware.
This may not be appropriate for your hardware. shows a large number of possible models. You can check your chip by looking at the chip reported by alsamixer.

You can setup a file /etc/modprobe.d/hda-snd-intel.conf and include a specific model.


options snd-hda-intel model=<some model name>
Edit: As the sound is working in Ubuntu, you could check the contents of alsabase.conf, which I believe is where Ubuntu keeps this configuration.

Bruce Hill 07-16-2010 08:02 AM

If you need to know which codec your card has, since there are
very many all using HDA Intel, issue:

cat /proc/asound/card0/codec#* | grep Codec

hajatvrc 07-16-2010 02:47 PM

As I have reinstalled slack for other reasons, the problem seems to have resolved itself. I won't know if the sound is going to stop working again until I start to play around a bit. Now it's time to get more edukated about Slackware, every day a new mystery.

Thanks for the help!

All times are GMT -5. The time now is 01:13 AM.