LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 06-07-2019, 10:13 AM   #1
xiongnu
Member
 
Registered: Sep 2004
Distribution: Debian, Void
Posts: 234

Rep: Reputation: 19
Boot problem on USB HDD: can't find /mnt in /etc/fstab error


hi, i have Slackware 14.1 installed on an external usb harddrive. and intend to use SL on different machines that i can get hold of whenever i travel.

I created the boot 'initrd' with the following:
Code:
cd /boot
mkinitrd -c -k 3.10.17-smp -m usb-storage:ehci-pci:ehci-platform -u -w 5 -f ext4 -r '_HDD_UUID'
However, some the machines I can boot SL, others i can't. receiving an error during boot.
Code:
mount: can't find /mnt in /etc/fstab
ERROR: no /sbin/init found on rootdev (or not mounted)
I should also mention that I've Openindiana as well as winXP installed on the same harddrive, partition and fstab are as follows:
Code:
Disk /dev/sdb: 80.0GB
...

Disk identifier: 0x3a393a38

Device    boot   start     end        blocks    id  systems
/dev/sdb1       63        41942879    20971408   7    hpfs/ntfs/exfat
/dev/sdb2   *   49945715   83875364    20964825  bf  solaris
/dev/sdb3       83875365   85867424    996030    82   linux swap
/dev/sdb4   *   85867425   125805014   19968795   83   linux


root@ :#  cat /etc/fstab
'swap partition UUID'    swap   swap  defaults  0 0
'install partition UUID'    /      ext4  defaults  1 1
/dev/sda1    /mnt/win   ntfs-3g  fmask=133, dmask=022  1 0
devpts       /dev/pts   devpts   gid=5, mode=620     0 0 
proc         /proc       proc     defaults           0  0 
tmpfs        /dev/shm    tmpfs    defaults            0  0
If it matters:
Of the machines that i can boot:
My two home PCs (one is HP, the other is homebuilt AMD machine with K8N Neo motherboard), and a Sony Vaio netbook.

Of the machines that i can't boot:
A nobrand microtower with Biostar P4M900-M4 MB
Dell OptiPlex 5060

Any suggestion how to fix this?
 
Old 06-07-2019, 10:25 AM   #2
Chuck56
Member
 
Registered: Dec 2006
Location: Colorado
Distribution: Slackware
Posts: 515

Rep: Reputation: 107Reputation: 107
Try using UUIDs instead of /dev/sd* in the /etc/fstab file. Run the "blkid" command as root to get the UUIDs on a machine that works.
 
Old 06-07-2019, 10:36 AM   #3
bassmadrigal
LQ Guru
 
Registered: Nov 2003
Location: West Jordan, UT, USA
Distribution: Slackware
Posts: 6,020

Rep: Reputation: 3687Reputation: 3687Reputation: 3687Reputation: 3687Reputation: 3687Reputation: 3687Reputation: 3687Reputation: 3687Reputation: 3687Reputation: 3687Reputation: 3687
Are you actually using the UUID of your harddrive in the mkinitrd command? I'm not sure if yours is edited to not show the UUID (which it doesn't really matter if those are made public or not) or if that is the actual command you ran.

And you'll definitely want to switch your /etc/fstab to UUIDs as if there is another harddrive or USB drive (or sometimes even cardreaders), it can affect your device names (/dev/sda, /dev/sdb, etc). Using UUIDs in your fstab will make sure that you don't run into issues with those changing. My guess is your problem is caused by the lack of UUIDs in your fstab and once you fix that, it will likely fix your problem.
 
Old 06-07-2019, 10:51 AM   #4
ehartman
Member
 
Registered: Jul 2007
Location: Delft, The Netherlands
Distribution: Slackware
Posts: 583

Rep: Reputation: 275Reputation: 275Reputation: 275
Quote:
Originally Posted by xiongnu View Post
Of the machines that i can't boot:
A nobrand microtower with Biostar P4M900-M4 MB
Dell OptiPlex 5060

Any suggestion how to fix this?
Could it be that the machines you cannot boot have UEFI enabled, which means they will need a FAT formatted UEFI partition with kernel and initrd ON your external hard disk?
 
Old 06-07-2019, 11:36 AM   #5
xiongnu
Member
 
Registered: Sep 2004
Distribution: Debian, Void
Posts: 234

Original Poster
Rep: Reputation: 19
Quote:
Originally Posted by bassmadrigal View Post
Are you actually using the UUID of your harddrive in the mkinitrd command? I'm not sure if yours is edited to not show the UUID (which it doesn't really matter if those are made public or not) or if that is the actual command you ran.

And you'll definitely want to switch your /etc/fstab to UUIDs as if there is another harddrive or USB drive (or sometimes even cardreaders), it can affect your device names (/dev/sda, /dev/sdb, etc). Using UUIDs in your fstab will make sure that you don't run into issues with those changing. My guess is your problem is caused by the lack of UUIDs in your fstab and once you fix that, it will likely fix your problem.
these are the actual mkintrd and fstab:
Code:
mkinitrd -c -k 3.10.17-smp -m usb-storage:ehci-pci:ehci-platform -u -w 5 -f ext4 -r UUID=f487c8e1-a959-4cfa-8a2e-c8718660dcaf

UUID=6faddc5e-8660-406d-a8b1-da1124368b0e        swap             swap        defaults         0   0
UUID=f487c8e1-a959-4cfa-8a2e-c8718660dcaf        /                ext4        defaults         1   1
UUID=8AA0E4F5A0E4E8A1        /mnt/win         ntfs-3g     fmask=133,dmask=022 1   0
#/dev/cdrom      /mnt/cdrom       auto        noauto,owner,ro,comment=x-gvfs-show 0   0
/dev/fd0         /mnt/floppy      auto        noauto,owner     0   0
devpts           /dev/pts         devpts      gid=5,mode=620   0   0
proc             /proc            proc        defaults         0   0
tmpfs            /dev/shm         tmpfs       defaults         0   0
I've modified 'fstab' to use UUIDs only, tried on the Dell Optiplex 5060 machine again, still got the same boot error.


Screenshot of error
 
Old 06-07-2019, 12:17 PM   #6
colorpurple21859
Senior Member
 
Registered: Jan 2008
Location: florida panhandle
Distribution: slackware64-current, puppy, ubuntu
Posts: 2,954

Rep: Reputation: 470Reputation: 470Reputation: 470Reputation: 470Reputation: 470
Try adding mbcache to mkinitrd
 
Old 06-07-2019, 12:46 PM   #7
xiongnu
Member
 
Registered: Sep 2004
Distribution: Debian, Void
Posts: 234

Original Poster
Rep: Reputation: 19
Quote:
Originally Posted by ehartman View Post
Could it be that the machines you cannot boot have UEFI enabled, which means they will need a FAT formatted UEFI partition with kernel and initrd ON your external hard disk?
UEFI boot is disabled on this Dell machine I had issue with, it uses Legacy boot.
 
Old 06-07-2019, 01:56 PM   #8
Chuck56
Member
 
Registered: Dec 2006
Location: Colorado
Distribution: Slackware
Posts: 515

Rep: Reputation: 107Reputation: 107
Based on the error screen the issue is most likely a missing module in the initrd. I wonder if an initrd similar to the one offered with a Slackware installation USB is the way to go for your use case. Maybe the "usbboot.img" found in the usb-and-pxe-installers directory of a 14.1 mirror can point the way to creating a universally bootable USB HDD for your mix of PCs?
 
Old 06-07-2019, 02:22 PM   #9
bassmadrigal
LQ Guru
 
Registered: Nov 2003
Location: West Jordan, UT, USA
Distribution: Slackware
Posts: 6,020

Rep: Reputation: 3687Reputation: 3687Reputation: 3687Reputation: 3687Reputation: 3687Reputation: 3687Reputation: 3687Reputation: 3687Reputation: 3687Reputation: 3687Reputation: 3687
You could try running /usr/share/mkinitrd/mkinitrd_command_generator.sh on the problematic machine and add any missing modules it suggests to your initrd.
 
Old 06-09-2019, 03:19 AM   #10
bormant
Member
 
Registered: Jan 2008
Posts: 332

Rep: Reputation: 192Reputation: 192
Try to increase delay to -w 10, does it help?
 
Old 06-09-2019, 05:05 AM   #11
Skaendo
Member
 
Registered: Dec 2014
Location: West Texas, USA
Distribution: Slackware64-14.2
Posts: 889

Rep: Reputation: Disabled
Are you using a USB3 or USB2 port?

If you are trying to boot legacy, you probably need to be using a USB2 port.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
mount: can't find /mnt in /etc/fstab rbn14 Slackware - Installation 10 07-31-2017 08:42 AM
[SOLVED] mount: can't find /mnt in /etc/fstab alberg Slackware - Installation 4 06-26-2016 08:08 AM
server startup error: "cannot find / in /etc/fstab or /etc/mtab"; /etc/fstab readonly knee-co Linux - Newbie 8 09-12-2010 05:37 PM
fstab problem: mount: can't find dvd in /etc/fstab or /etc/mtab Nikon01 Slackware 5 11-17-2006 06:15 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 11:55 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration