LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 10-03-2019, 07:48 AM   #1
rogan
Member
 
Registered: Aug 2004
Distribution: Slackware
Posts: 168

Rep: Reputation: 68
boot freeze after kernel-firmware upgrade 190923 -> 190926


Like the title says. This happens on AMD vega64. 100% sure it is
graphics related since it boots fine nomodeset.
Also sure is was the firmware upgrade since none of my kernels boot
with it.
Reverting to 190923 solves the problem.

Last edited by rogan; 10-03-2019 at 07:52 AM.
 
Old 10-04-2019, 07:23 PM   #2
bassmadrigal
LQ Guru
 
Registered: Nov 2003
Location: West Jordan, UT, USA
Distribution: Slackware
Posts: 6,199

Rep: Reputation: 3940Reputation: 3940Reputation: 3940Reputation: 3940Reputation: 3940Reputation: 3940Reputation: 3940Reputation: 3940Reputation: 3940Reputation: 3940Reputation: 3940
Out of curiosity, have you tried any newer kernels? I wonder if the firmware works better for newer kernels, like 5.3.x or the 5.4 RCs...
 
1 members found this post helpful.
Old 10-05-2019, 12:21 AM   #3
rogan
Member
 
Registered: Aug 2004
Distribution: Slackware
Posts: 168

Original Poster
Rep: Reputation: 68
Actually no. I might try it though.
As this happens from time to time I have tried that before, with negative result.

The vega64 has been a major pain.
 
Old 10-05-2019, 01:35 AM   #4
rogan
Member
 
Registered: Aug 2004
Distribution: Slackware
Posts: 168

Original Poster
Rep: Reputation: 68
Unexpectedly the firmware upgrade (190926) works with 5.4-rc1 on the vega64 this time.
 
Old 10-07-2019, 03:47 PM   #5
rogan
Member
 
Registered: Aug 2004
Distribution: Slackware
Posts: 168

Original Poster
Rep: Reputation: 68
Same problem with 191004. Halts mid-boot with a blank screen.
Had to downgrade to 190923 again.
 
Old 10-07-2019, 08:52 PM   #6
bassmadrigal
LQ Guru
 
Registered: Nov 2003
Location: West Jordan, UT, USA
Distribution: Slackware
Posts: 6,199

Rep: Reputation: 3940Reputation: 3940Reputation: 3940Reputation: 3940Reputation: 3940Reputation: 3940Reputation: 3940Reputation: 3940Reputation: 3940Reputation: 3940Reputation: 3940
You can keep an eye on the kernel-firmware commit history to see if any updates are affecting amdgpu devices.

https://git.kernel.org/?p=linux/kern...x-firmware.git
 
1 members found this post helpful.
Old 10-08-2019, 01:52 AM   #7
rogan
Member
 
Registered: Aug 2004
Distribution: Slackware
Posts: 168

Original Poster
Rep: Reputation: 68
Thanks
 
Old 10-08-2019, 10:11 AM   #8
aaditya
Member
 
Registered: Oct 2013
Location: India
Distribution: Slackware
Posts: 174
Blog Entries: 2

Rep: Reputation: Disabled
After reading bassmadrigal's post, another idea may be to gather more info and report it upstream.

A similar bug:
https://bugs.freedesktop.org/show_bug.cgi?id=109206

Last edited by aaditya; 10-08-2019 at 10:14 AM.
 
1 members found this post helpful.
Old 10-09-2019, 01:45 AM   #9
rogan
Member
 
Registered: Aug 2004
Distribution: Slackware
Posts: 168

Original Poster
Rep: Reputation: 68
These firmware "upgrades" has been a roulette wheel with the Vega64, pretty much since I bought it.
I just posted here so others that might have the same problem can find a quick fix.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[Slackware64 14.2] Loading error of ath10k firmware with latest kernel-firmware and latest kernel-huge pensador_13 Slackware 3 06-16-2018 12:31 PM
[SOLVED] Suggestion: install kernel firmware into /lib/firmware/$(uname -r) qweasd Slackware 7 08-08-2012 02:12 PM
Firmware is needed after kernel upgrade - why? 10110111 Linux - Wireless Networking 8 07-05-2010 10:35 AM
DSL modem firmware is not loaded after kernel upgrade fiz65 Slackware 1 05-25-2010 08:59 AM
Freeze of freeze on first boot compaq v6305nr distro: fedora core 7 schezel2000 Linux - Hardware 0 10-18-2007 10:01 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 04:50 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration