-   Slackware (
-   -   Boot fails at fsck but I get no error when I run fsck myself. new install on ssd. (

rlx 11-29-2012 09:50 PM

Boot fails at fsck but I get no error when I run fsck myself. new install on ssd.

I installed Slackware14 64bit on a new SSD partition. Initially everything went fine and I could boot and run Linux. After tuning the system and rebooting I eventually got in this situation where the boot hangs saying,

/sbin/e2fsck: Is a directory while trying to open /
The superblock could not be read or does not describe a correct
Ext2 filesystem. ...

Now, I login as root and type

fsck -C /dev/sdb4

The answer is,

ssd204: clean ...

In fact when I boot from another partition, I can mount and use that same partition without any kind of warning or problem.

During that same period I was attempting to clone Windows7 from my tabletPC on another partition of the same disk and being unsuccessful I ended up installing Windows8. I presumed that those attempts might have damaged the Linux partition. So I started over, wiping off the Linux partition, formatting, and reinstalling Slackware. I had kept a copy of the etc directory from my first install since it takes some time to setup everything and I reinstalled the etc files I had earlier modified.

Would any one have some insight to share as to what might possibly make 'fsck' fail during the boot and it is reporting no error when I run it myself?

By the way, the disk is detected all right at boot time and I can access it when I login as root when the file system is mounted read only.

Thanks for any clue.

rlx 12-02-2012 03:29 PM

[SOLVED] Boot fails at fsck but I get no error when I run fsck myself. new install on ssd.
The problem was an incorrect entry in '/etc/fstab'. The file read,

/sdb4 / ext4 noatime,discard,errors=remount-ro 1 0

while it should have been

/dev/sdb4 / ext4 noatime,discard,errors=remount-ro 1 0

What triggered this problem to happen after I had succeeded my first install of Slackware is that I had been a bit creative when I initially wrote the partition table of the disk. I gave the first partition to Windows, then created partitions 3 and 4 (no partition 2 in between). I should have created partition 2 at that time but Linux did not complain and I left that open until I needed partition 2. Later when I ran Windows7 repair from the repair USB, Windows7 Repair renumbered the partitions from 1 3 4 to 1 2 3. After that Linux did not boot since /sdb4 had become /sdb3 and I did not notice. Then I started making mistakes when correcting 'fstab' and that was the problem. Sorry about this. I add this just for the record in case someone else falls in the same trap. I boot with GRUB2 instead of LILO.

All times are GMT -5. The time now is 01:50 AM.