-   Slackware (
-   -   boot errors with udev on slack 12 (

quiescere 08-08-2008 12:14 PM

boot errors with udev on slack 12
After a relatively long period of uptime, I just updated my kernel to 2.6.26. I don't know if the kernel upgrade triggered this, or some patched package I had applied since my last boot was the culprit. Regardless:

On rebooting, I saw a massive list of errors relating to udev. Many complained of not being able to create symlinks in /dev because the files already existed. Deleting the listed devices and allowing udev to create its files and symlinks on the next boot solved some of the errors. Now I'm left with a handful of errors I cannot seem to eliminate.

Before udevd starts, there are a handful of cp errors, something like:
cp: create file /dev/stderr: Read-only file system.

Udev starts, then there are a bunch more errors that look something like
udevd[1061]: mkdir: cannot create /dev/.udev/queue: Read-only file system
udevd[1061]: rmdir: cannot remove /dev/.udev/failed: Read-only file system

over and over again. (The above errors are not exact. Neither dmesg nor syslog show them. If anyone really needs them letter-perfect, let me know and I'll write them down by hand.)

I tried booting with the root partition read-write, and I did not receive those errors, but they resurfaced when I started booting normally. Anyone experience this, or know the proper way to fix the problem?


stress_junkie 08-09-2008 09:51 PM

If the system is running okay once it starts up then I would just ignore the error messages. I get a short list of errors from udev related to being unable to find the tape group. I don't have a tape device on the computer so the errors don't affect anything. This is one situation where "If it works don't fix it" applies.

quiescere 09-03-2008 12:05 AM


If the system is running okay once it starts up then I would just ignore the error messages.
Well, that's no longer true. I don't reboot my laptop often, so it just started, but now there's an endless loop of these messages. I circumvented the problem temporarily by booting with root rw, but that's a temporary solution. I would love to know WHY I am getting these errors, and by extension, how to fix them.

All times are GMT -5. The time now is 08:29 AM.