LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   Bluetooth Xbox One controller problem (https://www.linuxquestions.org/questions/slackware-14/bluetooth-xbox-one-controller-problem-4175649866/)

TarFile 03-09-2019 11:49 AM

Bluetooth Xbox One controller problem
 
I could not get it to connect until I issued this command

echo 1 > /sys/module/bluetooth/parameters/disable_ertm

It worked fine before what is ertm ? (Enhanced Re-Transmission Mode) Well whatever that is. It apparently causes problems for the Xbox One controllers so it needs to be disabled.

How do I set this on boot?

It took two days to figure this out, what a pain.

Any ideas?

Ztcoracat 03-09-2019 01:55 PM

If you are using Retropie here's the fix:

https://techwiztime.com/guide/retrop...ne-controller/

Maybe write a script or create a configuration file to disable the module that is responsible for running ERTM.
I'm not a developer so I can't tell you what the strings in the script should be, sorry.

FWIW I had to consistently run a command on my laptop in order to get the keyboard to light up running Mint.
If I didn't run that command as root the keyboard wouldn't work. I creating a file with strings to make it run at boot time but couldn't find enough information to make it run.

Maybe there is a way to blacklist it? <guessing>
https://padovan.org/blog/tag/enhance...smission-mode/

dugan 03-09-2019 02:09 PM

In /etc/modprobe.d/xbox-one-s.conf
Code:

options bluetooth disable_ertm=1

Ztcoracat 03-09-2019 02:17 PM

Quote:

Originally Posted by dugan (Post 5972142)
In /etc/modprobe.d/xbox-one-s.conf
Code:

options bluetooth disable_ertm=1

Can the modprobe.d.conf be used in most cases to disable a lot of things?

TarFile 03-09-2019 03:38 PM

Thanks dugan that did the trick. I had just put the

echo 1 > /sys/module/bluetooth/parameters/disable_ertm

at the end of rc.bluetooth but that seemed more of a kludge that a fix.


All times are GMT -5. The time now is 07:36 AM.