LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 10-15-2016, 08:53 AM   #1
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Slackware 14.2 / Slackware 14.2 current / Manjaro / Parrot
Posts: 6,879

Rep: Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393
Bluetooth works in root but not user


I'm in root right now, I was in user, but I jumped over to root to be sure. I see that my Bluetooth icon is in the Notification area, and is showing. both in KDE and XFCE4, but it is not in user. So I know it is setup to start up and all.

Just how do I add users to the bluetooth, I've already added the bluetooth group and added myself to it, logged out , logged in and still nothing.

thanks
 
Old 10-15-2016, 09:02 AM   #2
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 4,422

Rep: Reputation: 2348Reputation: 2348Reputation: 2348Reputation: 2348Reputation: 2348Reputation: 2348Reputation: 2348Reputation: 2348Reputation: 2348Reputation: 2348Reputation: 2348
http://docs.slackware.com/slackbook:...ers_and_groups

the group that adduser suggests you by default in slackware 14.2 are
Code:
audio cdrom floppy plugdev video power netdev lp scanner
if you want to add your existing user to them you can use gpasswd, like
Code:
gpasswd -a youruser yourgroup
once your user will be in those groups and you have logged out and logged in again bluetooth should work fine: maybe plugdev and lp are enough, but I would add your user to all of them if you are using a desktop environment.

the "bluetooth" group is not used at all.

Last edited by ponce; 10-15-2016 at 09:05 AM.
 
4 members found this post helpful.
Old 10-15-2016, 09:05 AM   #3
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Slackware 14.2 / Slackware 14.2 current / Manjaro / Parrot
Posts: 6,879

Original Poster
Rep: Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393
Quote:
Originally Posted by ponce View Post
http://docs.slackware.com/slackbook:...ers_and_groups

the group that adduser suggests you by default in slackware 14.2 are
Code:
audio cdrom floppy plugdev video power netdev lp scanner
if you want to add your existing user to them you can use gpasswd, like
Code:
gpasswd -a youruser yourgroup
once your user will be in those groups and you have logged out and logged in again bluetooth should work fine: maybe plugdev and lp are enough, but I would add your user to all of them if you are using a desktop environment.
sssooo adding myself to all of them groups will activate bluetooth in my user account? I don't see how. Their is not one group in that list that even suggest it is for bluetooth.

plugdev is for usb stuff and lp is for cups / printers ...audio has nothing to do with it, cdrom, Floppy diffidently is old, they don;t even make floppies any more, video nope, netdev I hardly think so, scanner diffidently not.
Code:
userx@SlackDaddy & ~ >> $cat /etc/group | grep userx
users:x:100:userx
userx:x:1000:userx
bluetooth:x:1001:userx
those are my groups I belong to. the other groups that you suggested are just that, suggested groups, not a necessity.
thanks but nope .. next

Last edited by BW-userx; 10-15-2016 at 09:20 AM.
 
Old 10-15-2016, 09:06 AM   #4
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 4,422

Rep: Reputation: 2348Reputation: 2348Reputation: 2348Reputation: 2348Reputation: 2348Reputation: 2348Reputation: 2348Reputation: 2348Reputation: 2348Reputation: 2348Reputation: 2348
Quote:
Originally Posted by BW-userx View Post
sssooo adding myself to all of them groups will activate bluetooth in my user account? I don't see how.
nobody forces you to do it.
good luck.
 
Old 10-15-2016, 09:22 AM   #5
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Slackware 14.2 / Slackware 14.2 current / Manjaro / Parrot
Posts: 6,879

Original Poster
Rep: Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393
Quote:
Originally Posted by ponce View Post
nobody forces you to do it.
good luck.
sidetracking 10 points...

I was just stating facts.

furthermore, they do not have anything to do with Bluetooth. the names show that, else I'd of already added myself to them.

Last edited by BW-userx; 10-15-2016 at 09:29 AM.
 
Old 10-15-2016, 09:33 AM   #6
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Slackware 14.2 / Slackware 14.2 current / Manjaro / Parrot
Posts: 6,879

Original Poster
Rep: Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393
Code:
root@SlackDaddy & userx >> $/etc/rc.d/rc.bluetooth restart
Starting Bluetooth services:  bluetoothd hciconfig sdptool hciattach
Code:
root@SlackDaddy & userx >> $rfkill list all
0: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no
1: hp-wifi: Wireless LAN
	Soft blocked: no
	Hard blocked: no
2: hp-bluetooth: Bluetooth
	Soft blocked: no
	Hard blocked: no
3: hci0: Bluetooth
	Soft blocked: no
	Hard blocked: no
Code:
root@SlackDaddy & userx >> $dmesg | grep -i blue
[    7.209079] Bluetooth: Core ver 2.21
[    7.209566] Bluetooth: HCI device and connection manager initialized
[    7.209778] Bluetooth: HCI socket layer initialized
[    7.209990] Bluetooth: L2CAP socket layer initialized
[    7.210221] Bluetooth: SCO socket layer initialized
[   13.502283] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[   13.502287] Bluetooth: BNEP filters: protocol multicast
[   13.502291] Bluetooth: BNEP socket layer initialized
[ 1256.122837] Bluetooth: RFCOMM TTY layer initialized
[ 1256.122844] Bluetooth: RFCOMM socket layer initialized
[ 1256.122849] Bluetooth: RFCOMM ver 1.11
Code:
root@SlackDaddy & userx >> $hcitool dev
Devices:
	hci0	40:2C:F4:18:37:56
 
Old 10-15-2016, 11:05 AM   #7
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Slackware 14.2 / Slackware 14.2 current / Manjaro / Parrot
Posts: 6,879

Original Poster
Rep: Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393
ading all of them groups didnt work, it works in KDE root just not XFCE4 user haven't check KDE user because I am DL'ing can't log out .. :P
 
Old 10-15-2016, 12:45 PM   #8
drgibbon
Member
 
Registered: Nov 2014
Distribution: Slackware64 14.2
Posts: 412

Rep: Reputation: 235Reputation: 235Reputation: 235
Quote:
Originally Posted by BW-userx View Post
sssooo adding myself to all of them groups will activate bluetooth in my user account? I don't see how. Their is not one group in that list that even suggest it is for bluetooth.
Code:
userx@SlackDaddy & ~ >> $cat /etc/group | grep userx
users:x:100:userx
userx:x:1000:userx
bluetooth:x:1001:userx
those are my groups I belong to. the other groups that you suggested are just that, suggested groups, not a necessity.
thanks but nope .. next
There is no point creating a "bluetooth" group because Slackware doesn't use it. If you want less hassles, you should add your user to the default Slackware groups. When creating a new user with adduser, you should press the "up arrow" when prompted and add the groups that are recommended (unless you really know what you're doing). But anyway, since you didn't do it, you can add them this way (as root);

Code:
usermod -a -G audio,cdrom,floppy,plugdev,video,power,netdev,lp,scanner userx
You can check the groups that your user is in with the simple groups command (or groups username). Then you need to make sure that "blueman-applet" is running on startup (for XFCE4 or whatever you use). It should automatically start, but if not, try that command from a terminal and see if it works.

One last thing, there's no need to cat files into grep Just;
Code:
grep userx /etc/group
will do. But simply 'groups' is enough.
 
Old 10-15-2016, 01:12 PM   #9
luvr
Member
 
Registered: May 2005
Location: Boom - The Home Town of Tomorrowland, Belgium
Distribution: Slackware, Debian, Xubuntu
Posts: 192
Blog Entries: 1

Rep: Reputation: 83
Quote:
Originally Posted by BW-userx View Post
I see that my Bluetooth icon is in the Notification area, and is showing. both in KDE and XFCE4, but it is not in user. So I know it is setup to start up and all.
Perhaps it's simply a matter of making the Bluetooth icon appear in the notification area for your user session? I mean, just because the icon is missing, doesn't mean that Bluetooth isn't active.

The first place where I would look is the session startup. Under XFCE, open "Settings" -> "Session and Startup", and select the "Application Autostart" tab. Check if, under root, there is some kind of Bluetooth management applet getting started. If so, then ensure that it is also started under your user session. (Under KDE, I guess there must be some kind of similar feature available.)

The issue may be something else entirely, but this would be my first suggestion.
 
Old 10-15-2016, 01:24 PM   #10
bassmadrigal
LQ Guru
 
Registered: Nov 2003
Location: West Jordan, UT, USA
Distribution: Slackware
Posts: 5,362

Rep: Reputation: 3113Reputation: 3113Reputation: 3113Reputation: 3113Reputation: 3113Reputation: 3113Reputation: 3113Reputation: 3113Reputation: 3113Reputation: 3113Reputation: 3113
Quote:
Originally Posted by BW-userx View Post
plugdev is for usb stuff and lp is for cups / printers ...audio has nothing to do with it, cdrom, Floppy diffidently is old, they don;t even make floppies any more, video nope, netdev I hardly think so, scanner diffidently not.
You really should take the advice of knowledgeable people like ponce. He is an extremely knowledgeable Slacker and you'd be wise to head any advice he gives. I'm not sure plugdev is needed directly for bluetooth usage (but it might possibly be needed to be able to control usb-based devices), but based on the contents of /etc/dbus-1/system.d/bluetooth.conf, you should have lp in your user's group list to be able to use the bluetooth system. If you have complaints about how the lp group is being used, they should be directed at the BlueZ developers, since they're the ones who specified that (see the source).

Quote:
<!-- allow users of lp group (printing subsystem) to
communicate with bluetoothd -->
<policy group="lp">
<allow send_destination="org.bluez"/>
</policy>
All the groups ponce mentioned are groups that Pat mentions that should be used for a user. That's why it's part of the adduser script. Not being a member of those groups can cause a lot of issues and can prevent some subsystems from working as expected.

Once you're a member of the suggested groups, try running hcitool dev to see if it is working properly. This can help us determine if it's still a configuration problem of the system or an XFCE (and possibly KDE) issue.
 
1 members found this post helpful.
Old 10-15-2016, 03:26 PM   #11
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Slackware 14.2 / Slackware 14.2 current / Manjaro / Parrot
Posts: 6,879

Original Poster
Rep: Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393
Quote:
Originally Posted by drgibbon View Post
There is no point creating a "bluetooth" group because Slackware doesn't use it. If you want less hassles, you should add your user to the default Slackware groups. When creating a new user with adduser, you should press the "up arrow" when prompted and add the groups that are recommended (unless you really know what you're doing). But anyway, since you didn't do it, you can add them this way (as root);

Code:
usermod -a -G audio,cdrom,floppy,plugdev,video,power,netdev,lp,scanner userx
You can check the groups that your user is in with the simple groups command (or groups username). Then you need to make sure that "blueman-applet" is running on startup (for XFCE4 or whatever you use). It should automatically start, but if not, try that command from a terminal and see if it works.

One last thing, there's no need to cat files into grep Just;
Code:
grep userx /etc/group
will do. But simply 'groups' is enough.
that was before I added them look at the posting order hello..

i just cat group so I can see all of them .. ............

Last edited by BW-userx; 10-15-2016 at 04:04 PM.
 
Old 10-15-2016, 03:33 PM   #12
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Slackware 14.2 / Slackware 14.2 current / Manjaro / Parrot
Posts: 6,879

Original Poster
Rep: Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393
Quote:
Originally Posted by luvr View Post
Perhaps it's simply a matter of making the Bluetooth icon appear in the notification area for your user session? I mean, just because the icon is missing, doesn't mean that Bluetooth isn't active.

The first place where I would look is the session startup. Under XFCE, open "Settings" -> "Session and Startup", and select the "Application Autostart" tab. Check if, under root, there is some kind of Bluetooth management applet getting started. If so, then ensure that it is also started under your user session. (Under KDE, I guess there must be some kind of similar feature available.)

The issue may be something else entirely, but this would be my first suggestion.
I looked at startup oin setting it is already checked to start, I looked in the Notification area properties. it is showing an applet without an icon. Suggesting that it is started in my session but when I go into the menu listings and select Bluetooth managers, or Bluetooth adapters I get nothing.

with that Bluetooth group I get a message about bluez not being started when I start up bluetooth.

Code:
userx@SlackDaddy & ~ >> $blueman-applet
blueman-applet version 2.0.4 starting
_________
Load (/usr/lib64/python2.7/site-packages/blueman/main/PluginManager.py:60)
['KillSwitch', 'NMPANSupport', 'SerialManager', 'PPPSupport', 'ShowConnected', 'NetUsage', 'AuthAgent', 'GameControllerWakelock', 'ExitItem', 'TransferService', 'DhcpClient', 'Networking', 'StandardItems', 'Headset', 'NMDUNSupport', 'PowerManager', 'Menu', 'DiscvManager', 'StatusIcon', 'DBusService', 'RecentConns'] 
ERROR:dbus.proxies:Introspect error on :1.191:/: dbus.exceptions.DBusException: org.freedesktop.DBus.Error.AccessDenied: Rejected send message, 2 matched rules; type="method_call", sender=":1.248" (uid=1000 pid=17597 comm="/usr/bin/python2.7 /usr/bin/blueman-applet ") interface="org.freedesktop.DBus.Introspectable" member="Introspect" error name="(unset)" requested_reply="0" destination=":1.191" (uid=0 pid=6079 comm="/usr/sbin/bluetoothd ")
Traceback (most recent call last):
  File "/usr/bin/blueman-applet", line 121, in <module>
    BluemanApplet()
  File "/usr/bin/blueman-applet", line 63, in __init__
    self.Plugins.Load()
  File "/usr/lib64/python2.7/site-packages/blueman/main/PluginManager.py", line 90, in Load
    __import__(self.module_path.__name__ + ".%s" % plugin, None, None, [])
  File "/usr/lib64/python2.7/site-packages/blueman/plugins/applet/AuthAgent.py", line 9, in <module>
    import blueman.main.applet.BluezAgent as BluezAgent
  File "/usr/lib64/python2.7/site-packages/blueman/main/applet/BluezAgent.py", line 23, in <module>
    from blueman.bluez.Agent import Agent, AgentMethod
  File "/usr/lib64/python2.7/site-packages/blueman/bluez/Agent.py", line 48, in <module>
    class Agent(dbus.service.Object):
  File "/usr/lib64/python2.7/site-packages/blueman/bluez/Agent.py", line 56, in Agent
    @AgentMethod
  File "/usr/lib64/python2.7/site-packages/blueman/bluez/Agent.py", line 38, in AgentMethod
    if BlueZInterface.get_interface_version()[0] < 5:
  File "/usr/lib64/python2.7/site-packages/blueman/bluez/BlueZInterface.py", line 17, in get_interface_version
    introspection = dbus.Interface(obj, 'org.freedesktop.DBus.Introspectable').Introspect()
  File "/usr/lib64/python2.7/site-packages/dbus/proxies.py", line 70, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib64/python2.7/site-packages/dbus/proxies.py", line 145, in __call__
    **keywords)
  File "/usr/lib64/python2.7/site-packages/dbus/connection.py", line 651, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.AccessDenied: Rejected send message, 2 matched rules; type="method_call", sender=":1.248" (uid=1000 pid=17597 comm="/usr/bin/python2.7 /usr/bin/blueman-applet ") interface="org.freedesktop.DBus.Introspectable" member="Introspect" error name="(unset)" requested_reply="0" destination=":1.191" (uid=0 pid=6079 comm="/usr/sbin/bluetoothd ")
then I found "blueDevil" in my internet menu so I clicked it . then it popped up an icon into my Notifications area but it says it is turned off. and clicking the turn on Bluetooth is not making it work ..

Last edited by BW-userx; 10-15-2016 at 03:39 PM.
 
Old 10-15-2016, 03:56 PM   #13
drgibbon
Member
 
Registered: Nov 2014
Distribution: Slackware64 14.2
Posts: 412

Rep: Reputation: 235Reputation: 235Reputation: 235
Quote:
Originally Posted by BW-userx View Post
that was before I added them look at the posting order hello..
Hello! And give the attitude a rest please
 
Old 10-15-2016, 03:57 PM   #14
Richard Cranium
Senior Member
 
Registered: Apr 2009
Location: Carrollton, Texas
Distribution: Slackware64 14.2
Posts: 3,036

Rep: Reputation: 1409Reputation: 1409Reputation: 1409Reputation: 1409Reputation: 1409Reputation: 1409Reputation: 1409Reputation: 1409Reputation: 1409Reputation: 1409
Quote:
Originally Posted by BW-userx View Post
ading all of them groups didnt work, it works in KDE root just not XFCE4 user haven't check KDE user because I am DL'ing can't log out .. :P
If you didn't log out, the new groups aren't applied to your current environment.
 
Old 10-15-2016, 04:05 PM   #15
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Slackware 14.2 / Slackware 14.2 current / Manjaro / Parrot
Posts: 6,879

Original Poster
Rep: Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393
Quote:
Originally Posted by drgibbon View Post
Hello! And give the attitude a rest please
hello ... pointing out facts ... hello ........
 
  


Reply

Tags
bluetoothd


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] DBD::ODBC works as root but not as non-root user on CentOS5 - any ideas? prgupta Red Hat 2 07-13-2010 12:20 AM
Gnome Bluetooth applet in Lenny: root user vs. ordinary user SuSE_Lamer Linux - Desktop 1 03-20-2009 05:41 AM
Gnome Bluetooth applet in Lenny: root user vs. ordinary user SuSE_Lamer Debian 1 02-25-2009 01:30 AM
IntelliMouse thumb buttons work as root, broken as non-root user, wheel works always digital vortex Linux - Hardware 7 03-02-2004 04:14 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 03:26 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration