LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 03-31-2017, 12:49 PM   #16
limpingstone
Member
 
Registered: Mar 2017
Location: Mountain Time Area
Distribution: Slackware64 14.2
Posts: 52

Original Poster
Rep: Reputation: Disabled

Quote:
Originally Posted by BW-userx View Post
check your desktop file and if you have to put the absolute path to the executable in the TryExec and Exec=/usr/bin/executable <-- like that. you could even try using the other desktop file for the other executable -- the main thing is letting the system start it and not you in the cli. it got a go through the proper channels it is after all a root permissions needed to run properly like the wifi and network connections.

This is all taken care of via (what should I call it?) the executable chain of command the polkit and other needed files that give out permissions for things like this.
Ha! I even tried copying the .desktop file to ~/.kde/Autostart and still nothing shows up starting KDE.
I think there might be something that is preventing the system from executing the files in all the startup folders.
I only remembered that I dealt with the rfkill problem earlier on, but I hope I didn't switch off anything during the process.

Also, I executed the .desktop file and it only showed me a list of "command not found"s.
That's why I am also wondering if the file itself is valid.

Last edited by limpingstone; 03-31-2017 at 01:11 PM.
 
Old 03-31-2017, 12:57 PM   #17
limpingstone
Member
 
Registered: Mar 2017
Location: Mountain Time Area
Distribution: Slackware64 14.2
Posts: 52

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by BW-userx View Post
check your desktop file and if you have to put the absolute path to the executable in the TryExec and Exec=/usr/bin/executable <-- like that . you could even try using the other desktop file for the other executable -- the main thing is letting the system start it and not you in the cli. it got a go through the proper channels it is after all a root permissions needed to run properly like the wifi and network connections.

This is all taken care of via (what should I call it?) the executable chain of command the polkit and other needed files that give out permissions for things like this.
I did not get the part about the executive path in the first place sorry!
I'll check the .desktop file first.

Last edited by limpingstone; 03-31-2017 at 01:12 PM.
 
Old 03-31-2017, 01:25 PM   #18
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Slackware 14.2 / Slackware 14.2 current / Manjaro
Posts: 6,440

Rep: Reputation: 1277Reputation: 1277Reputation: 1277Reputation: 1277Reputation: 1277Reputation: 1277Reputation: 1277Reputation: 1277Reputation: 1277
check off list:
1. check rfkill to be sure no block status
2. check autostart directory to ensure desktop file for pkg is there
3. check cli execute app to see if errors occurs.

you say it says command not found.

check PATH
echo $PATH

if not in path then export $PATH
Code:
export PATH=/path/to/executable:$PATH
if no go then try reinstall pkg repeat command line to check for errors.

Last edited by BW-userx; 03-31-2017 at 01:27 PM.
 
Old 03-31-2017, 03:07 PM   #19
limpingstone
Member
 
Registered: Mar 2017
Location: Mountain Time Area
Distribution: Slackware64 14.2
Posts: 52

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by BW-userx View Post
check off list:
1. check rfkill to be sure no block status
2. check autostart directory to ensure desktop file for pkg is there
3. check cli execute app to see if errors occurs.

you say it says command not found.

check PATH
echo $PATH

if not in path then export $PATH
Code:
export PATH=/path/to/executable:$PATH
if no go then try reinstall pkg repeat command line to check for errors.
I don't think the package is installed incorrectly for it is all good on root.
I turned on system activity monitor and found both the blueman-manager and blueman-applet working and occupies a certain amount of ram. They're there. It's just that it won't show up in the system tray and won't launch when KDE is started.
 
Old 03-31-2017, 05:27 PM   #20
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Slackware 14.2 / Slackware 14.2 current / Manjaro
Posts: 6,440

Rep: Reputation: 1277Reputation: 1277Reputation: 1277Reputation: 1277Reputation: 1277Reputation: 1277Reputation: 1277Reputation: 1277Reputation: 1277
Quote:
Originally Posted by limpingstone View Post
I don't think the package is installed incorrectly for it is all good on root.
I turned on system activity monitor and found both the blueman-manager and blueman-applet working and occupies a certain amount of ram. They're there. It's just that it won't show up in the system tray and won't launch when KDE is started.
f'in KDE -- have you tried a different WM in user to see if you can get it to work in that one instead? like are you startx or GUI login?

xwmconfig to change WM

xfce4 should load it --- if not check

/etc/xdg/autostart for that desktop file.
 
Old 03-31-2017, 05:43 PM   #21
bassmadrigal
LQ Guru
 
Registered: Nov 2003
Location: West Jordan, UT, USA
Distribution: Slackware
Posts: 5,209

Rep: Reputation: 2985Reputation: 2985Reputation: 2985Reputation: 2985Reputation: 2985Reputation: 2985Reputation: 2985Reputation: 2985Reputation: 2985Reputation: 2985Reputation: 2985
If KDE isn't loading it, it is likely other WMs won't load it either. It just reads what's in the .desktop file, so if one WM uses that .desktop and doesn't open it, then it is likely another one won't either.

@OP, let's backtrack a little. Do you have /etc/rc.d/rc.bluetooth executable and is it started currently? Do you get any output with the command hcitool dev listing the bluetooth devices?

Let's make sure it is working for your user in the commandline before we start troubleshooting the GUIs. If it isn't working in the commandline, it is highly unlikely it would work in the GUI.
 
Old 03-31-2017, 07:35 PM   #22
limpingstone
Member
 
Registered: Mar 2017
Location: Mountain Time Area
Distribution: Slackware64 14.2
Posts: 52

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by bassmadrigal View Post
If KDE isn't loading it, it is likely other WMs won't load it either. It just reads what's in the .desktop file, so if one WM uses that .desktop and doesn't open it, then it is likely another one won't either.

@OP, let's backtrack a little. Do you have /etc/rc.d/rc.bluetooth executable and is it started currently? Do you get any output with the command hcitool dev listing the bluetooth devices?

Let's make sure it is working for your user in the commandline before we start troubleshooting the GUIs. If it isn't working in the commandline, it is highly unlikely it would work in the GUI.
Code:
bash-4.3$ /etc/rc.d/rc.bluetooth start
Starting Bluetooth services:  bluetoothd hciconfig sdptool hciattach
D-Bus setup failed: Connection ":1.203" is not allowed to own the service "org.bluez" due to security policies in the configuration file
Code:
bash-4.3$ sudo /etc/rc.d/rc.bluetooth start
Starting Bluetooth services:  bluetoothd hciconfig sdptool hciattach
D-Bus setup failed: Name already in use
I got these two lines, and I believe it is running as shown in the screenshot of "Monitor Activity."

As for hcitool dev, I got this response:
Code:
bash-4.3$ hcitool dev
Devices:
        hci0    74:DF:BF:4C:01:B8
Attached Thumbnails
Click image for larger version

Name:	快照5.png
Views:	9
Size:	15.2 KB
ID:	24650  
 
Old 03-31-2017, 07:39 PM   #23
limpingstone
Member
 
Registered: Mar 2017
Location: Mountain Time Area
Distribution: Slackware64 14.2
Posts: 52

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by BW-userx View Post
f'in KDE -- have you tried a different WM in user to see if you can get it to work in that one instead? like are you startx or GUI login?

xwmconfig to change WM

xfce4 should load it --- if not check

/etc/xdg/autostart for that desktop file.
In fact, I only have KDE 4 installed at the moment.
I am not sure if running XFCE would enable bluetooth to run at startup.
I tried launching the blueman-manager in text mode before logging in, but still, no luck. :P
 
Old 03-31-2017, 10:46 PM   #24
bassmadrigal
LQ Guru
 
Registered: Nov 2003
Location: West Jordan, UT, USA
Distribution: Slackware
Posts: 5,209

Rep: Reputation: 2985Reputation: 2985Reputation: 2985Reputation: 2985Reputation: 2985Reputation: 2985Reputation: 2985Reputation: 2985Reputation: 2985Reputation: 2985Reputation: 2985
Can you now try hcitool scan to see if it can scan for external devices?

If this works, then it likely means that bluetooth is working fine for your user, and then we can work on diagnosing the GUI aspect.

Quote:
Originally Posted by limpingstone View Post
In fact, I only have KDE 4 installed at the moment.
Does that mean you did a partial installation? If so, what all did you leave out?
 
1 members found this post helpful.
Old 03-31-2017, 10:57 PM   #25
limpingstone
Member
 
Registered: Mar 2017
Location: Mountain Time Area
Distribution: Slackware64 14.2
Posts: 52

Original Poster
Rep: Reputation: Disabled
Unhappy

Quote:
Originally Posted by bassmadrigal View Post
Can you now try hcitool scan to see if it can scan for external devices?

If this works, then it likely means that bluetooth is working fine for your user, and then we can work on diagnosing the GUI aspect.



Does that mean you did a partial installation? If so, what all did you leave out?
Well, out of luck :/ Nothing comes up... (force smile

Code:
bash-4.3$ hcitool scan
Scanning ...
bash-4.3$ 
bash-4.3$ sudo hcitool scan
Password: 
Scanning ...
I only left out XFCE during installation because I'm used to KDE. I don't suppose it includes some necessary bluetooth drivers or applets?
 
Old 03-31-2017, 11:25 PM   #26
Richard Cranium
Senior Member
 
Registered: Apr 2009
Location: Carrollton, Texas
Distribution: Slackware64 14.2
Posts: 3,000

Rep: Reputation: 1374Reputation: 1374Reputation: 1374Reputation: 1374Reputation: 1374Reputation: 1374Reputation: 1374Reputation: 1374Reputation: 1374Reputation: 1374
Try
Code:
bluetoothctl
and tell us what that outputs.
 
2 members found this post helpful.
Old 03-31-2017, 11:33 PM   #27
limpingstone
Member
 
Registered: Mar 2017
Location: Mountain Time Area
Distribution: Slackware64 14.2
Posts: 52

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Richard Cranium View Post
Try
Code:
bluetoothctl
and tell us what that outputs.
Code:
bash-4.3$ bluetoothctl
[bluetooth]# quit
bash-4.3$ sudo bluetoothctl
Password: 
[NEW] Controller 74:DF:BF:4C:01:B8 BlueZ 5.40 [default]
[NEW] Device F8:0B:7F:2B:36:B7 Flex
[NEW] Device 90:72:40:E5:D4:D1 iPhone 
[NEW] Device 1C:52:16:39:E0:5F IC-BTH02
[bluetooth]#
Looks good with sudo but not without.
The devices are what I connected earlier logging in as root.
Should I type in anything yet?

Last edited by limpingstone; 03-31-2017 at 11:35 PM.
 
Old 04-01-2017, 01:06 AM   #28
Richard Cranium
Senior Member
 
Registered: Apr 2009
Location: Carrollton, Texas
Distribution: Slackware64 14.2
Posts: 3,000

Rep: Reputation: 1374Reputation: 1374Reputation: 1374Reputation: 1374Reputation: 1374Reputation: 1374Reputation: 1374Reputation: 1374Reputation: 1374Reputation: 1374
What's the output of
Code:
groups
command when run as your normal user?
 
1 members found this post helpful.
Old 04-01-2017, 01:08 AM   #29
limpingstone
Member
 
Registered: Mar 2017
Location: Mountain Time Area
Distribution: Slackware64 14.2
Posts: 52

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Richard Cranium View Post
What's the output of
Code:
groups
command when run as your normal user?
Code:
bash-4.3$ groups
users lp wheel floppy audio video cdrom plugdev power netdev scanner
I added wheel, plugdev, and power earlier in the thread.
 
Old 04-01-2017, 10:29 AM   #30
Richard Cranium
Senior Member
 
Registered: Apr 2009
Location: Carrollton, Texas
Distribution: Slackware64 14.2
Posts: 3,000

Rep: Reputation: 1374Reputation: 1374Reputation: 1374Reputation: 1374Reputation: 1374Reputation: 1374Reputation: 1374Reputation: 1374Reputation: 1374Reputation: 1374
OK, do you see...
Code:
  <!-- allow users of lp group (printing subsystem) to 
       communicate with bluetoothd -->
  <policy group="lp">
    <allow send_destination="org.bluez"/>
  </policy>
...in /etc/dbus-1/system.d/bluetooth.conf?
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Bluetooth works in root but not user BW-userx Slackware 81 06-14-2018 10:43 PM
[SOLVED] bluetooth headset works only on root husarz Slackware 5 12-27-2016 05:40 PM
Bluetooth Is Not Working Ashish Sood Linux - General 1 08-27-2010 01:55 PM
[SOLVED] Bluetooth is not working shariefbe Linux - Newbie 1 01-29-2010 12:23 AM
Bluetooth not working on FC6 with Targus USB bluetooth adapter mikevicious Linux - Software 1 12-11-2009 09:03 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 07:19 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration