LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 03-30-2017, 04:44 PM   #1
limpingstone
Member
 
Registered: Mar 2017
Location: Mountain Time Area
Distribution: Slackware64 14.2
Posts: 52

Rep: Reputation: Disabled
Bluetooth not working except for root


I am using Slackware64 14.2 pre-installed with blueman-manager (BlueZ).
Bluetooth works absolutely fine with root, but not my own account.
My account does not even start the manager after boot, and I tried to launch the manager manually using 'sudo'. Still, the manager cannot connect to my headset and smartphone, while showing this error message:

Connection Failed: DBusFailedError: Protocol not available

I doubt that it is because of having limited permission to hardware configurations. Any ideas how to solve it?

Thank you!

Last edited by limpingstone; 03-30-2017 at 04:46 PM.
 
Old 03-30-2017, 04:51 PM   #2
Skaendo
Member
 
Registered: Dec 2014
Location: West Texas, USA
Distribution: Slackware64-14.2
Posts: 743

Rep: Reputation: Disabled
Is your user a member of the recommended groups?

This issue has been gone over and over.
Example: https://www.linuxquestions.org/quest...er-4175591462/

Recommended groups are:
Code:
audio cdrom floppy plugdev video power netdev lp scanner
 
1 members found this post helpful.
Old 03-30-2017, 05:12 PM   #3
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Slackware 14.2 / Slackware 14.2 current / Manjaro
Posts: 6,440

Rep: Reputation: 1287Reputation: 1287Reputation: 1287Reputation: 1287Reputation: 1287Reputation: 1287Reputation: 1287Reputation: 1287Reputation: 1287
yep
Code:
userx@slackwhere⚡~ $groups
users lp wheel floppy audio video cdrom plugdev power netdev scanner userx
my Bluetooth works.

and yep that was my post. learn from my mistake . lolololo hehe.

Last edited by BW-userx; 03-30-2017 at 05:13 PM.
 
1 members found this post helpful.
Old 03-30-2017, 06:03 PM   #4
limpingstone
Member
 
Registered: Mar 2017
Location: Mountain Time Area
Distribution: Slackware64 14.2
Posts: 52

Original Poster
Rep: Reputation: Disabled
Nope, it still doesn't work.
And I also got this message trying to connect to my headset: (no sound)

Connection Failed: Traceback (most recent call last):
File "/usr/lib64/python2.7/site-packages/blueman/services/meta/SerialService.py", line 29, in connect
port_id = create_rfcomm_device(Adapter(props['Adapter']).get_properties()['Address'], props['Address'], 1)
File "_blueman.pyx", line 218, in _blueman.create_rfcomm_device (_blueman.c:2127)
Exception: Can't connect RFCOMM socket

It did connect, but there is no sound coming out of the headphone.
BW-userx I noticed the wheel group you have. Is it because of the group you added?

Thanks!
 
Old 03-30-2017, 06:17 PM   #5
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Slackware 14.2 / Slackware 14.2 current / Manjaro
Posts: 6,440

Rep: Reputation: 1287Reputation: 1287Reputation: 1287Reputation: 1287Reputation: 1287Reputation: 1287Reputation: 1287Reputation: 1287Reputation: 1287
Quote:
Originally Posted by limpingstone View Post
Nope, it still doesn't work.
And I also got this message trying to connect to my headset: (no sound)

Connection Failed: Traceback (most recent call last):
File "/usr/lib64/python2.7/site-packages/blueman/services/meta/SerialService.py", line 29, in connect
port_id = create_rfcomm_device(Adapter(props['Adapter']).get_properties()['Address'], props['Address'], 1)
File "_blueman.pyx", line 218, in _blueman.create_rfcomm_device (_blueman.c:2127)
Exception: Can't connect RFCOMM socket

It did connect, but there is no sound coming out of the headphone.
BW-userx I noticed the wheel group you have. Is it because of the group you added?

Thanks!
no I actually I only added wheel to get sudo.
you're using blueman-manager to pair your head set?

then if you get it paired you have to use pavcontrol to change the source to your headset to get sound.

Code:
usermod -aG users,wheel,floppy,audio,video,cdrom,plugdev,power,netdev,lp,scanner
I'd just reboot to keep it simple then try to pair your headset using blueman-manager.

you don't really need wheel I think it was only plugdev audio and maybe netdev that I tried to only add first time i went though this and it worked.

Code:
userx@slackwhere⚡/etc/xdg/autostart $cat blueman.desktop
[Desktop Entry]
Name=Blueman Applet
Name[ast]=Applet Blueman
Comment=Blueman Bluetooth Manager
Icon=blueman
Exec=blueman-applet
Terminal=false
Type=Application
Categories=
that is if it is not showing up in your desktop

Last edited by BW-userx; 03-30-2017 at 06:25 PM.
 
Old 03-30-2017, 06:28 PM   #6
limpingstone
Member
 
Registered: Mar 2017
Location: Mountain Time Area
Distribution: Slackware64 14.2
Posts: 52

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by BW-userx View Post
no I actually I only added wheel to get sudo.
you're using blueman-manager to pair your head set?

then if you get it paired you have to use pavcontrol to change the source to your headset to get sound.
Well weirdly, I found that there are in fact two managers for bluetooth: blueman-manager and the system default manager in settings. I am rather confused which one I should use. And by the way, the one provided by the system seems like it's not even available. Is it another group that I need to add to make it work? For both of them works in root.

Last edited by limpingstone; 03-30-2017 at 06:37 PM.
 
Old 03-30-2017, 06:37 PM   #7
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Slackware 14.2 / Slackware 14.2 current / Manjaro
Posts: 6,440

Rep: Reputation: 1287Reputation: 1287Reputation: 1287Reputation: 1287Reputation: 1287Reputation: 1287Reputation: 1287Reputation: 1287Reputation: 1287
Quote:
Originally Posted by limpingstone View Post
Well weirdly, I found that there are in fact two managers for bluetooth: blueman-manager and the system default manager in settings. I am rather confused which one I should use. And by the way, the one provided by the system seems like it's not even available. Is it another group that I need to add to make it work? For both of them works in root.

Thank you! It's my first time using Slackware and I have many to learn...
what WM are you using and are you getting the apple showing up in the apt tray? whichever one shows up click on it and go though its setup search with your Bluetooth device turned on for discovery. then just follow the prompts.

if you have to copy the one desktop to /etc/xdg/autostart
Code:
userx@slackwhere⚡/etc/xdg/autostart $ls /usr/share/applications/blue*
/usr/share/applications/blueman-adapters.desktop
/usr/share/applications/blueman-manager.desktop
Code:
sudo cp -v /usr/share/applications/blueman-manager.desktop /etc/xdg/autostart
logout and back in again to get it to load.
 
Old 03-30-2017, 07:02 PM   #8
limpingstone
Member
 
Registered: Mar 2017
Location: Mountain Time Area
Distribution: Slackware64 14.2
Posts: 52

Original Poster
Rep: Reputation: Disabled
The default bluetooth manager (藍芽) is not working. And I still have to manually turn on blueman-manager.

Code:
sudo /usr/bin/blueman-manager
https://drive.google.com/file/d/0B5U...ew?usp=sharing

Is that the apple you're talking about?
So I believe I should stick to blueman-manager?

Last edited by limpingstone; 03-30-2017 at 07:04 PM.
 
Old 03-30-2017, 07:15 PM   #9
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Slackware 14.2 / Slackware 14.2 current / Manjaro
Posts: 6,440

Rep: Reputation: 1287Reputation: 1287Reputation: 1287Reputation: 1287Reputation: 1287Reputation: 1287Reputation: 1287Reputation: 1287Reputation: 1287
Quote:
Originally Posted by limpingstone View Post
The default bluetooth manager (藍芽) is not working. And I still have to manually turn on blueman-manager.

Code:
sudo /usr/bin/blueman-manager
https://drive.google.com/file/d/0B5U...ew?usp=sharing

Is that the apple you're talking about?
So I believe I should stick to blueman-manager?
yes applet (typo - not an apple) and do not use the command line to start it. use the desktop file that is prob why it is erroring out on you.

AGAIN
Code:
sudo cp -v /usr/share/applications/blueman-manager.desktop /etc/xdg/autostart
logout then back in again after you've copied it into your xdg/autostart directory.
 
Old 03-30-2017, 08:01 PM   #10
bassmadrigal
LQ Guru
 
Registered: Nov 2003
Location: West Jordan, UT, USA
Distribution: Slackware
Posts: 5,209

Rep: Reputation: 2985Reputation: 2985Reputation: 2985Reputation: 2985Reputation: 2985Reputation: 2985Reputation: 2985Reputation: 2985Reputation: 2985Reputation: 2985Reputation: 2985
What is the output of the groups command for your user?
 
Old 03-30-2017, 08:50 PM   #11
limpingstone
Member
 
Registered: Mar 2017
Location: Mountain Time Area
Distribution: Slackware64 14.2
Posts: 52

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by bassmadrigal View Post
What is the output of the groups command for your user?
users lp wheel floppy audio video cdrom plugdev power netdev scanner

All I should have I believe. LOL
 
Old 03-30-2017, 09:23 PM   #12
limpingstone
Member
 
Registered: Mar 2017
Location: Mountain Time Area
Distribution: Slackware64 14.2
Posts: 52

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by BW-userx View Post
yes applet (typo - not an apple) and do not use the command line to start it. use the desktop file that is prob why it is erroring out on you.

AGAIN
Code:
sudo cp -v /usr/share/applications/blueman-manager.desktop /etc/xdg/autostart
logout then back in again after you've copied it into your xdg/autostart directory.
For some reason, blueman-manager.desktop is not picked up by the system when I login with KDE. That is why I started blueman-manager with Konsole. I even tried "chmod 755 blueman-manager.desktop" to make it executable, and it still does not run.

I tested the .desktop file with Konsole and it just gave me a list of "command not found". Perhaps the .desktop file is corrupted?
 
Old 03-30-2017, 10:00 PM   #13
Richard Cranium
Senior Member
 
Registered: Apr 2009
Location: Carrollton, Texas
Distribution: Slackware64 14.2
Posts: 3,000

Rep: Reputation: 1374Reputation: 1374Reputation: 1374Reputation: 1374Reputation: 1374Reputation: 1374Reputation: 1374Reputation: 1374Reputation: 1374Reputation: 1374
Maybe you should check your normal user's home directory for any files/directories that are owned by root. A sudo with the wrong command can do interesting things to your environment.
 
Old 03-31-2017, 12:21 AM   #14
limpingstone
Member
 
Registered: Mar 2017
Location: Mountain Time Area
Distribution: Slackware64 14.2
Posts: 52

Original Poster
Rep: Reputation: Disabled
I think for now I'll deal with pavcontrol first and see if it works fine.

Thank you for all your answers!
 
Old 03-31-2017, 08:57 AM   #15
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Slackware 14.2 / Slackware 14.2 current / Manjaro
Posts: 6,440

Rep: Reputation: 1287Reputation: 1287Reputation: 1287Reputation: 1287Reputation: 1287Reputation: 1287Reputation: 1287Reputation: 1287Reputation: 1287
Quote:
Originally Posted by limpingstone View Post
For some reason, blueman-manager.desktop is not picked up by the system when I login with KDE. That is why I started blueman-manager with Konsole. I even tried "chmod 755 blueman-manager.desktop" to make it executable, and it still does not run.

I tested the .desktop file with Konsole and it just gave me a list of "command not found". Perhaps the .desktop file is corrupted?
check your desktop file and if you have to put the absolute path to the executable in the TryExec and Exec=/usr/bin/executable <-- like that . you could even try using the other desktop file for the other executable -- the main thing is letting the system start it and not you in the cli. it got a go through the proper channels it is after all a root permissions needed to run properly like the wifi and network connections.

This is all taken care of via (what should I call it?) the executable chain of command the polkit and other needed files that give out permissions for things like this.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Bluetooth works in root but not user BW-userx Slackware 81 06-14-2018 10:43 PM
[SOLVED] bluetooth headset works only on root husarz Slackware 5 12-27-2016 05:40 PM
Bluetooth Is Not Working Ashish Sood Linux - General 1 08-27-2010 01:55 PM
[SOLVED] Bluetooth is not working shariefbe Linux - Newbie 1 01-29-2010 12:23 AM
Bluetooth not working on FC6 with Targus USB bluetooth adapter mikevicious Linux - Software 1 12-11-2009 09:03 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 04:16 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration