-   Slackware (
-   -   Bluetooth mouse issues after upgrading to BlueZ 4 in -current (

cgorac 05-06-2010 08:09 AM

Bluetooth mouse issues after upgrading to BlueZ 4 in -current
Am using Slackware64 -current on a HP EliteBook 8530w, coupled with HP Bluetooth Laser mouse. The mouse worked fine previously with BlueZ 3.x - I had only to run "hidd --search" (with the mouse put in discovery mode) once after installing Slackware, and it would get recognized, and working properly afterward. However, after yesterday upgrade to BlueZ 4.64, an issue started to occur with the mouse: whenever I reboot machine, or restart from suspend or hibernate, or even if I leave mouse unused over some period of time, the mouse get dropped, and then I have to turn it off, and then on again, put it into the discovery mode, and then re-run "hidd --search" in order to have it working again. Now, I tried to find some information on BlueZ site, but it is as un-informative as ever, so I'm wondering does anyone that eventually used BlueZ 4.x know how to have it to remember the mouse permanently, and re-connect when needed?

dolphin77 05-07-2010 09:40 AM

Did not try it from console. But if you installed blueman - it should work with it. I specialy just took an bluetooth mouse from a friend. And it works fine. If you want to do it from console read bluez documentation. it shouldn't be difficult.

cgorac 05-08-2010 12:56 AM

Have to edit this message once again: I've encountered the same problem now after installing Slackware 13.1 from scratch, and I would say the definitive solution is indeed to use blueman-manager, and then to put mouse into discovery mode so that blueman-manager could find it and have it listed in the devices list, and then with the corresponding item in devices list selected, to run "Setup" command (in order to connect the device with Bluetooth input service (skip pairing step, when asked for it), and then "Trust" command - after this, the mouse should just keep working across resume from suspend or hibernation, and after restarting the machine.

All times are GMT -5. The time now is 12:24 PM.