-   Slackware (
-   -   Bluetooth device became permanently down (

Karimo 11-16-2008 09:58 AM

Bluetooth device became permanently down
Hi to all!
Today I've made the usual upgrade with slackpkg at the -current brunch and the bluetooth device stopped working.
I've a Sony Vaio Laptop, it has a bluetooth device (seen as an usb device) that worked perfectly before the upgrade.
I used to launch rc.bluetooth, and a simple inquiry with "hcitool scan" worked perfectly.
Since I've all bluez* packages installed and the correct driver compiled in the kernel (because worked 'till the update) I'm wondering why the device doesn't work anymore.

[Some useful output]


root@station:/home/karimo# . /etc/rc.d/rc.bluetooth restart
Stopping Bluetooth subsystem:  pand dund rfcomm hidd hcid.
Starting Bluetooth subsystem:  hcid sdp rfcomm/usr/lib/bluetooth/register-passkeys: line 20: 30455 Done                    cat "$f"
    30456 Aborted                | $PASSKEY_AGENT --default >/dev/null 2>&1
karimo@station:~$ su
root@station:/home/karimo# hcitool scan
Device is not available: No such device
root@station:/home/karimo# hciconfig
hci0:  Type: USB
        BD Address: 00:00:00:00:00:00 ACL MTU: 0:0 SCO MTU: 0:0
        RX bytes:0 acl:0 sco:0 events:0 errors:0
        TX bytes:0 acl:0 sco:0 commands:0 errors:0

root@station:/home/karimo# lspci
00:00.0 Host bridge: Intel Corporation Mobile 915GM/PM/GMS/910GML Express Processor to DRAM Controller (rev 03)
00:01.0 PCI bridge: Intel Corporation Mobile 915GM/PM Express PCI Express Root Port (rev 03)
00:1b.0 Audio device: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #3 (rev 03)
00:1d.3 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #4 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev d3)
00:1f.0 ISA bridge: Intel Corporation 82801FBM (ICH6M) LPC Interface Bridge (rev 03)
00:1f.1 IDE interface: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) IDE Controller (rev 03)
00:1f.2 IDE interface: Intel Corporation 82801FBM (ICH6M) SATA Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) SMBus Controller (rev 03)
01:00.0 VGA compatible controller: ATI Technologies Inc M24 1P [Radeon Mobility X600]
02:01.0 CardBus bridge: Texas Instruments PCI7420 CardBus Controller
02:01.2 FireWire (IEEE 1394): Texas Instruments PCI7x20 1394a-2000 OHCI Two-Port PHY/Link-Layer Controller
02:01.3 Mass storage controller: Texas Instruments PCI7420/7620 Combo CardBus, 1394a-2000 OHCI and SD/MS-Pro Controller
02:02.0 Network controller: Intel Corporation PRO/Wireless 2200BG Network Connection (rev 05)
02:03.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8169 Gigabit Ethernet (rev 10)

Suggestions to solve this strange problem?
Thank you all very much for any reply.


MS3FGX 11-17-2008 09:07 PM

There is a bit of confusion with BlueZ at the moment, as Pat put BlueZ 4.x out in -current and then retracted it since there is just not enough downstream support to make it viable right now.

So we started with the bluez-libs and bluez-utils packages, then had them removed and replaced with the single bluez-4.17 package, only to get removed and replaced with the original ones. Since you are using an automated package manager, it could be that there was some issue there with the various config files. BlueZ 3.x and BlueZ 4.x are wildly different, so any part remaining of one would almost certainly screw up the other.

I would suggest removing all of the BlueZ packages you currently have, deleting the /etc/bluetooth and /var/lib/bluetooth directories, and then reinstall the latest packages (bluez-libs-3.36-i486-2.tgz and bluez-utils-3.36-i486-4.tgz).

Remember that you will need to re-pair your device again after this.

All times are GMT -5. The time now is 07:01 AM.