LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-16-2013, 12:32 PM   #1
dlachausse
LQ Newbie
 
Registered: May 2012
Distribution: Slackware
Posts: 28

Rep: Reputation: Disabled
Bluetooth (A2DP) headphones in KDE


Is there an easy way to get Bluetooth A2DP headphones working in Slackware 14.0 under KDE?

My bluetooth adapter is Linux compatible and I've gotten it to work under Fedora, but I'd rather use Slackware.
 
Old 01-17-2013, 05:03 PM   #2
guanx
Senior Member
 
Registered: Dec 2008
Posts: 1,014

Rep: Reputation: 145Reputation: 145
Don't know any KDE specific way but taking a look at "/etc/alsa/bluetooth.conf" probably will solve your problem.
 
Old 01-19-2013, 06:03 AM   #3
slacktroll
Member
 
Registered: May 2011
Distribution: Slackware 14.0 on Thinkpad X60
Posts: 56

Rep: Reputation: 3
Quote:
Originally Posted by dlachausse View Post
Is there an easy way to get Bluetooth A2DP headphones working in Slackware 14.0 under KDE?

My bluetooth adapter is Linux compatible and I've gotten it to work under Fedora, but I'd rather use Slackware.
I asked the question myself. Setting up these device with blueman is not hard at all. And they will exist in alsamixer as well.

Programs can often chose output device, and if it can it will work straight away.

But make sure your device actual works in GNU/Linux at all.
 
Old 02-05-2013, 06:56 PM   #4
dlachausse
LQ Newbie
 
Registered: May 2012
Distribution: Slackware
Posts: 28

Original Poster
Rep: Reputation: Disabled
I finally figured this out. Use either Blueman or Bluedevil (KDE's bluetooth applet) to pair your headset.

Then you create a /etc/asound.conf file with the following contents (replace the X's in the device line with your headset's MAC address):

Quote:
pcm.!default{
type bluetooth
device "XX:XX:XX:XX:XX:XX"
}
 
2 members found this post helpful.
Old 02-06-2013, 06:51 AM   #5
guanx
Senior Member
 
Registered: Dec 2008
Posts: 1,014

Rep: Reputation: 145Reputation: 145
Ok. I did not comprehend the word "work" very well. So the question was "How to set bluetooth as ALSA default output device" and not "How to get bluetooth headset usable by ALSA".

Quote:
Originally Posted by slacktroll View Post
... Setting up these device with blueman is not hard at all. ...
Neither is it hard on the command line.
Code:
sh /etc/rc.d/rc.messagebus start
sh /etc/rc.d/rc.buetooth start
hcitool scan
hcitool inq
hcitool cc BTMAC
hcitool auth BTMAC
Tested to work with SonyEricsson MW600. Your milage may very. I remember I got it from Gentoo wiki or Arch wiki (not sure) with a simple search on the Internet.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Debian Squeeze: connect to A2DP (bluetooth) through command line math1985 Linux - Hardware 1 11-12-2012 05:14 PM
[SOLVED] bluetooth dongle with A2DP protocol RedNeck-LQ Linux - Hardware 2 01-21-2011 06:59 PM
Bluez A2DP audio streaming djfuzz Linux - Software 0 08-14-2010 06:21 PM
2 Bluetooth Headphones on 1 Linux System, How ? skate Linux - Software 0 06-17-2008 08:24 AM
Trying to get a2dp device working... niidea Slackware 1 05-18-2008 07:12 AM


All times are GMT -5. The time now is 10:21 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration