-   Slackware (
-   -   Blank screen on Lenovo T420s during boot (

kfritz 01-05-2012 07:39 AM

Blank screen on Lenovo T420s during boot
On a fresh install of 13.37 Slackware64, (dual-boot with Windows 7 for now), the screen goes blank during the boot process.

It is similar to previous threads mentioned here, yet different. Same Intel graphics as link.

The display is black on the left 2/3 and white on the right 1/3. It's not a backlight problem, and booting with "nomodeset" makes the problem go away, but makes X suck. Logging in blind and running startx does not make the problem go away.

If I wait for the screen-blanking timeout, then press a key, I get the console back and everything works.

Any suggestions?

allend 01-05-2012 07:52 AM

Does booting using 'vga=normal' as a boot option make any difference?

kfritz 01-05-2012 08:00 AM

No, that was the first thing I tried but I forgot to mention it above.

allend 01-05-2012 08:33 AM

Apparently you are not alone.

This link seems to suggest that a later kernel may help.

allend 01-05-2012 08:54 AM

Just found another link that discusses the problem.

kfritz 01-05-2012 08:44 PM

Your Google-fu is better than mine! It's unclear to me from the Ubuntu bug what kernel might fix the problem, so I guess I'll try -current, and failing that try a few workarounds like figure out how to make sleep mode "Fn F4" work in console, etc. Thanks!

kfritz 01-06-2012 07:58 AM

I'm marking this as "solved", but I wish LQ had a "worked around" tag. I modified /etc/acpi/ to pm-suspsend when it gets the sleep action, so when it boots, I press Fn F4 to sleep, then press power to wake, and all is good.

Update of kernel from (13.37) to (today's -current) did not fix the issue (and broke my acpi handler, but that's a different topic...).

All times are GMT -5. The time now is 03:45 PM.