-   Slackware (
-   -   black screen on bootup after a few lines (slack 13.37) (

Agni 05-25-2011 03:18 PM

black screen on bootup after a few lines (slack 13.37)

sorry if this has been solved somewhere, i didn't find it...

i just installed slackware 13.37 which worked fine but when i boot it up it runs a number of lines and then the screen just goes black... i can login as root blindly and start x (i THINK, judging from hdd led)... but screen stays black... its a laptop and closing/opening the lid doesnt work either...

i am dualbooting with slack 13.1 which runs fine... it switches screen res at some point during boot (font is smaller) and i would say that is the point where the screen goes black in 13.37...

anyone? :S ...

MS3FGX 05-25-2011 03:53 PM

Well first, this topic is surely more appropriate in the Slackware forum than in Software. Having a moderator move this topic to the proper forum will greatly increase the chances of the issue being resolved quickly.

Second, what exactly are the lines printed right before the screen goes black? That will be useful in determining exactly what part of the boot process is causing the issue.

Tinkster 05-25-2011 04:27 PM

Moved: This thread is more suitable in <SLACKWARE> and has been moved accordingly to help your thread/question get the exposure it deserves.

adamk75 05-25-2011 04:33 PM

What video card? If you pass video=640x480 to the kernel, does it work? If not, how about if you pass nomodeset ?

slack_them_all 05-25-2011 05:33 PM

Have a look at this file

It might tell you what is wrong to load X.

xj25vm 05-26-2011 02:43 AM

Same problem here with Slackware 13.37 on a Packard Bell EasyNote Butterfly XS. I think it might be connected with KMS (Kernel Mode Setting) - as it happens about that time in the boot when it normally switches to the tiny fonts. Still investigating.

Edit: nomodeset does the trick. Thank you.

xj25vm 05-26-2011 02:54 AM

It's strange, but if I pass video=1366x768 to Lilo (which is the native resolution of this laptop) - it conks out again. Life use to be good when the video stuff was left to Xorg.

Agni 05-26-2011 01:11 PM

1 Attachment(s)
thanks for your replies so far (:

nomodeset works around it, but i am now stuck with a 1024x768 X (on a widescreen -.-)

video=anything doesnt help

xorg log is attached (i think?) ... if thats any help (not to me, unfortunately :| )

no idea what the last lines are, its just way too fast

adamk75 05-26-2011 02:48 PM

if you boot without the modeset option, can you remotely login from another machine via ssh? If so, the output of 'dmesg | grep drm' might prove very helpful.


xj25vm 05-27-2011 04:23 AM

1 Attachment(s)
I've attached the dmesg output with no nomodeset in lilo and screen going blank during boot. I hope I haven't left anything out.

I've tried to watch carefully, and I think the last message I've seen on the screen before it went blank was somewhere about second 12.44 of the kernel boot countdown (countup?).

I don't know if there is a connection, but I'm having trouble convincing Xorg to use the intel driver on this computer. Without a configuration file it loads the vesa driver - and refuses to use 1366x768 resolution - it insists on a lower resolution. If I use xorgsetup to create a xorg.conf file, when I try xstart, it errors with "no devices detected" and conks out.



Edit: Added 3 missing words in second sentence above.

adamk75 05-27-2011 04:27 AM

The intel driver requires KMS and since 1366x768 is not a vesa resolution, that's not going to work either.

What I meant when I said "if you boot without the modeset option, can you remotely login from another machine via ssh?" was actually "if you boot without the nomodeset option, can you remotely login from another machine via ssh?" We need to see if the DRM driver throws any errors when you are using KMS.


colorpurple21859 05-27-2011 05:18 AM

Installing and using the 2.6.38 kernel and modules from testing might fix the problem

xj25vm 05-27-2011 07:43 AM


I understand what you meant and that's exactly what I did. I removed nomodeset from lilo - which broke the boot process again. Then started the machine, the screen went black during boot. Left the machine on, sshed from another machine, ran dmesg, saved the output - and attached it to my post above.

adamk75 05-27-2011 08:09 AM

D'oh. Sorry, I didn't understand your post earlier.

Unfortunately, the intel DRM is not very verbose, apparently. I was hoping it would show some comment about not detecting the EDID of your monitor. But, then again, that wouldn't necessarily tell us much anyway.

I think, at this point, you're probably going to have to try a newer/different kernel. You could try the 2.6.38 kernel as colorpurple21859 suggested.


xj25vm 05-27-2011 10:46 AM

I have, what I think is, some interesting follow up. I've discovered that the screen doesn't actually go blank - it only switches the lamps off. In a room with plenty of ambient lightning - I can just about see what is on the screen, both of the boot process, and later of xdm. I can even login. I've tried all the keyboard combinations to see if I can switch the lamps back on - but so far no luck.

All times are GMT -5. The time now is 05:59 PM.