-   Slackware (
-   -   Black screen during boot up after new 2.6.1 kernel (

cjdock 01-18-2004 10:38 PM

Black screen during boot up after new 2.6.1 kernel
I run slackware9.1. I have been using swaret to upgrade my packages, including my kernel. All has been well. I decided to try kernel 2.6.1 and after installing it, when I re-boot I get a black screen but I hear the hard drive running. So I wait a minute and then log on and then startx and then X comes on, the screen lights up correctly! I do see the inital kernel choice menu, I choose the new one and then see that black screen until I log on "in the dark".
What did I do wrong?

leonscape 01-18-2004 10:42 PM

Framebuffer problems probably. You may have the wrong device driver in the kernel for a frame buffer.

Nvidia cards are reported to not like the frame buffers.

_mu_ 01-18-2004 11:20 PM

Im not totally sure but I think I read somewhere that you had to have /dev/pts enabled forthe 2.6 kernels. Just check its in the kernel and whether it has an entry in /etc/fstab. But yeh I think I have read some other post somewhere about this. Hope it works but I could be wrong so just check. :)

The /dev/pts is only for people with devfs so unless you have devfs dont worry about it :)

_mu_ 01-18-2004 11:56 PM

I could be way of with the /dev/pts thing check out this aswell its a good read if your going to the 2.6 kernels.
Its under the "The known gotcha's" where there is something like your problem.

Vincent_Vega 01-19-2004 12:31 AM

I solved this exact problem by enabling VESA in the Console driver/Framebuffer section.

dirstyGuy 01-19-2004 05:12 AM

I've changed too much that I don't know wut responsible for that blank screen:
Previously I enabled many thing but now I even reduce them, n disabled AGP & DRI. But am not sure whether it is that that responsible for ..


# Ftape, the floppy tape device driver
# CONFIG_FTAPE is not set
# CONFIG_AGP is not set
# CONFIG_DRM is not set

# Graphics support
# CONFIG_FB_CYBER2000 is not set
# CONFIG_FB_IMSTT is not set
# CONFIG_FB_VGA16 is not set
# CONFIG_FB_HGA is not set
# CONFIG_FB_RIVA is not set
# CONFIG_FB_MATROX is not set
# CONFIG_FB_RADEON is not set
# CONFIG_FB_ATY128 is not set
# CONFIG_FB_ATY is not set
# CONFIG_FB_SIS is not set
# CONFIG_FB_3DFX is not set
# CONFIG_FB_VOODOO1 is not set
# CONFIG_FB_TRIDENT is not set

# Console display driver support
# CONFIG_FONT_6x11 is not set
# CONFIG_FONT_PEARL_8x8 is not set
# CONFIG_FONT_ACORN_8x8 is not set
# CONFIG_FONT_MINI_4x6 is not set
# CONFIG_FONT_SUN8x16 is not set
# CONFIG_FONT_SUN12x22 is not set

# Logo configuration
# CONFIG_LOGO is not set

Vincent_Vega 01-19-2004 06:53 AM

Well, I can only guess by telling you to select a video card under CONFIG_VIDEO_SELECT, even if you module them all. Maybe that will help. I also think you can disable the CONFIG_FB_VIRTUAL.
Then just enable your logo so you get to see the little linux penguin and hopefully you'll be ready.....
Do you know what video card you have?

cjdock 01-19-2004 10:13 AM

The VESA vga graphic was already checked so I checked another box that said intel 810/815 support (experimental), that ran make, su -s "modules_install", and make install and it worked!!!Thanks!

Vincent_Vega 01-19-2004 12:01 PM

Penguins Rule!
I hope that when you get time you'll go back and give the little 256 penguin a shot at the top! What would linux be without the penguin??? :)
Congrats on the display! Gotta have some hardware to use. Hope I was of some help.

Alinuxnoob 01-21-2004 09:11 AM

I have the same problem and I have an Nvidia Card. So what do you do to fix this problem?

Vincent_Vega 01-21-2004 10:31 AM

go through the video and console graphics sections very carefully, and read the help section for anything other than modules you don't need. and definitely find out exactly what module you need for your card so there's no guessing involved. make sure you enable VESA and read the several posts around here about it. lots of other people were in the same situation, including me!
if you can't get it, come back and we'll help you more.

Alinuxnoob 01-21-2004 11:41 AM

Ok when you mean go through the video and console graphics section you mean rerunning menuconfig? and compiling it with the new settings. I mean I'm able to boot into slackware using the 2.6.1 kernel but I just don't see anything before I logg in. and another thing is when I boot using the 2.6.1 kernel my mouse doesn't work. I have a USB mouse but kernel setting didn't give me an option for USB mouse....

Vincent_Vega 01-21-2004 11:53 AM

You do get an option in USB for a mouse so make sure you find it. You'll have to do menuconfig again, yes.
make mrproper
make menuconfig
make modules_install
make install
before you exit, after you're done, save your settings to a separate file in your home directory by typing the full path. You can look through it and post parts of it here for troubleshooting.

brandonloserkid 01-21-2004 04:50 PM

i have the same problem with 2.6.0 but i cant even "ghost login"

i read the codemonkey document, and i have:


any other suggestions?

Vincent_Vega 01-21-2004 09:10 PM

Well if you can't do the 'ghost login' then you're getting a kernel panic probably and you'll have to sort that out first. Check your filesystems setup in the menuconfig. Post if here if you want everyone to check it out.

All times are GMT -5. The time now is 04:21 AM.