-   Slackware (
-   -   Black Screen At Boot (

Obscure 12-17-2003 03:02 PM

Black Screen At Boot
I've recompiled 2.4.23 kernel on my Slack 9.0...
The first 2 recompilation worked well but on my last one I don't have the video output
During the boot (and after) the screen is always black!
The boot is done correctly except for this erro in /var/log/messages:


Dec 17 15:37:22 thor init: open(/dev/console): Input/output error

The only change about video I made before this recompilation is to enable

Console Drivers ----> Video Mode Selection Support --> Y

# ls -l /dev/console
crw------- 1 root tty 5, 1 Dec 17 15:38 console

Someone should help please??

Abe_the_Man 12-17-2003 05:58 PM

i had a similar problem it probably has something to do with the framebuffer support. Try waiting a few minutes after boot then type in your login (make sure to type it exactly as you can't see it) and then startx. If you get to a useable desktop recompile your kernel with the 'vesa console' selected for framebuffer. It should all work after that.

**or you can just boot with your old kernel and fix the problem (probably easier :D )

Obscure 12-18-2003 03:17 PM

Tnx 4 help!!

I've noticed (and I don know why) many options are unselectable
One of this is:
Console Drivers ---->Frame-buffer Support

under Console Driver I got only:
VGA text console -----> Y
Video Mode Selection Support --> Y

and no other!
Any suggestion??

Abe_the_Man 12-18-2003 10:10 PM

that's really weird, there should be:

VGA tex console
Video mode selection support
MDA text console (dual-headed) (experimental)
Frame-buffer support --->

and under framebuffer support choose:
VESA VGA graphics console (or whatever video card you have, though i've had problems selecting anything other than VESA VGA)

Or you can try the new kernel 2.6 which was officially released last night (just hours after i compiled the 2.4.23 kernel :) )

Obscure 12-19-2003 03:28 AM

Tnx again!
I'm going to try 2.6 :)

Tnx 4 yr help..

karthikrr 12-19-2003 10:25 AM

This happened to me on two or three of my compiles, and one of the times, I just selected ONE of these two options...

"VGA text console -----> Y
Video Mode Selection Support --> Y"

and it worked for me... I THINK (Im not sure) that u should select only one of those two, or it gets confused which mode to use...

BTW, if u have another working kernel, boot with that, and edit lilo.conf and turn off VGA mode by commenting it out, and that will allow a standard text console... that worked for me too... actually, thats the only thing that works for me... :-) coz I havent been able to get my nVidia drivers installed under 2.6 yet!!!

Obscure 12-19-2003 11:59 AM

Thank you karthikrr...
I think that what you said is correct..
Recompiling kernel without "Video Mode Selectio Support" I got the text console corectly..
My previous kernel (2.4.21) works with both options selected and I was confused by this..
Fortunatly I got a working kernel too...

It's strange that many options as "Frame-buffer support" are unselectable..
I will compile the 2.6 as soon as possible..

Andronik 12-19-2003 03:08 PM

yes this is in connection with framebuffer thing.

whatever kernel you are compiling from 2.4.22 to 2.6.test11 you can include or not framebuffer things-this is your choice. but edit your lilo to use standard vga console (not framebuffer ones).

and you boot is allways ok.
maybe it does not look just so nice, but is fast.

karthikrr 12-19-2003 11:05 PM

ur welcome obscure... 2.6 DOES have all those other options mentioned above... but even tho' I selected VESA VGA AND Video Mode Selection, and even a Linux Logo, I dont get vga boot! I only get text mode! Even when my LILO has vga enabled! Very weird, and I cant figure out why... but I HAVE messed up earlier kernel compiles so badly that I think I may have to reinstall to get everything back in shape now!!! Let us know how ur 2.6 compile goes... see ya round...

karthikrr 12-20-2003 06:02 AM

I got EVERYTHING working now!!! ok, still dunno how to get the Linux Logo during bootup, but everything else works... Just had to recompile the kernel with some config options I had missed....

minio 12-20-2003 06:29 AM

If you get boot logo working let me know how. :o)

Abe_the_Man 12-20-2003 11:34 AM

yeah i'm having trouble getting the logo at boot on 2.6 kernel too

karthikrr 12-21-2003 12:03 AM

minio, will do... I just asked in another thread... hopefully, i'll know by morrow...

All times are GMT -5. The time now is 07:02 PM.