-   Slackware (
-   -   Bizarre CD problem (

masterJ 07-01-2003 11:38 AM

Bizarre CD problem
Bit of an odd one, this...

I'm putting Slack 9 on an old PII 350MHz box, and the installation keeps on failing on me.

I get as far as the part where you select the source media (and iso image I downloaded and burned to CD), then it says it's looking for the Slackware media, and then the installation totally hangs the box! (this happens whether I let it automatically find the CD or manually specify that it's it /dev/hdc )

I scolled back through the console log, and this is how the drive initializes -

hdc: set_drive_speed_status : status = 0x51 {DriveReady SeekComplete Error}
hdc: set_drive_speed_status : error 0xb4
hdc: ATAPI 36X CD-ROM drive, 128kB Cache, DMA

I've tried turning off all advanced drive options (DMA etc) in the BIOS, but it makes no diff.

I tried the same CD in a new P4, did a full install and all was fine, so it's not the CD... Also decided to try using a Slack 8.1 CD (in the original PII box), and got the same prob!!

Any ideas?? Kinda tearing my hair out on this one..... Maybe I have to pass some extra parameters to the kernel?!

Any help / suggesions would be really cool.

P.S. - I know it's not just a straight prob of Linux not liking the CD drive, 'cos I can put RH8 on there with no probs.

Thymox 07-01-2003 06:26 PM

Is it the ide cable? I'm presuming that since you're specifying hdc that you have your harddrive as 1:master and your cddrive as 2:master. Try swapping the cables over - if it's the cable, you should get harddrive errors. Alternatively, try putting your cddrive as 1:slave - it'll possibly take longer to install, but if it works... :D

labr@ 07-01-2003 09:38 PM

Sometimes the installation will puke if you have the CD set to "cable select" I would make sure that the hard drive(s) are on IDE1 and that the CD is on IDE2 and set to master.

masterJ 07-02-2003 04:31 AM

Nope, the CD was secondary master with all jumpers set correctly, put tried cabling it up and changing jumpers to make it primary slave, but still no joy - just does exactly the same (with the same errors as above).

Am still fairly sure that it's not a HW issue though, as I can still install RH8, with no errors at all. But I want Slackware on it instead!!

Does anyone know if theres any CD related parameters that I can pass to the kernel on boot, so that it detects it in a differnet way or something. I'm just guessing now, as I'm kinda out of ideas....

masterJ 07-02-2003 06:56 AM

Bit of an update for you all -

Installed by copying entire CD to a new partition (botted using tomsrtbt to do this - so the CD drive definately still works under Linux!!), and installing from that. All installs OK.

However, once I have my Slack system up and running, if I try to mount a CD (any CD!), it just totally hangs as before. And it's still doing exactly the same error messages at startup.

Not sure whether this does shed any more light on the problem, but this has really got me stumped!!

*ANY* help would be appreciated right now!

masterJ 07-02-2003 07:21 AM

And a bit MORE info (!) - here's all the IDE related stuff I can find in the syslog from when it boots the system.....

Jul 2 10:52:28 lumpy kernel: ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
Jul 2 10:52:28 lumpy kernel: PIIX4: IDE controller on PCI bus 00 dev 39
Jul 2 10:52:28 lumpy kernel: PIIX4: chipset revision 1
Jul 2 10:52:28 lumpy kernel: PIIX4: not 100%% native mode: will probe irqs later
Jul 2 10:52:28 lumpy kernel: ide0: BM-DMA at 0x14a0-0x14a7, BIOS settings: hda:DMA, hdb:pio
Jul 2 10:52:28 lumpy kernel: ide1: BM-DMA at 0x14a8-0x14af, BIOS settings: hdc:DMA, hdd:pio
Jul 2 10:52:28 lumpy kernel: hda: MAXTOR 6L040J2, ATA DISK drive
Jul 2 10:52:28 lumpy kernel: hdc: CRD-8360B, ATAPI CD/DVD-ROM drive
Jul 2 10:52:28 lumpy kernel: ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
Jul 2 10:52:28 lumpy kernel: ide1 at 0x170-0x177,0x376 on irq 15
Jul 2 10:52:28 lumpy kernel: blk: queue c0388784, I/O limit 4095Mb (mask 0xffffffff)
Jul 2 10:52:28 lumpy kernel: hdc: set_drive_speed_status: status=0x51 { DriveReady SeekComplete Error }
Jul 2 10:52:28 lumpy kernel: hdc: set_drive_speed_status: error=0xb4
Jul 2 10:52:28 lumpy kernel: hdc: ATAPI 36X CD-ROM drive, 128kB Cache, DMA

Thanks in advance to whoever has a clue what all this is about!!


hojoloco 07-02-2003 07:28 AM

I've had this happen several times on different hardware, it's not distribution specific but rather has to do with the CD drive not liking the CD you burned. Some of the older CD drives and I've found some newer ones in HP E-PCs don't like homemade CDs. Not really much you can do about it other than what you already did.

masterJ 07-02-2003 07:37 AM

Hmmm - wish that was the case, but I've tried to mount several pre-recorded CDs, and they all do the same...

Any other things to try?

hojoloco 07-02-2003 07:58 AM

Yes it is odd, but I would still look at it as a hardware (the CDRom drive). I've had problems with mounting CD and then it refusing to umount (this was on an HP ePC and the mount point wasn't in use), again not distro specific happened under RH, Slack, and Gentoo. How old is the drive? If you have another PC (like an M$ box) swap the CD drives and see if that fixes it.

masterJ 07-02-2003 09:31 AM

SUCCESS!!! Right, that fixed it (the original CD drive was the one that came in the PC, an old PII) put in a CD from a PIII box, and it worked fine.

Still really bugs me that it doesn't work with the old CD drive when other distros do...

Never mine, eh? Thanks for the help, hojoloco!

All times are GMT -5. The time now is 01:58 AM.