-   Slackware (
-   -   Bizarre behaviour of parted/cfdisk/fdisk. (

stf92 01-11-2013 06:57 AM

Bizarre behaviour of parted/cfdisk/fdisk.
Slackware 14.0

I had a hard disk with four primary partitions (DOS style). All of them where created from a clean disk, by parted under slackware 14.0. Partition 4 was NTFS.
Today, I ran cfdisk, deleted it and created a new partition 4 type ext2. But when telling cfdisk to write, it did not output the message "wrote partition table".

Question: is this expected behavior in 14.0?

In short, the three programs write the partition table and, printing it, raw format, partition 4 shows 0x83 in the ID byte. But only fdisk list it as type 'ext2', The other too "see" NTFS, the previous fs type. The hard disk is SATA and, when I tried to install 10.2 on partition 4 the installer said it saw no partiotions at all! This can be because 10.2 is too old. But the second question is, why do these programs get confused? Another peculliarity of this machine, brand new, is that my old Linux from Scratch live CD and other Linux live CD after booting think the BIOS is in error. But it is them that do not undertand the machine architecture I think. I say this in case it helps.

Another thing: the machine is an Intel H61 (this is the PCH, platform controller hub, which replaces the motherboard, let's say; all very extrange to me).

Iberwil 01-11-2013 08:40 AM

Hi stf92,

I've had similar issues with those CLI partitioning tools, but never bothered to troubleshoot them. GParted is a rather nice program, as you probably know, so I'd recommend it. You will have to deal with a bunch of deps to get it running though.

The curious thing is what do you need 10.2 for if I may ask?

stf92 01-11-2013 08:45 AM

I can't mount the DVD bundled with my new machine, nor can I boot two linux live CDs without they objecting (don't find the fs). So, I blame 14.0 and, and wanted to see what happens with some older version.

All times are GMT -5. The time now is 03:05 AM.