-   Slackware (
-   -   Backtrack / DHCP Issue (

bigdogg 03-24-2006 09:57 AM

Backtrack / DHCP Issue
I'm going through some basic Security training and I have been using Whoppix and Back Track distro's. The problem is when I boot them off a Dell Latitude D600 series laptop and I do an ifconfig I get nothing? I know itís built off of Slax so hopefully this is the right place to post. I tried running through a network wizard with no luck. Does anyone have any suggestions on what commands to run or how I could get the Linux driver loaded for my Ethernet adapter?

ifconfig down/up did not work

03.03.0 Network controller: Intel Corp.: Unknown Device 4220 (re05)

Thanks in Advance,


jaykup 03-24-2006 11:35 AM

You will have to make sure the network card is selected in the Kernel (which is where all of your "drivers" or modules are) then simple run

dhcpcd eth0 and it will load the module and send out the DHCP request .. etc.

my lspci:

root@digital:~# lspci
00:00.0 Host bridge: Advanced Micro Devices [AMD] AMD-760 MP [IGD4-2P] System Controller (rev 20)
00:01.0 PCI bridge: Advanced Micro Devices [AMD] AMD-760 MP [IGD4-2P] AGP Bridge
00:07.0 ISA bridge: Advanced Micro Devices [AMD] AMD-768 [Opus] ISA (rev 05)
00:07.1 IDE interface: Advanced Micro Devices [AMD] AMD-768 [Opus] IDE (rev 04)
00:07.3 Bridge: Advanced Micro Devices [AMD] AMD-768 [Opus] ACPI (rev 03)
00:07.5 Multimedia audio controller: Advanced Micro Devices [AMD] AMD-768 [Opus] Audio (rev 03)
00:10.0 PCI bridge: Advanced Micro Devices [AMD] AMD-768 [Opus] PCI (rev 05)
01:05.0 VGA compatible controller: nVidia Corporation NV25 [GeForce4 Ti 4600] (rev a3)
02:00.0 USB Controller: Advanced Micro Devices [AMD] AMD-768 [Opus] USB (rev 07)
02:05.0 Ethernet controller: Intel Corporation 82557/8/9 [Ethernet Pro 100] (rev 0c)
02:07.0 Ethernet controller: Intel Corporation 82557/8/9 [Ethernet Pro 100] (rev 0d)

and my lsmod

root@digital:~# lsmod
Module Size Used by
nvidia 4085680 12
w83627hf 25168 0
hwmon_vid 2688 1 w83627hf
eeprom 6160 0
lm90 12132 0
hwmon 2820 2 w83627hf,lm90
i2c_isa 4096 1 w83627hf
snd_pcm_oss 48992 0
snd_mixer_oss 17472 1 snd_pcm_oss
yealink 11456 0
i2c_amd756 6148 0
ohci_hcd 16708 0
eepro100 27664 0
3c59x 40872 0

I am running 2 network cards, so that is why you see both of them, and the eepro100 is the module it needs to run.

See what device it says under Ethernet Controller instead of Network, and go from there.

If you have a well bloated kernel, just doing "dhcpcd eth0" may do what you want.

---------------- EDIT --------------

The Dell D600 uses the "Internal Broadcom BCM5705M Gigabit Ethernet NIC" for regular ethernet and can be loaded by doing

"modprobe tg3"


dhcpcd eth0



you should see what you want.

As for the wireless, it isnt supported nativly by linux, and takes some work to get going.

bigdogg 03-24-2006 01:11 PM

Sorry I have a Dell C610 :0 I tried the following with no luck:

"modprobe tg3"
dhcpcd eth0

I'm getting Input/Output errors and Opertaion not Permitted in /var/log/messages? Could this be because it's a Live Distro CD?


jaykup 03-24-2006 01:15 PM

The C610 Uses a 3com card, this module will load it

modprobe 3c59x

If it says the module cannot be found then it needs to be enabled in the kernel (a live cd is not the best for this)

Your IO errors may be the cause of a scratched CD

Also. Make sure you are doing this as root!

modprobe 3c59x
dhcpcd eth0

You may want to consider moving to a non Live-CD Distro (unless you are just testing it out)

bigdogg 03-24-2006 03:25 PM

I followed the link above.

root@slax:~#modprobe 3c59x
root@slax:~#dhcpcd eth0

I can see the TX & RX packets increase on another terminal window but when the dhcpcd eth0 command finished the only thing listed under ifconfig is 'lo' device? The laptop is a Dell C610 I have a C600 that is having the same issue. I thought it was an Intel chipset?

jaykup 03-24-2006 03:40 PM

This is the link I used to get the information about the C610

Check your lspci (or display it here) and make sure you are properly hooked up to a network.

you might want to try

ifconfig eth0 (or w/e your network is on) and see if that even brings up the network card. has more indepth if you cannot use DHCP

-=Graz=- 03-24-2006 05:08 PM

Hey Bigdog... The backtrack CD should automatically setup ll your devices when you boot up.. DO you get any errors during boot?
What kind of nic do you have? is it one of the intel ipw2100 or 2200 cards that the Dell's ship with? or PCMCIA?
If it is PCMCIA make sure the probe completes without errors when the cd boots. If it is a intel IPW2100 or IPW2200 then it should appear as eth1 or eth2 by simply typing ifconfig or iwconfig (I have a Dell inspiron 700m and it does with both auditor and backtrack)
If it is PCMCIA what chipset does the card have? I have seen with the live CD that some nics get assigned the wrong bindings. i.e. get assigned orinoco instead of Prism2 etc... This can be changed but i think it would need to be installed on HDD>
actually - just looking at your post again - it says ,
03.03.0 Network controller: Intel Corp.: Unknown Device 4220 (re05)

Looks like it not supported to me... those live cd's are packed with goodies and it should just work.
check what kind of nic the laptop has (can do easily in windows etc) - go to the exploit forum and check whether it is supported or not...(there is a list of all suported network cards) If the card that is build into the C610 does not support monitor mode i would say it would have been pointless for them to include it... i know that intelprowireless2100 is flaky but can work in some fashion. the ipw2200 works well - just simple monitor mode though.. nothing fancy

bigdogg 03-30-2006 09:48 AM

Thanks for the update. I had an older Dell C610 with a 10/100 card and Dlink Wireless and now the Live CD's have recognized the hardware. Thanks for the detailed post it was very weird that the live CD's could not detect my NIC and wifi card in the D-600 :\ When in doubt use something a little older. :)>


All times are GMT -5. The time now is 05:47 AM.