LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   backlight adjustment (https://www.linuxquestions.org/questions/slackware-14/backlight-adjustment-891604/)

Knightron 07-13-2011 07:41 PM

backlight adjustment
 
Hey, i can normally adjust the back light settings of my lap top by pressing fn and the up and down aarows. I am using the default xorg server without using xorgconfig in slackware, and it works perfect so far dispite this slight problem. When i do, do that key combo, (in kde) it does display the the meter of brightness, but i can't move the settings. I believe this may be an x issue, but not sure.

Konphine 07-15-2011 04:45 AM

Do you mean you can't move the settings with your mouse?

george-lappies 07-15-2011 04:46 AM

Hi what do you mean you can't move the settings? Mine works fine when I use the key combo to adjust the brightness as well. I like seeing that onscreen brightness meter ;) . When the screen dims by itself (set to dim after a few minutes) it sadly however doesn't show the meter...

Knightron 07-24-2011 02:22 AM

what i mean? i'll use the volume control as an example, because it works.
I press and hold fn, then i can adjust the volume with the right and left buttons, showing the meter, revealing the change in settings. Now when i do the appropriate key combo to adjust the backlight, (fn + up/down) it shows the meter, but but there is no level in the meter to show the current brightness and pressing up or down does nothing, except keep the meter on screen doing nothing.

Konphine 07-24-2011 03:05 AM

Maybe your current kernel version doesn't support backlights. In one of your last posts I recall you saying that you're using 2.6.39.3, which can do it but doesn't select it automatically.

deNiro 07-24-2011 07:23 AM

can you set it manually from commandline with?:

# xbacklight -set 80
(to set it to 80 percent)

do a xbacklight --help for other options

or have you tried the xfce4 brightness plugin in the tray (comes with full install of slackware)?

Knightron 07-24-2011 05:44 PM

hi, no im not running the 2.6.39 kernel yet, i want to and am currently getting help to get it going, but thats irralivelnt. i havent tried them commands yet since im at work atm. but as for the xfce thing, that doesnt work either, but interestingly i used to have robbies xfce 4.8 and it worked while running that.

Quote:

Originally Posted by deNiro (Post 4423800)
can you set it manually from commandline with?:

# xbacklight -set 80
(to set it to 80 percent)

ok, i just checked, and yes this does work. p.s. no need to be root ;-P


All times are GMT -5. The time now is 07:28 AM.