-   Slackware (
-   -   avahi network browsing in gnomeslackbuild (

bamdad 08-10-2010 03:14 AM

avahi network browsing in gnomeslackbuild
a short question aimed at those using Gnome SlackBuild:

i've noticed a bug-ish thing, and i'd like to know if there's a workaround, or should i contact the developers.

basically, when i start up my Gnome session, if i open network:/// in Nautilus, it shows nothing (aside from the default 'Windows Network'). it _should_ show my Mac server on the network. i can see it in the Zeroconf Browser, and i can even connect to it using the 'Connect to Server..' menu entry. it's just that it fails to show up in the Network browser.

however, if i restart the Avahi daemon (/etc/rc.d/rc.avahidaemon), it shows up immediately.

i've tried disabling inet(d), since i use NetworkManager (i'm on a laptop), and tried moving the Avahi-related entry in rc.local to the bottom, to make it start after NetworkManager (just a guess), but nothing has changed. i'm in the group 'netdev', and 'avahi-daemon' shows up in 'ps aux'.

is anyone else noticing this?


Keith Hedger 08-10-2010 12:10 PM

What services have you got switched on in OSX? I've got "Personal File Sharing" "Windows Sharing" "Personal Web Sharing" and "Remote Login" activated and my mac shows up fine and runs under sftp, do you start up your mac before or after your linux box?

bamdad 08-10-2010 12:41 PM

thank you, but i think these things are irrelevant, since Fedora 13 (on my other laptop) doesn't have this issue. even Solaris SXCE (on the same machine as Slack) shows them automatically.

but to answer your questions, i have 'Personal File Sharing', 'Remote Login' and 'FTP Access' enabled on the OSX box. it's on 24/7 (yes, i tried restarting it). on other systems (and on Slackware after restarting rc.avahidaemon) the hostname of the server shows up in two instances, one for FTP and one for SFTP.

seriously, there's nothing wrong with that server. ;)

bamdad 08-10-2010 01:13 PM

update: i thought i might be experiencing a bug with Avahi that some Ubuntu users were noticing last year (i.e. sometimes it had to be restarted it manually, most of the times after resume), but i'm sure it's not that. the network is browsable after multiple suspend+resume cycles.

instead, restarting Xorg (and thus Gnome) seems to trigger the strange behaviour. i've even added a

%wheel  ALL=NOPASSWD: /etc/rc.d/rc.avahidaemon
%wheel  ALL=NOPASSWD: /usr/sbin/avahi-daemon

to my /etc/sudoers, and a startup script to issue

/usr/bin/sudo /etc/rc.d/rc.avahidaemon restart
but strangely enough i have to issue it twice (with a sleep 10 in between) for it to work. it works as a temporary fix, but this is really boggling me.

so strange..

All times are GMT -5. The time now is 05:47 AM.