LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 03-08-2012, 03:27 PM   #1
saycheese
LQ Newbie
 
Registered: Mar 2012
Distribution: Slackware64 13.37
Posts: 6

Rep: Reputation: 0
Automount of audio CD and play not working Slackware 13.37 64, XFCE and KDE


Hi all,

Recently installed Slackware64 13.37. Besides the nouveau driver fail issue (common across all distros unfortunately) everything installed fine. My system is updated with all the fixes from the repos as well.

When I put an audio CD in, nothing happened. When I manually opened Amarok, it see's the disc but won't play it. None of the other players wanted to work either. One of them did play after a while but only because it ripped the CD which isn't what I wanted. I first tried in XFCE and than I tried in KDE and neither worked. Nothing else is installed besides the standard stuff and the updates.

Is this feature just left out? Am I doing something wrong?
 
Old 03-08-2012, 08:09 PM   #2
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 10,882
Blog Entries: 1

Rep: Reputation: 1307Reputation: 1307Reputation: 1307Reputation: 1307Reputation: 1307Reputation: 1307Reputation: 1307Reputation: 1307Reputation: 1307Reputation: 1307
Member response

Hi,

What groups do you have the user in;
Code:
 users floppy audio video cdrom plugdev power netdev burning
EDIT: Welcome to LQ!
 
Old 03-09-2012, 12:16 AM   #3
saycheese
LQ Newbie
 
Registered: Mar 2012
Distribution: Slackware64 13.37
Posts: 6

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by onebuck View Post
EDIT: Welcome to LQ!
Thank you!

I used the default groups when adding a new user:
Quote:
users floppy audio video cdrom plugdev power netdev scanner
All of them are the same as the ones you posted except at the end you have burning and I have scanner. Does it work for you? If so what program?

edit: I don't have a burning group.

Last edited by saycheese; 03-09-2012 at 12:24 AM. Reason: additional info
 
Old 03-09-2012, 08:45 AM   #4
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 10,882
Blog Entries: 1

Rep: Reputation: 1307Reputation: 1307Reputation: 1307Reputation: 1307Reputation: 1307Reputation: 1307Reputation: 1307Reputation: 1307Reputation: 1307Reputation: 1307
Member response

Hi,

'burning' group is used by 'k3b' and must be created. You add the user to that group when using the default 'k3b'.

You should check through 'dmesg' to see how the media devices are recognized.
 
Old 03-09-2012, 10:58 PM   #5
saycheese
LQ Newbie
 
Registered: Mar 2012
Distribution: Slackware64 13.37
Posts: 6

Original Poster
Rep: Reputation: 0
As a follow up in case anybody else bumps into this thread with the same problem...
My googlefu turned up no clear fix to get autoplay audio cd's working. There are a couple settings in KDE that lead you to believe the functionality is there though.

Found a lot of good information here: http://www.linuxquestions.org/questi...-2-4-a-791192/

Basically, if you pop an audio CD in ignore the KDE popup if you want to listen to it. Open up audacious and find the "Play CD" in the plugins menu. I tried adding a command to the KDE popup menu but that didn't do anything, had to be done manually. MPlayer worked on the command line too. Couldn't get Amarok to work with audio cds whatsoever.
 
Old 03-09-2012, 11:41 PM   #6
mrclisdue
Senior Member
 
Registered: Dec 2005
Distribution: Slackware -current, 14.1
Posts: 1,019

Rep: Reputation: 157Reputation: 157
You mention in the thread title that you tried in xfce. Did you check the settings in Thunar for volume management and configure the behaviour?

cheers,
 
Old 03-10-2012, 12:24 AM   #7
saycheese
LQ Newbie
 
Registered: Mar 2012
Distribution: Slackware64 13.37
Posts: 6

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by mrclisdue View Post
You mention in the thread title that you tried in xfce. Did you check the settings in Thunar for volume management and configure the behaviour?
I gave it a try. All the settings are checked under the storage tab and multimedia tab. The multimedia tab makes reference to a program called totem which isn't installed on slackware from what I can tell, so I've changed it to amarok, no luck. No matter what the CD never shows anywhere in the file system in XFCE.
 
Old 03-10-2012, 06:55 AM   #8
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,111

Rep: Reputation: Disabled
Quote:
Originally Posted by saycheese View Post
No matter what the CD never shows anywhere in the file system in XFCE.
Audio CD's do not have a file system, so you will not be able to mount such a CD at all.

Eric
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware 13.37 + XFCE : handle audio formats with Brasero ? kikinovak Slackware 0 07-29-2011 02:47 AM
Cannot play audio CD on Slackware 13.0 KDE 4.2.4 traveller1212 Slackware 13 03-01-2010 02:21 PM
Automount - HAL - udev - Xfce - Konqueror - Slackware - help requested Linux.tar.gz Linux - Hardware 5 06-19-2008 09:49 AM
Trouble with Audio cds: Slackware 12 / xfce andrew.46 Slackware 1 03-04-2008 10:11 PM


All times are GMT -5. The time now is 08:30 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration