LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 04-27-2010, 03:18 AM   #1
Linux.tar.gz
Senior Member
 
Registered: Dec 2003
Location: Paris
Distribution: Slackware forever.
Posts: 2,437

Rep: Reputation: 95
Unhappy Autofs mounts, but doesn't umount


Hi !
I have some trouble using autofs with Slackware64 13.0
I use the alien's script :
http://connie.slackware.com/~alien/r...ipts/rc.autofs

Here's my auto.master :
/mnt/autofs /etc/auto.misc --timeout 20

Here's my auto.misc :
local -defaults,ro,noatime,tcp,acregmin=60 server:/exports/local
www -defaults,ro,noatime,tcp,acregmin=10 server:/exports/www

First problem : both are mounted as boot.
Second problem : they stay mounted.
As mounted, i mean visible in /proc/mounts
Sometimes, only one is mounted, and the second is activated when i click inside the folder.

Another thing, i made a symlink from /mnt/autofs/local to /usr/local, and i wonder if it can cause trouble.

Is the timeout really in seconds ?

EDIT :
Here's my /proc/mounts
automount(pid1478) on /mnt/autofs type autofs (rw,relatime,fd=5,pgrp=1478,minproto=2,maxproto=3)
server:/exports/local on /mnt/autofs/local type nfs (ro,noatime,vers=3,rsize=1048576,wsize=1048576,namlen=255,acregmin=60,hard,proto=tcp,timeo=600,retra ns=2,sec=sys,mountaddr=192.168.1.15,mountvers=3,mountproto=tcp,addr=192.168.1.15)
server:/exports/www on /mnt/autofs/www type nfs (ro,noatime,vers=3,rsize=1048576,wsize=1048576,namlen=255,acregmin=10,hard,proto=tcp,timeo=600,retra ns=2,sec=sys,mountaddr=192.168.1.15,mountvers=3,mountproto=tcp,addr=192.168.1.15)

Last edited by Linux.tar.gz; 04-27-2010 at 03:35 AM.
 
Old 04-27-2010, 03:36 AM   #2
Richard Cranium
Senior Member
 
Registered: Apr 2009
Location: Carrollton, Texas
Distribution: Slackware64 14.2
Posts: 3,668

Rep: Reputation: 2013Reputation: 2013Reputation: 2013Reputation: 2013Reputation: 2013Reputation: 2013Reputation: 2013Reputation: 2013Reputation: 2013Reputation: 2013Reputation: 2013
I really don't know why Pat hasn't upgraded the autofs version that he ships with Slackware. I've had to build and install autofs 4.1.4 at work to get something that actually worked.
 
Old 04-27-2010, 03:37 AM   #3
catkin
LQ 5k Club
 
Registered: Dec 2008
Location: Tamil Nadu, India
Distribution: Debian
Posts: 8,577
Blog Entries: 31

Rep: Reputation: 1197Reputation: 1197Reputation: 1197Reputation: 1197Reputation: 1197Reputation: 1197Reputation: 1197Reputation: 1197Reputation: 1197
Summarising this LQ thread ...

The Slackware 13.0's version of automounter pre-dates support for --timeout in auto.master.
Code:
root@CW8:~# /usr/sbin/automount --version
Linux automount version 3.1.7
The workaround is to use automount's timeout option when starting the daemon. This is not as nice as having it as an option in the map files because it uses the same timeout for all maps; that was OK for me. If that's a problem for you, bathory posted a very nice script that gives different timeouts in the linked thread.
 
Old 04-27-2010, 07:04 AM   #4
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 8,012

Rep: Reputation: 6743Reputation: 6743Reputation: 6743Reputation: 6743Reputation: 6743Reputation: 6743Reputation: 6743Reputation: 6743Reputation: 6743Reputation: 6743Reputation: 6743
Quote:
Originally Posted by Richard Cranium View Post
I really don't know why Pat hasn't upgraded the autofs version that he ships with Slackware. I've had to build and install autofs 4.1.4 at work to get something that actually worked.
In Slackware 13.1 (still called -current at the moment) you will find autofs-5.0.5

Eric
 
1 members found this post helpful.
Old 04-27-2010, 07:10 AM   #5
Linux.tar.gz
Senior Member
 
Registered: Dec 2003
Location: Paris
Distribution: Slackware forever.
Posts: 2,437

Original Poster
Rep: Reputation: 95
In 13.0, this is indeed, a little outdated :^)

/var/log/packages/autofs-3.1.7-x86_64-1

http://slackware.at/data/slackware64...urce/n/autofs/
autofs-3.1.7.tar.bz2 2000-Nov-04 08:05:24

Do you think i can use this -current package on my 13.0 ?
Anyway, i'll try on a non-production machine right now.
Keep in touch.

EDIT :
As autofs is not network-centric, is the /n series the right place for it to be ?

Last edited by Linux.tar.gz; 04-27-2010 at 07:11 AM.
 
1 members found this post helpful.
Old 04-27-2010, 07:13 AM   #6
Linux.tar.gz
Senior Member
 
Registered: Dec 2003
Location: Paris
Distribution: Slackware forever.
Posts: 2,437

Original Poster
Rep: Reputation: 95
Ouch !

bash-3.1# sh rc.autofs start
Starting automounter: /mnt/nfs/usr/sbin/automount: /usr/lib64/libxml2.so.2: no version information available (required by /usr/sbin/automount)
/usr/sbin/automount: test mount forbidden or incorrect kernel protocol version, kernel protocol version 5.00 or above required.

bash-3.1# uname -r
2.6.33.2

Will try to build.

EDIT :
Compiled -current version from sources :

###alien's script
bash-3.1# sh rc.autofs start
Starting automounter: /mnt/nfs/usr/sbin/automount: test mount forbidden or incorrect kernel protocol version, kernel protocol version 5.00 or above required.

Well have no V5.00 in my kernel settings...

EDIT 2 :
###.new script from -current selfbuilt package
bash-3.1# sh /etc/rc.d/rc.autofs.new start
Starting automount:
Error: autofs kernel module is loaded, autofs4 required

EDIT 3 :
bash-3.1# rmmod autofs
bash-3.1# modprobe autofs4
bash-3.1# sh /etc/rc.d/rc.autofs.new start
Starting automount: done.
bash-3.1#

Ok now it works. Let's see if it auto-umounts on this test machine without symlinks.
Hope default timeout isn't two days :^)

EDIT 4 :
Umounted !!!
Going for my production machine with "more advanced settings"

EDIT 5 :
Working too on my production machine.
autofs4 module well started.
Unfortunately, i still have the same problem.
Strangely, at the first cat /proc/mounts, i see only /mnt/autofs/local
At the second i see /mnt/autofs/www too
Now i wait and hope for umount.

EDIT 6 :
umount worked !!!
Now i have to figure out why shares are pre-mounted, as this is the thing i absolutely want to avoid.

EDIT 7 :
I saw only one share mounted this time, which disappeared very quickly.
I don't like this non-slack randomness and i wonder if it's the normal way autofs works, i mean, mounting things very quickly, then umounting.

Last edited by Linux.tar.gz; 04-27-2010 at 08:32 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] autofs, fstab and manual cifs mounts fail if using credentials file carltm Red Hat 1 12-02-2009 06:39 AM
autofs/ldap limit mounts dziqus83 Linux - Server 1 07-07-2009 07:41 AM
Noob question: AutoFS and NFS Share Issue: Group mounts gerhardb Linux - Networking 0 03-20-2007 02:09 PM
autofs fails to umount Moloko Debian 2 01-23-2005 06:12 PM
autofs won't umount. RoaCh Of DisCor Linux - Software 1 12-26-2004 06:58 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 08:32 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration