-   Slackware (
-   -   audacity not capturing sound (

joelescoulie 05-20-2005 02:42 PM

audacity not capturing sound
I cannot get audacity to capture sound played through the sound card. I can import sound files just fine, but I'm not able to record sound that is being played. I have two sound cards and I think that is the problem. I have the integrated card on my motherboard that I do not use, and a soundblaster sbLIVE pci card that I do use. How can I find out which card is which in /dev and how to configure audacity to listen to it.

Shade 05-20-2005 07:33 PM

The first solution I would try is to go into the motherboard bios and disable the onboard sound. Most have options for this.

If you don't know how to enter the BIOS, normally you hit delete or F2 or somesuch as the machine first boots, before it gets to the bootloader. Which key to hit is also usually displayed.


piete 05-20-2005 07:55 PM

I recently had a very similar problem with my Audigy2, Audacity and Slamd64 (10.1 with a newer toolchain, for all intents and purposes).

I fixed it, eventually.

1. Disable the second soundcard at BIOS level, then there's no confusion as to which card is getting used.
2. In the kernel, be sure OSS emulation is ticked under ALSA and check any necessary OSS modules you need are also in there.
3. At bootup time, just before you get the login, you should be seeing this message:

Loading ALSA mixer settings: /usr/sbin/alsactl restore
Loading OSS compatibility modules for ALSA.

If you do not see that, or you see something else - the OSS part isn't sorted.

4. Recompile Audacity without ALSA (./configure --with-portaudio=v18). The only difference should be the entry point for Audacity - it knows more about OSS than ALSA, so you're more likely to get the results you want.
5. Run "alsaconf" as root, just to be certain you've got it all sorted.
6. Run "alsamixer" (as user) - this'll bring up an ugly looking mixer (alsa 1.0.7, perhaps?) but it's the only one that I can get to work properly.

You want to hit tab once which will switch from displaying "output" levels to "input" ("capture") levels - these are your recording levels. PCM represents sound being played through your system, while I suspect you want that at 0 and LINE or similar up near full whack. Hitting tab again will move you to display mode "all" (not so useful), a third time will move you back to "output" or "playback". Dropping LINE playback to 0 will mean you can record from line in while playing sound back from, XMMS, say, without it affecting your recording!

I haven't tried this under anything less than a 2.6.9 kernel - but theoretically the same applies for a 2.4 series.

Incidentally, the newer versions of alsamixer (and associated drivers, utils and tools) are significantly better than the ones shipped with 2.6.9 and I am currently using kernel version 2.6.12rc4 (ships with ALSA drivers 1.0.8) as well as the 1.0.9beta alsa-libs and alsa-utils (where you get alsamixer from).

If you're going to upgrade ALSA, make sure you copy /etc/rc.d/rc.alsa before removing the alsa-utils package, then copy it back to /etc/rc.d/ after compiling and (check-)installing the new alsa-libs / alsa-utils.

Finally, Audacity should be setup to use /dev/dsp as both playback and recording (if you've run it --with-portaudio=v18, it'll be the only option available). Pushing record should show the recording level meter bounce around a bit.

joelescoulie 05-21-2005 07:14 PM

I was totally on the wrong track. I fiddled around with the preferences tab in audacity and seem to have fixed the problem. I unchecked the 'software playthrough' button and the 'play other tracks' button and it works great. Thanks.

VibeOfOurTribe 05-24-2005 08:26 PM

What do I need to select for "capture" in alsamixer? I tried just about all of them with no success and I unchecked the two options like you said in audacity. I also tried using the rec command.

Under capture view in alsamixer, I do not have a PCM option. Do you guys have that?

All times are GMT -5. The time now is 02:35 PM.