LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   Audacity and -current (https://www.linuxquestions.org/questions/slackware-14/audacity-and-current-4175628701/)

pchristy 04-30-2018 06:08 AM

Audacity and -current
 
Is anyone else having issues with audacity in current?

Its recently stopped working (version 2.1.2) and recompiling fails. Neither 2.2.2 not git versions compile either. I'm assuming the compile issues are to do with the recent gcc upgrade.

Has anyone else run in to this or found a workaround?

Cheers,

--
Pete

RadicalDreamer 04-30-2018 07:09 AM

2.2.2 built for me for Slackware64-Current. I guess make sure you are using lame supplied by Slackware Current and reinstall wxGTK3 if you haven't before you build audacity.

Toutatis 04-30-2018 07:11 AM

I have recompiled audacity-2.2.2 (using SBo slackbuild) recently in slackware64-current. But I have also recompiled almost everything outside slackware64-current, beginning with libraries, after the huge "Mass Rebuild".

pchristy 04-30-2018 07:56 AM

Thanks very much for the pointers! The culprit was wxGTK3. Rebuilding that solved the problem!

--
Pete

rpedrica 03-11-2019 02:12 PM

I'm also having an issue building audacity 2.3.1 in -current (as of 11 Mar 2019). It fails with the following error:

Quote:

mv -f gtk/.deps/libFileDialog_la-FileDialogPrivate.Tpo gtk/.deps/libFileDialog_la-FileDialogPrivate.Plo
/bin/sh ./libtool --tag=CXX --mode=link g++ -Wl,-O1,-L/lib64,-L/usr/lib64 -o libFileDialog.la -rpath /usr/lib64 libFileDialog_la-FileDialog.lo gtk/libFileDialog_la-FileDialogPrivate.lo -lgtk-x11-2.0 -lgdk-x11-2.0 -lpangocairo-1.0 -latk-1.0 -lcairo -lgdk_pixbuf-2.0 -lgio-2.0 -lpangoft2-1.0 -lpango-1.0 -lgobject-2.0 -lglib-2.0 -lfontconfig -lfreetype -lgtk-x11-2.0 -lgdk-x11-2.0 -lpangocairo-1.0 -latk-1.0 -lcairo -lgdk_pixbuf-2.0 -lgio-2.0 -lpangoft2-1.0 -lpango-1.0 -lgobject-2.0 -lglib-2.0 -lfontconfig -lfreetype
libtool: link: `/usr/lib64/gcc/x86_64-slackware-linux/8.2.0/../../../../lib64/libstdc++.la' is not a valid libtool archive
make[2]: *** [Makefile:529: libFileDialog.la] Error 1
I've checked and my system does not have the file libstdc++.la (only the .a). I've tried creating it with just the name of the lib as contents but same issue. My system is 32/64 multilib with AlienBob's multilib packages included. My libstdc++ files in /usr/lib64:

-rwxr-xr-x 1 root root 3271696 Mar 1 00:07 /usr/lib64/libstd-1c60a19b0a9bc53e.so*
-rw-r--r-- 1 root root 4824800 Jul 27 2018 /usr/lib64/libstdc++.a
lrwxrwxrwx 1 root root 19 Aug 1 2018 /usr/lib64/libstdc++.so -> libstdc++.so.6.0.25*
lrwxrwxrwx 1 root root 18 Jun 3 2018 /usr/lib64/libstdc++.so.5 -> libstdc++.so.5.0.7*
-rwxr-xr-x 1 root root 830616 Feb 6 00:11 /usr/lib64/libstdc++.so.5.0.7*
lrwxrwxrwx 1 root root 19 Aug 1 2018 /usr/lib64/libstdc++.so.6 -> libstdc++.so.6.0.25*
-rwxr-xr-x 1 root root 1602552 Feb 6 00:11 /usr/lib64/libstdc++.so.6.0.25*
-rw-r--r-- 1 root root 1499182 Jul 27 2018 /usr/lib64/libstdc++fs.a

GCC is 8.2.0 ...

Any help is appreciated.

ponce 03-11-2019 02:49 PM

hi rpedrica,

I just tried to build audacity 2.3.1 on my current installation and everything went fine.

I suppose the issue you are facing is because you have built in the past some third party package that is a dependency of audacity (or a dependency of a dependency of audacity, and so on...) that used that libstdc++.la when it was installed in your system: *.la files had been removed nearly one year ago
Quote:

Originally Posted by The ChangeLog
Code:

Thu Apr 19 01:04:06 UTC 2018
Hi folks, and welcome to the third ever Slackware Mass Rebuild (and the
longest ChangeLog entry in project history). There were two primary
motivations for rebuilding everything in the main tree. The first was to
switch to the new C++ ABI. The second was to get rid of all the .la files
in the LD_LIBRARY_PATH. Really, having .la files installed has been mostly
obsolete since things began to use pkg-config instead, but it's not easy
to get rid of them unless you do it all at once. If you just take them out
of one package, any other packages containing .la files that refer to the
removed ones will be broken. We've removed a few here and there before
(and then handled any packages that had referred to them with a rebuild),
but it was time to finally remove all the ones in /lib{,64} and
/usr/lib{,64}. One of the reasons that this really needed to happen is that
many projects are starting to migrate to build systems other than autotools,
and those systems do not generate .la files. So if we didn't get rid of them
now, we might end up in a situation later on where they are being removed
by upstream and then we would have to chase down the dependency breakage and
recompile (possibly many) other packages. The .la files that are outside of
the LD_LIBRARY_PATH were not removed (and shouldn't be) - those ones are
often used by the lt_dlopen() function to load plugins and removing those
ones can break things. But those ones don't cause problems... they aren't
likely to try to infect .la files produced by other packages.
IMPORTANT NOTE: If you have any third party or other packages installed on
your system that don't come with Slackware, and those packages have installed
any .la files, it is very likely that they refer to some .la files which we
have just removed, and that trying to compile against these packages will no
longer work. Luckily, the solution is simple: remove them. This command will
remove any stale .la files from the LD_LIBRARY_PATH:
rm /{,usr/}lib{,64}/*.la
Moving forward, nothing shipped in Slackware will contain any .la files in
those directories, and any SlackBuilds intended to be used with Slackware 15.0
should contain this bit of script:
# Don't ship .la files:
rm -f $PKG/{,usr/}lib${LIBDIRSUFFIX}/*.la
In addition to those goals, the opportunity was taken to clean up slack-desc
files and make many trivial fixes to build scripts. We've also made it easy
to recompile everything again should there be a good reason to do so.
You'll also find various updates scattered throughout this long list.
Enjoy, and sorry about the bandwidth. ;-)


you can try the command to remove any stale .la files from the LD_LIBRARY_PATH that Pat suggests in the ChangeLog, or, in alternative, you can also rebuild every third-party package that you have installed as part of the audacity dependency chain (mandatory and optional) on the latest current.
note that the compiler has been updated to gcc-8.3.0 (it's available also in Alien Bob's multilib repository).

rpedrica 03-11-2019 03:48 PM

Thanks @ponce, I'm guessing it is something like that. So I've put up a quick vm with a fresh -current install to compile and then will install package on my existing system after. When I get some time, I'll recompile all my old stuff to see if it solves the issue.


All times are GMT -5. The time now is 11:38 PM.