-   Slackware (
-   -   Attempt to get Slackware Graphical Boot working ends in Segfault. (

ReaperX7 10-07-2012 02:18 PM

Attempt to get Slackware Graphical Boot working ends in Segfault.
3 Attachment(s)
I've been following the handbook for adding a Graphical Startup screen to Slackware here:

I have all the paths set up correctly in the RC scripts but each time I attempt to boot with it I get this error:

rc.S-Wrap Segmentation Fault 1361 at Line 47 /boot/initrd/bin/busybox /boot/initrd/sbin/fbsplash -i /boot/GSplash/fbsd.config -f /boot/GSplash/fbfifo -s /boot/GSplash/shutdown.ppm &

To which I have to then chroot using the install media change the inittab paths back to the original one so I can boot again.

I've also included my scripts so please give me some insight if I didn't set something correctly.

My paths are as such for fbsplash and busybox and I am booting with fb0 enabled in /dev via the vga=791 flag for my bootloader.

Any help would be appreciated.

Beelzebud 10-07-2012 03:38 PM

I tried this last night, and had the same result. I also saw a bunch of errors relating to the x server trying to start up a bunch of times. I'm not sure what to do to get it to work.

ReaperX7 10-07-2012 07:49 PM

Well, I have inittab set to load gdm as my display manager on runlevel 4. Maybe it has something to do with that?

I wonder if using runlevel 3 and not allow X11 to load might help any.

Beelzebud 10-08-2012 01:10 PM

That's a good observation. I was still running in runlevel 4 as well. I'll give this another try when I have more time, and see what runlevel 3 does.

Pode 10-13-2012 04:49 PM

Segmentation Fault
I get Segmentation Fault too. But if I comment out the line

echo "$COUNT\n" > /boot/GSplash/fbfifo
in every wrap file:


#echo "$COUNT\n" > /boot/GSplash/fbfifo
or put -n option for echo


echo -n "$COUNT\n" > /boot/GSplash/fbfifo
Then I don't get segmentation fault but there is no progress bar

Marcelo_Belfalas 10-13-2012 05:34 PM


After a lot of time in the past I did manage to get a Graphical Boot.

The segfault is because fbsplash can't display your image, either due to it's size, or because fb0 is loaded with a resolution that it doesn't support.

To check that, go to tty and use the command


/boot/initrd/bin/busybox fbsplash -s /boot/GSplash/shutdown.ppm
And if all goes well, your image display's fine.

To get fb0 to the right resolution, add to /etc/lilo.conf


It is the only way I found to affect only tty and not X.

You may find that after udev is started, udev resizes your screen to the recommended resolution, but the resolution in tty is 1024x768, so you get black bars on the sides of your screen if your resolution is bigger.

It is a little ugly, but it was the only work around I found at the time.

After udev starts, the script also bugs, since it will continue to display the progress bar, but not the image. To correct that, the only way I found is to change /etc/rc.d/rc.M


if [ -x /etc/rc.d/rc.udev ]; then
  /bin/sh /etc/rc.d/rc.udev start


if [ -x /etc/rc.d/rc.udev ]; then
      /bin/sh /etc/rc.d/rc.udev start
      /boot/initrd/bin/busybox fbsplash -s /boot/GSplash/shutdown.ppm

This will get the image to display again

All times are GMT -5. The time now is 01:53 PM.