-   Slackware (
-   -   ATI proprietary driver not working probperly with Radeon HD 5470 (

markush 11-02-2012 03:24 AM

ATI proprietary driver not working probperly with Radeon HD 5470

my Laptop has a Radeon HD5470 Graphics-adapter, I'm running Slackware64-14.0 and use generic kernel 3.5.4.

Yesterday I have installed the fglrx-driver from ATI (amd-driver-installer-catalyst-12.10). previously I've used the kernel's radeon-driver.

I've configured for hibernate and suspend which worked well with the radeon-driver.

Now there have two problems occured. I use to boot to runlevel 3 and then startx. When I shut down the X-server, The X-server closes (probably) but the screen freezes.
When trying to suspend the machine doesn't halt, it remains running with a dark screen.
My first attempt to work around the problems was to build a new initrd with the fglrx-module, but now X freezes before it starts.

Question: is there any configuration possible in xorg.conf which works around this issues? Or can there be a problem with the initrd?

Does anyone of you have suspend and hibernate working with the fglrx-driver?

Thanks in advance.


STDOUBT 11-02-2012 08:42 PM

I have a similar setup:
graphics HD6570, using catalyst-12.10.
I did nothing to configure suspend or hibernate.
To fix a related problem (TTY1-6 garbled when using fglrx), I found that adding "blacklist radeon"
to /etc/modprobe.d/blacklist.conf solved the suspend problem AND the garbed text in the TTYs.
Also, I use init3 and then run startx. I'm using the default 3.2.29-smp with an initrd that does not include the fglrx module.
I think it's pretty cool the proprietary installer gives an option to roll a distro-specific package. It actually detected Slackware, and made "fglrx-9.002-x86-1.tgz" for me.
The radeon driver is fantastic, but some stuff (megaglest for example) really runs better with fglrx.

Please note, I haven't tested hibernate, but suspend resumes well now by just tapping the spacebar.

markush 11-02-2012 08:47 PM

Thanks for the answer, I'll try that. I've thought about blacklisting the radeon-module, but I was not sure because I thought that the aticonfig --initial command had blacklisting the radeon module if this is necessary.


markush 11-02-2012 09:17 PM

Well, blacklisting radeon did the trick.

I've now rebuilt the initrd without the fglrx-module, this was not necessary.

Both, returning from X and suspend are working properly now.

Thanks very much to STDOUBT for the help.


BTW: I did build the fglrx-Slackwarepackage because it is much more convenient when the package has to be uninstalled.

All times are GMT -5. The time now is 05:55 AM.