-   Slackware (
-   -   Ati fglrx driver... strange bug (

kule 03-08-2005 09:57 AM

Ati fglrx driver... strange bug
I've installed fglrx_6_8_0-8.10.19-1.i386 without any errors, and fglrxinfo reports:

display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON 9600 XT Generic
OpenGL version string: 1.3.4893 (X4.3.0-8.10.19)

and when I run glxgears they run very slow, reporting:

15110 frames in 5.0 seconds = 3022.000 FPS
and when I run fgl_glxgears, they display a blak window and this is what the console says:

FGLTexMgr: open of shared memory object failed (Function not implemented)
__FGLTexMgrCreateObject: __FGLTexMgrSHMmalloc failed!!!

And none of my OpneGL games work or they wotk in like 1 FPS.

coffeedrinker 03-08-2005 10:41 AM

Add this line to your fstab:

tmpfs /dev/shm tmpfs defaults 0 0

kule 03-08-2005 10:52 AM

no, that didn't help, same error.

coffeedrinker 03-08-2005 11:20 AM

Sorry, I forgot to say you have to mount it too. It will mount automatically next time you boot.

kule 03-08-2005 11:59 AM

I mounted it and it still doesn't work :(

Darnaus 03-08-2005 12:20 PM

doing a "modprobe shm" should fix the problem. if it doesnt work.. check the line in your fstab to see if it's right.

That damn problem plagued me for a long time >_< That fixed all those errors for me, and finally 3D acceleration in games ran fine. BTW 3022 FPS isnt bad at all... i normally get around 1500-2000 depending on whats on the screen, etc etc.

good luck!

coffeedrinker 03-08-2005 12:22 PM

Try looking at the following page for more help:

edit: can't get it to put this url in

google search for:

Gentoo ATI Radeon FAQ

Shade 03-08-2005 12:29 PM

Make sure tmpfs or shm is enabled in your kernel.


kule 03-08-2005 02:49 PM


All times are GMT -5. The time now is 04:10 AM.