LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   ATI drivers and smp kernel (https://www.linuxquestions.org/questions/slackware-14/ati-drivers-and-smp-kernel-4175434603/)

cheese1343 10-29-2012 07:23 AM

ATI drivers and smp kernel
 
Hello, I am trying to install the catalyst driver, version 12.10 on my Slackware 14 and get the following error when trying to buildpkg

Error:
kernel includes at /lib/modules/3.2.29/build/include do not match current kernel.
they are versioned as "3.2.29-smp"
instead of "3.2.29".
you might need to adjust your symlinks:
- /usr/include
- /usr/src/linux
ERROR: I didn't make module

The problem is that I am running the smp kernel, in lilo.conf I have

image = /boot/vmlinuz-huge-smp-3.2.29-smp
root = /dev/sda1
label = Slackware

but uname -r still returns 3.2.29
Any ideas how to fix this?

NorthBridge 10-29-2012 08:20 AM

Run lilo -v to make it use the configuration in /etc/lilo.conf

cheese1343 10-29-2012 09:28 AM

Thank you, it worked! :)


All times are GMT -5. The time now is 08:24 PM.