-   Slackware (
-   -   ati driver question (

campher 07-15-2007 06:07 PM

ati driver question
after installing the ati driver 8.38.6 (thanks to old_fogie for the description and cwwilson721) the whole thing is dead slow.

when changing screen i first get empty window frames within two seconds text, icons and lines appear and scrolling is now only going in block segments. im not using any 3d effects its the normal kde screen without any animations and effects.

system is a ibm tp60 512mb ram ati x1300 64mb. i followed old_fogies installation, with the difference, that its no longer necessary to make a slackware package out of a rpm. after installation i run aticonfig and didnt change the xorg.conf.

is this lethargic behavior normal for the proprietary ati drivers or did i miss something?

my xorg.conf:

/etc/X11# cat xorg.conf
Section "ServerLayout"         
        Identifier    " Configured"
        Screen      0  "aticonfig-Screen[0]" 0 0
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"
        Option      "StandbyTime" "5"
        Option      "SuspendTime" "0"
        Option      "OffTime" "0"
Section "Files"               
        RgbPath      "/usr/X11R6/lib/X11/rgb"
        ModulePath  "/usr/X11R6/lib/modules"
        FontPath    "/usr/X11R6/lib/X11/fonts/misc/"
        FontPath    "/usr/X11R6/lib/X11/fonts/TTF/"
        FontPath    "/usr/X11R6/lib/X11/fonts/Type1/"
        FontPath    "/usr/X11R6/lib/X11/fonts/CID/"
        FontPath    "/usr/X11R6/lib/X11/fonts/75dpi/"
        FontPath    "/usr/X11R6/lib/X11/fonts/100dpi/"
Section "Module"               
        Load  "glx"           
        Load  "extmod"         
        Load  "xtrap"
        Load  "record"
        Load  "dbe"
        Load  "dri"
        Load  "freetype"
        Load  "type1"

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option      "XkbModel" "pc105"
        Option      "XkbLayout" "de(nodeadkeys)"

Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Protocol" "auto"
        Option      "Device" "/dev/mouse"
        Option      "Buttons" "3"
        Option      "ZAxisMapping" "4 5 6 7"

Section "Monitor"
        Identifier  "Monitor0"
        VendorName  "Monitor Vendor"
        ModelName    "Monitor Model"

Section "Monitor"
        Identifier  "aticonfig-Monitor[0]"
        Option      "VendorName" "ATI Proprietary Driver"
        Option      "ModelName" "Generic Autodetecting Monitor"
        Option      "DPMS" "true"

Section "Device"

        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option    "ShadowFB"                  # [<bool>]
        #Option    "DefaultRefresh"            # [<bool>]
        #Option    "ModeSetClearScreen"        # [<bool>]
        Identifier  "Card0"
        Driver      "vesa"
        VendorName  "ATI Technologies Inc"
        BoardName  "Unknown Board"
        BusID      "PCI:1:0:0"

Section "Device"
        Identifier  "aticonfig-Device[0]"
        Driver      "fglrx"
Section "Screen"
        Identifier "Screen0"
        Device    "Card0"
        Monitor    "Monitor0"
        DefaultDepth    24
        SubSection "Display"
                Viewport  0 0
                Depth    1
        SubSection "Display"
                Viewport  0 0
                Depth    4
        SubSection "Display"
                Viewport  0 0
                Depth    8
        SubSection "Display"
                Viewport  0 0
                Depth    15
        SubSection "Display"
                Viewport  0 0
                Depth    16
        SubSection "Display"
                Viewport  0 0
                Depth    24

Section "Screen"
        Identifier "aticonfig-Screen[0]"
        Device    "aticonfig-Device[0]"
        Monitor    "aticonfig-Monitor[0]"
        DefaultDepth    24
        SubSection "Display"
                Viewport  0 0
                Depth    24


if you find any mistakes take em be happy with them

Road_map 07-15-2007 06:14 PM

Your /etc/X11/xorg.conf file is incomplete. You better run xorgconfig or xorgsetup again.

symatic 07-16-2007 02:59 AM

make these changes if you havent:

add this to your fstab(this allows opengl 3D stuff):
tmpfs /dev/shm tmpfs defaults 0 0

mount tmpfs

okay then open up xorg.conf and add this to the bottom(Direct Rendering):

Section "DRI"
Mode 0666

Restart X and type in the console: fglrxinfo

should say ati yadda yadda yadda
if it says mesa something, then something is wrong.

actually read /usr/share/ati/fglrx-install.log
and make sure it actually built the module.
Then read /var/log/xorg.log
and see if the module is loading.

Doing the steps above is fine either way and will improve performance. I also like to clean things up in my xorg.conf once things are working and remove all the duplicate sections. Your xorg.conf file looks fine to me, actually looks quite similar to mine and it runs like a champ!?! <---only because ati is special. The only thing I was never able to run properly after the driver is the catalyst control panel. Don't really need it but i have dual monitor and would love to shut one off to play games. But what can ya do!


dunric 07-16-2007 04:07 AM

I'm not sure if it caused described problem but ATI's proprietary drivers are notorious with they even poorer performance in 2D then in 3D.
Try to add following record in aticonfig-Device[0] device section:

Option      "XaaNoOffscreenPixmaps" "on"
More in manpage for xorg.conf if interested.

If you do not need some concrete OpenGL extensions not yet implemented in Xorg driver I would reconsider to switch back to opensource version. I'm more happier with it - reliable suspend/resume to/from disk, no random X lockups, faster. I'm speaking about r300 driver from Xorg 7.2 and OpenGL library from Mesa 6.5 implementation - all contained in Slackware 12.0 .

campher 07-16-2007 06:29 PM

ok found the error
the kernel module is not inside the slackware package produced by the ati-installer. some mudheads decided to put this file inside a separate package and then tell people they have to install the kernel modules to get the driver installed properly. my kernel modules were installed during the last kernel change so i ignored this advice.

after fixing this and making the xorg.conf complete the whole thing is working faster, but still not as fast as the xorg driverbut now i got 2 monitors working.

thanks everybody for the help.


pete_bogg 07-17-2007 07:51 AM

I am currently using the default ATI driver that came with Slackware 12.0. I have the tmpfs and DRI statements in the correct places and am seeing glxgears in the 2000+ fps range. However, there are some 3D applications that are running slow.

With the default ATI driver, I cannot find fglrxinfo to check that I really am getting 3D rendering. Do I really need to install the current ATI driver from ATI?

symatic 07-18-2007 08:38 PM

fglxinfo is supplied with the ATI proprietary driver so you would not have it installed. Direct rendering is supported with the open source driver installed on slackware. I have heard some ppl have better performance with the ATI driver in /extra . But I don't know your harware situation. Just maybe something to look at.

syvy 07-19-2007 03:04 AM

Pete, use glxinfo to check if 3D is working.
If you got

direct rendering: Yes
it is.

All times are GMT -5. The time now is 04:59 PM.