-   Slackware (
-   -   ATi Catalyst driver 8.1 problem on Slack 10.2 (

brooky9999 02-07-2008 07:03 PM

ATi Catalyst driver 8.1 problem on Slack 10.2

I have the following problem.

I have installed the 8.1 drivers on my Slack 10.2 box. After a reboot, when I run 'fglrxinfo' as root, I get:

display: :0.0 screen: 0
OpenGL vendor string: ATI Tecnologies Inc.
OpenGL renderer string: Radeon X1900 Series
OPenGL version string: 2.1.7276 Release
However if I run it as a normal user, I get:
libGL error: open DRM failed (operation not permitted)
libGL error: Reverting to (slow) indirect rendering
display: :0.0 screen: 0
OpenGL vendor string: Mesa project:
OpenGL renderer string: Mesa GLX indirect
OPenGL version string: 1.2 (1.5 Mesa 6.2.1)
This obviously affects applications like Google Earth.

Anybody know why it reverts to Mesa when used as a non-root user?

Thanks for your time,


Jeebizz 02-07-2008 07:27 PM

Check at the end of your xorg.conf and make sure that the following is UN-commented.


 Section "DRI"
    Mode 0666

brooky9999 02-08-2008 04:09 AM

Hi Jeebiz,

Thank you for replying.

My xorg.conf file didn't have that section, so I added it and now all is well.

I'm now going to read up on how / why that fixed it.

Many thanks,


brooky9999 02-08-2008 06:32 AM

Hi Jeebiz,

Does this need any support in the kernel?

The reason I ask is that I have just upgraded my kernel to 2.6.24 and I'm back to square 1. 'fglrxinfo' now displays the Mesa message again.

However, if I boot back into my 2.6.23 kernel, its all okay.

Neither kernel has Direct Rendering Manager support enabled.

Any thoughts?


Uncle_Theodore 02-08-2008 06:35 AM

The module, fglrx, was compiled for your 2.6.23 kernel. Look into the /lib/modules/fglrx directory.

brooky9999 02-08-2008 09:10 AM

That's the one - thank you.

I don't know why I didn't spot that. Maybe another Red Bull will wake me up ;-)


All times are GMT -5. The time now is 01:06 PM.