-   Slackware (
-   -   ath0 DHCP Script Trouble (

pxumsgdxpcvjm 01-24-2007 02:37 AM

ath0 DHCP Script Trouble
Sorry, if this has been resolved before. I've tried searching but nothing came up.

For some strange reason, my ath0 interface isn't being setup for DHCP at startup when it should be. I'm running an almost fresh install of Slackware 11.0.

I know for a fact that my wireless network is currently setup and working fine. I followed the guide located here. To connect to the network (and via that, the Internet) I need to run the command 'dhcpcd -h Sen ath0' once the startup has completed.

My /etc/rc.d/rc.inet1.conf contains 'USE_DHCP[0]="yes"' (under the ath0 selection) but it doesn't appear to make a difference.

I did a little research and found that this part of /etc/rc.d/rc.inet1 causes DHCP to run...

      if [ "${USE_DHCP[$i]}" = "yes" ]; then # use DHCP to bring interface up
        [ ${DHCP_HOSTNAME[$i]} ] && DHCP_OPTIONS="-h ${DHCP_HOSTNAME[$i]}"
        [ "${DHCP_KEEPRESOLV[$i]}" = "yes" ] && DHCP_OPTIONS="$DHCP_OPTIONS -R"
        [ "${DHCP_KEEPNTP[$i]}" = "yes" ] && DHCP_OPTIONS="$DHCP_OPTIONS -N"
        [ "${DHCP_KEEPGW[$i]}" = "yes" ] && DHCP_OPTIONS="$DHCP_OPTIONS -G"
        [ ${DHCP_IPADDR[$i]} ] && DHCP_OPTIONS="$DHCP_OPTIONS -s ${DHCP_IPADDR[$i]}"
        echo "/etc/rc.d/rc.inet1:  /sbin/dhcpcd -d -t ${DHCP_TIMEOUT[$i]:-60} ${DHCP_OPTIONS} ${1}" | $LOGGER
        /sbin/dhcpcd -d -t ${DHCP_TIMEOUT[$i]:-60} ${DHCP_OPTIONS} ${1}
      else # bring up interface using a static IP address

I've tried adding an echo statement to it to tell me what was going on and I found that it's calling '/sbin/dhcp -d -t 60 -h Sen eth0'. The strange thing is that I have no eth0 configured anywhere and the only matches of 'eth0' in the entire /etc/rc.d directory are just under script comments.

What causing eth0 to be set? Any ideas? Sorry, if there is an obvious answer. I'm quite newbie when it comes to Linux and bash scripting.

Huge thanks to any replies.

pxumsgdxpcvjm 01-24-2007 03:41 AM

Alright, this has been resolved. Could someone delete this thread.

onebuck 01-24-2007 07:15 AM


Originally Posted by pxumsgdxpcvjm
Alright, this has been resolved. Could someone delete this thread.


Post how you resolved the problem. No matter how embarrassing it may seem, we all make silly mistakes.

That way another user may find the solution on LQ with a search. Just to request a deletion helps no one.

All times are GMT -5. The time now is 12:10 AM.