-   Slackware (
-   -   Arduino MEGA 2560 REV3, Arduino IDE working software versions (

jamesf 04-30-2012 07:00 PM

Arduino MEGA 2560 REV3, Arduino IDE working software versions
I purchased an Arduino MEGA 2560 REV3 board and couldn't program it using slackware-current and the avr-* and Arduino IDE package versions from

I used the slackbuilds as a basis for newer version packages just by changing the version number in the .Slackbuild, downloading newer source from the site of the slackbuilds source link, and building my own package.

Here are the software versions that work for me:

1.) Slackware 13.37 upgraded to current as of 4/30/2012
2.) avr-binutils-2.22-i486-1_SBo (upgraded from slackbuilds version)
3.) avr-gcc-4.6.3-i486-1_SBo (upgraded from slackbuilds version)
4.) avr-libc-1.7.1-i486-1_SBo
5.) arduino-1.0-i486-2_SBo (I believe I used the slackbuilds source version)

I tried several combinations of various packages. Some worked, some did not.

Both an older (but web-recommended) 2.20 version and a newer version of avr-binutils worked, I chose the newer one. I do not believe that I tried the slackbuilds version of this package.

The big key to the whole thing seemed to be the avr-gcc version used. The slackbuilds 4.5.3 would not generate a program that could run on the 2560. There were so many versions of gcc that I simply chose one of the latest and hoped it worked. It did.

Arduino IDE 1.0 works well.

I had confirmed that I did not have a USB serial problem by writing code for the board on a Linux Mint 11 install, verifying that the code ran through the Arduino 0022 IDE Serial Monitor, and then successfully seeing the code running using the Arduino Serial Monitor under slackware even before slackware could compile working programs.

Two things to avoid:
1.) Do not attempt to connect the Arduino board through a USB hub. Timing errors were all I got in this case.
2.) Slackware doesn't automatically add or suggest adding users to the 'dialout' group. suggests some trickery with hal to create /dev/ttyACM0 with global r/w permissions. As root I added myself to the dialout group with 'usermod -a -G dialout james'. This seems to work as well.

I hope that this helps someone. I'll mark the thread as solved. (If I can figure out how to do so.)

EDIT: The version of avrdude that was included in the Arduino IDE 1.0 worked for me with no modifications to the boards.txt or conf files. You'll see a lot of such suggestions for the 2560, none of them helped me.

EricTRA 05-02-2012 01:56 AM


Thank you for sharing. Off the Zero Reply List.

Kind regards,


All times are GMT -5. The time now is 02:27 AM.