-   Slackware (
-   -   Arduino IDE not working (

brianL 02-28-2013 06:27 AM

Arduino IDE not working
On Slack64 14.0, using KDE, trying to run the slackbuilds package. When I click on the Arduino IDE entry in the menu, it appears in the kicker briefly, then disappears. So I tried it from the terminal, and got this:

bash-4.2$ /opt/arduino/arduino
java: relocation error: java: symbol JLI_Launch, version SUNWprivate_1.1 not defined in file with link time reference

Any ideas? TIA.

Lirey 02-28-2013 09:30 PM

I'm not sure if I can be of any help, but I'm guessing that the problem is either due to some sort of incompatibility between software versions, or java not being properly installed. What versions of the Arduino IDE and java do you have installed?

I'm currently using Arduino 1.0.3, and I haven't had any problems using Oracle's JDK version 7u13 (until recently) and now 7U15.

You may also want to check that java is able to find

- Lirey

brianL 03-01-2013 04:47 AM

I've got Oracle's 7u15. The arduino from SlackBuilds is 1.0.2, but I've just tried downloading, unpacking, and running 1.0.3 with the same results. It does look like java can't find something that's right under its nose. is in /usr/lib64/java/jre/lib/amd64/jli.

brianL 03-02-2013 05:19 AM

I removed Oracle's JDK and Arduino, installed Eric's OpenJDK and reinstalled Arduino. And now everything works OK. A victory for open source!
Praise "Bob" for Alien Bob! :)

All times are GMT -5. The time now is 11:07 AM.