-   Slackware (
-   -   APSFilter Epson 760 Gimp drivers (

joel1 12-02-2002 05:03 PM

APSFilter Epson 760 Gimp drivers
I am trying yet again to get printing working under Slack :(

I have tried to set APSfilter but whichever printer I choose it just prints out pages of code when I test, and if I try to print after accepting this I get the same code.

Under Ghost my printer is not listed, however under gimp the Epson 760 is listed but if I choose it, it tells me that gimp wsa compiled without my driver. Do I just download gimp source and compile over the top (or remove gimp first), or is there a way to just add the driver!

Aussie 12-03-2002 12:05 AM

You don't need to download gimp, you need to download gimp-print.

joel 12-03-2002 01:00 AM

Thanks bern, actually my lazy typing I meant gimp-print :)

joel 12-03-2002 01:10 AM

After installing gimp-print and reinstalling ghostprint with "--with-gimp-print" I still get:

"Enter number: 48

Error: Your gs version doesn't have driver "stp" compiled in...
Select another driver or build a new gs version with complete or customized
driver support.

Now you'll see a list of drivers supported by your gs version...

Press <RETURN> to continue"

When I get a list 48 (epson 760) is there but even after isntalling gimp-print, it still gives me the message above in APSFilter setup.

Aussie 12-03-2002 01:56 AM

What driver options are you passing to ghostscript when you run configure?

joel 12-03-2002 02:05 AM

none the README for gimp just said to do

"configure --with-gimp-print"

so I did that!

Aussie 12-03-2002 02:32 AM

What version of GNU-ghostscript are you using?

joel 12-03-2002 04:59 AM


Aussie 12-03-2002 05:38 AM

Well, GNU Ghostscript only goes up to 7.05, if you have version 8.0 then you have AFPL Ghostscript, but I think you should try ESP Ghostscript, which has more up-to date gimp-print support.
Have a look here for some more info on all three flavours of ghostscript.

joel 12-03-2002 06:02 AM

Ok thanks again Bern I will give GNU version 7.05 a try....

joel 12-03-2002 06:37 AM

OK some progression, it finds the printer driver now but when I print the Test page I get the following:

"Creating test page...
Error: /invalidfont in findfont
Operand stack:
f1 (Times-Roman) (Times-Roman) Font (Times-Roman) 358023 (Times-Roman) --nostringval-- Courier NimbusMonL-Regu (NimbusMonL-Regu) NimbusMonL-Regu (NimbusMonL-Regu) NimbusMonL-Regu
Execution stack:
%interp_exit .runexec2 --nostringval-- --nostringval-- --nostringval-- 2 %stopped_push --nostringval-- --nostringval-- --nostringval-- false 1 %stopped_push 1 3 %oparray_pop 1 3 %oparray_pop 1 3 %oparray_pop .runexec2 --nostringval-- --nostringval-- --nostringval-- 2 %stopped_push --nostringval-- --nostringval-- 3 3 %oparray_pop 4 3 %oparray_pop --nostringval-- --nostringval-- --nostringval-- --nostringval-- --nostringval-- false 1 %stopped_push 7 4 %oparray_pop --nostringval-- --nostringval-- --nostringval-- 5 -1 1 --nostringval-- %for_neg_int_continue --nostringval-- --nostringval--
Dictionary stack:
--dict:1057/1123(ro)(G)-- --dict:0/20(G)-- --dict:100/200(L)-- --dict:17/17(ro)(G)-- --dict:1057/1123(ro)(G)--
Current allocation mode is local
Last OS error: 2
Current file position is 5546
ESP Ghostscript 7.05.5: Unrecoverable error, exit code 1

real 0m0.091s
user 0m0.070s
sys 0m0.020s

Printing test page...
ls: /tmp/apsfilter10210/test_page.aps: No such file or directory
cat: /tmp/apsfilter10210/test_page.aps: No such file or directory

real 0m0.002s
user 0m0.000s
sys 0m0.000s

Also KDE doesn't "see" any print device!

Aussie 12-03-2002 06:47 AM

Have you tried cups yet? I've never had any luck with apsfilter and my usb printer, as for the font problem do you have the MS core fonts installed?

joel 12-03-2002 06:50 AM

CUPS has other problems, all appears to work fine, but when I print nothing happens, I may have to go back to trying cups! :(

And no haven't installed the MS core fonts yet!

Though to test the printer in KDE, what do I set its location as, I tried '/dev/lp0' and get a message about no rights to write to '.'

P.S. My printer is uses lpt1 not a usb printer... printing under slackware has always been the most difficult task for me :(

Aussie 12-03-2002 07:57 AM

Try "chmod 666 /dev/lp0".
My printer is a HP810c USB and I use cups-1.14 with foomatic and the hpijs driver.

joel1 12-03-2002 04:35 PM

tried that, I might reinstall Slackware 8.1 tonight, only just reinstalled it the other day after trying gentoo so no biggy....

Restarting with APSFilter may help as I have probably made a mess putting cups, EPS trial, and various forms of ghostscript on...

All times are GMT -5. The time now is 11:01 PM.