LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 08-27-2015, 04:27 AM   #1
lensilvan
Member
 
Registered: Jun 2013
Distribution: Arch Linux, Mintppc, Slackware
Posts: 159

Rep: Reputation: Disabled
Apple keyboard doesn't work anymore, even on console mode.


Hi.

I use a macbook 5.2 with Slackware 14.1 x86 64 (not current). Since I saw that the alt key didn't work, especially when necessary to go to tty consoles, I ran the following command I saw in the Archlinux wiki:

Code:
$ echo options hid_apple swap_opt_cmd=1 | sudo tee -a /etc/modprobe.d/hid_apple.conf
However, upon rebooting, after LILO, the keyboard doesn't work at all. From KDM, I even switched to console mode but even there the keyboard doesn't work.

What to do in this case?

Last edited by lensilvan; 08-27-2015 at 07:59 AM.
 
Old 08-27-2015, 04:44 AM   #2
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slint64-14.2 on Lenovo Thinkpad W520
Posts: 7,693

Rep: Reputation: 2611Reputation: 2611Reputation: 2611Reputation: 2611Reputation: 2611Reputation: 2611Reputation: 2611Reputation: 2611Reputation: 2611Reputation: 2611Reputation: 2611
If multiboot, start Arch or Mint, mount your Slackware root (/) partition, for instance on /mnt, and "rm /mnt/etc/modprobe.d/hid_apple.conf".
If not, do that from the Slackware installer: start it, then as soon as you are logged in as "root" mount your Slackware root (/) partition on /mnt and "rm /mnt/etc/modprobe.d/hid_apple.conf".

Next time don't blindly follow an advice, especially if it's not intended for the same distribution.

PS But it could be interesting to see the full content of /etc/modprobe.d/hid_apple.conf in Arch. Maybe that could help understand why you get a different behavior in Arch vs Slackware. Maybe.

Last edited by Didier Spaier; 08-27-2015 at 07:03 AM. Reason: Wrong path in command fixed.
 
Old 08-27-2015, 07:59 AM   #3
lensilvan
Member
 
Registered: Jun 2013
Distribution: Arch Linux, Mintppc, Slackware
Posts: 159

Original Poster
Rep: Reputation: Disabled
I chrooted in my system, and now everything is fine. Topic solved, thanks.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Try to disable console output, console=null doesn't work embLinux Linux - Kernel 5 03-04-2014 03:21 AM
[SOLVED] After upgrade, my mouse/keyboard don't work anymore in X. BILLYKANE Slackware 5 09-15-2010 07:25 AM
automount doesn't work anymore cracorange Linux - General 3 08-17-2009 10:22 PM
PHP doesn't work anymore nyk Linux - Software 4 10-06-2004 03:51 AM
CXoffice doesn't work anymore? flamesrock Linux - Software 0 07-07-2004 01:59 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 01:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration