-   Slackware (
-   -   APC UPS not found by xfce4-power-manager or upower in slackware 14.1 (

Rod3775 11-08-2013 07:36 PM

APC UPS not found by xfce4-power-manager or upower in slackware 14.1
In slackware-14.0, the command 'upower -d' lists both information
about the upowerd daemon configuration and a USB-attached APC UPS.

In slackware-14.1, only the upowerd info is listed by this command. apcupsd and apcaccess work normally on both systems (same machine, same hardware, dual boot). 14.1 (kernel 3.10.17) loads a module named 'hid_generic' which doesn't exist in 14.0 (kernel 3.2.45), but otherwise the module differences are what one would expect.

In 3.2.45, the APC device is /org/freedesktop/UPower/devices/ups_hiddev0. Both slackwares run the same upower slackpackage version(0.9.17), as released.

Rod3775 11-08-2013 11:05 PM

more info: In kernel-3.2.45, the USB interface for the UPS is in /sys/class/usb.
In kernel-3.10.17, it is in /sys/class/usbmisc.
Obviously, the format of sysfs has changed, and perhaps upower needs upstream repair. For what it's worth, I tried compiling upower-0.9.23 from It compiles, but fails the same way. Their latest version - upower-0.99 - won't compile on slackware-14.1

BTW, on slackware-14.0, my USB printer shows up in /sys/class/usb also. Don't know where it went in 14.1 So there may be printing issues ahead with 14.1 as well...

wildwizard 11-09-2013 02:04 AM

0.99.0 is a beta release for upower 1.0 with API changes and more so avoid that

0.9.23 should work but the 95-upower-hid.rules file is out of date and you can get the new version from the 0.99.0 src package.

That new rules file enables usbmisc as well as usb, I don;t know why it is not included when the rest of the patch to fix the problem is included.

See here for more :-


Tested fix and it works here

ATTN Pat fix for 14.1 No. 2

Rod3775 11-09-2013 12:27 PM

As wildwizard points out, the udev rules have changed. upower-0.9.23 worked fine once I rebooted. I erroneously assumed that the problem was in the code itself, not the exported rules. Installpkg updates the code and the rules, but doesn't restart udev (duh!) so it looked like the newer version didn't work. My bad.

wildwizard 11-09-2013 04:05 PM

I did note an issue on my system where suspend and hibernate disappear, as I never use them I have no idea if that should or should not happen.

Rod3775 11-19-2013 11:09 AM

[NOT SOLVED] The recent(11/19/13) upgrade of upower ( -1) is still upower-0.9.17 and is still broken.

[SOLVED] Reinstalled upower-0.9.23 to get the correct udev rules.

[BTW] I'll bet a number of the other threads reporting problems with HID devices (headsets,etc) are tied to other packages not coping with the changes to sysfs in kernel 3.10.17!

All times are GMT -5. The time now is 09:49 PM.