-   Slackware (
-   -   Apache Connection time-out problems (

bogzab 11-28-2012 03:12 AM

Apache Connection time-out problems
My first steps in setting up an apache server are partially successful - I can get a response on the host PC by asking for the page : http://localhost. However when I try and get to the same page from another PC on my LAN, using its IP LAN address I get a connection timeout. Konqueror reports "Although contact was made with the server, a response was not received within the amount of time allocated for the request".

I have set up the apache server according to the HOWTO setup apache, php and mysql in Slackware docs. All the steps there work fine and checkout - but they are confined to testing on localhost.

I can contact the server PC from other PCs on the LAN by ping and by ftp on port 22. There is currently no firewall set up on the server, although a minimal firewall is active on the LAN router.

I tried configuring the apache server to listen on port 8000 instead of 80. Again this worked fine in local mode getting http://localhost:8000 but fails from another PC on the LAN if I ask for http://<server ip address>:8000.

Something obvious I am missing?

willysr 11-28-2012 04:22 AM

You might want to check the apache logs first to see if there's a request from that client
If not, the problem might be the network configuration

bogzab 11-28-2012 05:22 AM

httpd access_log shows only the local host (127.0.01) access requests. So my problem must be in getting the request to the server rather than with server config. Thanks for the insight. Unfortunately I guess there could be a wide range of places to look!

bogzab 11-28-2012 10:23 AM

Solved. I feel foolish. There **was** a firewall enabled on the server. I had tried to test whether this was the case by running

ps x | grep iptables
but I now realise that this is a poor diagnostic. I had a script rc.firewall in /etc/rc.d which was executable and had installed a firewall. I am happy to see that it is effective, although annoyed with myself that I spent all morning looking for firewall settings on my router when I should have checked out the server better.

All times are GMT -5. The time now is 07:38 PM.