LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 11-13-2015, 12:20 PM   #1
dugan
LQ Guru
 
Registered: Nov 2003
Location: Canada
Distribution: distro hopper
Posts: 9,663

Rep: Reputation: 4314Reputation: 4314Reputation: 4314Reputation: 4314Reputation: 4314Reputation: 4314Reputation: 4314Reputation: 4314Reputation: 4314Reputation: 4314Reputation: 4314
Anyone using Alien Bob's KDE5?


I'm thinking of trying out Alien Bob's KDE5 build. Anyone here using it?
 
Old 11-13-2015, 12:23 PM   #2
kikinovak
MLED Founder
 
Registered: Jun 2011
Location: Montpezat (South France)
Distribution: CentOS, OpenSUSE
Posts: 3,441

Rep: Reputation: 2108Reputation: 2108Reputation: 2108Reputation: 2108Reputation: 2108Reputation: 2108Reputation: 2108Reputation: 2108Reputation: 2108Reputation: 2108Reputation: 2108
Quote:
Originally Posted by dugan View Post
I'm thinking of trying out Alien Bob's KDE5 build. Anyone here using it?
Judging from the numerous comments on his blog, I'd say yes, quite definitely.
 
Old 11-13-2015, 12:48 PM   #3
gmgf
Senior Member
 
Registered: Jun 2012
Location: Bergerac, France
Distribution: Slackware
Posts: 1,802

Rep: Reputation: 713Reputation: 713Reputation: 713Reputation: 713Reputation: 713Reputation: 713Reputation: 713
me
 
Old 11-13-2015, 01:11 PM   #4
Tonus
Member
 
Registered: Jan 2007
Location: Paris, France
Distribution: Slackware-current
Posts: 666
Blog Entries: 3

Rep: Reputation: 174Reputation: 174
Anyone using Alien Bob's KDE5?

I do.

Can't connect with Telepathy on my side but I don't use it.

I'd suggest you wait few days for next release ;-)
 
Old 11-13-2015, 02:26 PM   #5
dugan
LQ Guru
 
Registered: Nov 2003
Location: Canada
Distribution: distro hopper
Posts: 9,663

Original Poster
Rep: Reputation: 4314Reputation: 4314Reputation: 4314Reputation: 4314Reputation: 4314Reputation: 4314Reputation: 4314Reputation: 4314Reputation: 4314Reputation: 4314Reputation: 4314
Full disclosure: one of the reasons I'm interested in KDE5 is because it's a dependency for LXQt.
 
Old 11-13-2015, 02:40 PM   #6
gmgf
Senior Member
 
Registered: Jun 2012
Location: Bergerac, France
Distribution: Slackware
Posts: 1,802

Rep: Reputation: 713Reputation: 713Reputation: 713Reputation: 713Reputation: 713Reputation: 713Reputation: 713
it depend of qt5, but not of kde
 
Old 11-13-2015, 03:27 PM   #7
dugan
LQ Guru
 
Registered: Nov 2003
Location: Canada
Distribution: distro hopper
Posts: 9,663

Original Poster
Rep: Reputation: 4314Reputation: 4314Reputation: 4314Reputation: 4314Reputation: 4314Reputation: 4314Reputation: 4314Reputation: 4314Reputation: 4314Reputation: 4314Reputation: 4314
Quote:
Originally Posted by gmgf View Post
it depend of qt5, but not of kde
It needs KDE Framework 5 as well as Qt 5.

Believe me, I tried to build it with just Qt 5.
 
Old 11-13-2015, 03:39 PM   #8
kikinovak
MLED Founder
 
Registered: Jun 2011
Location: Montpezat (South France)
Distribution: CentOS, OpenSUSE
Posts: 3,441

Rep: Reputation: 2108Reputation: 2108Reputation: 2108Reputation: 2108Reputation: 2108Reputation: 2108Reputation: 2108Reputation: 2108Reputation: 2108Reputation: 2108Reputation: 2108
Quote:
Originally Posted by dugan View Post
It needs KDE Framework 5 as well as Qt 5.

Believe me, I tried to build it with just Qt 5.
You might want to double-check your facts.
 
Old 11-13-2015, 03:40 PM   #9
dugan
LQ Guru
 
Registered: Nov 2003
Location: Canada
Distribution: distro hopper
Posts: 9,663

Original Poster
Rep: Reputation: 4314Reputation: 4314Reputation: 4314Reputation: 4314Reputation: 4314Reputation: 4314Reputation: 4314Reputation: 4314Reputation: 4314Reputation: 4314Reputation: 4314
Quote:
Originally Posted by gmgf View Post
it depend of qt5, but not of kde
Quote:
Originally Posted by kikinovak View Post
You might want to double-check your facts.
Okay, what did I miss that you two got?

You can see right here that KDE Framework 5 is a compile-time dependency for the current version of liblxqt. This is consistent with the results I actually got:

https://github.com/lxde/liblxqt/blob...Lists.txt#L138

Code:
find_package(KF5WindowSystem REQUIRED QUIET)
And it's documented as a dependency on the official LXQt homepage:

http://wiki.lxde.org/en/Build_LXQt_From_Source#liblxqt

Quote:
  • Prerequisite: cmake >= 2.8.11, qt >= 5.3, KWindowSystem, libqtxdg

Last edited by dugan; 11-13-2015 at 03:49 PM.
 
Old 11-13-2015, 03:56 PM   #10
gmgf
Senior Member
 
Registered: Jun 2012
Location: Bergerac, France
Distribution: Slackware
Posts: 1,802

Rep: Reputation: 713Reputation: 713Reputation: 713Reputation: 713Reputation: 713Reputation: 713Reputation: 713
yes, but it seem, that kwindowsystem depend just of qt5.
 
1 members found this post helpful.
Old 11-13-2015, 04:41 PM   #11
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 8,078

Rep: Reputation: 6865Reputation: 6865Reputation: 6865Reputation: 6865Reputation: 6865Reputation: 6865Reputation: 6865Reputation: 6865Reputation: 6865Reputation: 6865Reputation: 6865
dugan, you just need the KDE Frameworks. The rest of KDE 5 (Plasma, Applications) is not required for LXQT.

To facilitate people who build LXQT, I have made a proper subrepository out of my Framework packages, read the section "A note on Frameworks" in http://alien.slackbook.org/blog/kde-...ngs-telepathy/ for instance.
 
1 members found this post helpful.
Old 12-05-2015, 06:15 PM   #12
dugan
LQ Guru
 
Registered: Nov 2003
Location: Canada
Distribution: distro hopper
Posts: 9,663

Original Poster
Rep: Reputation: 4314Reputation: 4314Reputation: 4314Reputation: 4314Reputation: 4314Reputation: 4314Reputation: 4314Reputation: 4314Reputation: 4314Reputation: 4314Reputation: 4314
I made the switch to Plasma 5 today. It was completely seamless and trouble free. Great work, Alien Bob!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Alien BOB bmarley83 Slackware 29 01-24-2014 03:18 PM
[SOLVED] Vote for Alien Bob samac Slackware 49 08-27-2013 08:48 PM
Alien Bob's Blog. cwizardone Slackware 15 01-19-2012 05:29 AM
Alien Bob's Server Down? vtel57 Slackware 8 03-28-2011 08:51 PM
One for Alien Bob cwwilson721 Slackware 28 08-15-2006 04:26 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 11:08 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration