LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 12-16-2011, 10:23 AM   #1
vdemuth
Member
 
Registered: Oct 2003
Location: West Midlands, UK
Distribution: Slackware 14 (Server),OpenSuse 13.2 (Laptop & Desktop),, OpenSuse 13.2 on the wifes lappy
Posts: 781

Rep: Reputation: 98
Anyone managed to get owncloud running?


Been looking at owncloud, which seems to be quite an exciting project. However, having installed it on my home server, I cant seem to get any further and accessing it via the server results in just a blank page, as if the php interpreter is not functioning. However, other php based servers on the same box work well, so I have pretty much ruled that out.
Anyone here tried it and had success getting it going at all, and if so, any pointers?

TIA
 
Old 12-16-2011, 12:47 PM   #2
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 7,439

Rep: Reputation: 5692Reputation: 5692Reputation: 5692Reputation: 5692Reputation: 5692Reputation: 5692Reputation: 5692Reputation: 5692Reputation: 5692Reputation: 5692Reputation: 5692
Works here (Slackware 13.37 64-bit) without any weird hoops to jump through. Ever since their first release.

My work notes state:
Code:
  - Download owncloud-2 from http://owncloud.org/
  - unpack into the DocumentRoot of the webserver (here, '/home/www')
  - make apache owner:
    # chown -R www:wheel ~www/sox/owncloud
  - Add these lines to /etc/httpd/httpd.conf (the directory 'owncloud' is below DocumentRoot):
      <Directory /home/www/owncloud>
          AllowOverride AuthConfig FileInfo Options Limit
      </Directory>
  - Run the setup wizard at http://localhost/owncloud/
  - Enable various applications (storage, bookmarks) in the admin setup
Eric
 
Old 12-16-2011, 01:19 PM   #3
vdemuth
Member
 
Registered: Oct 2003
Location: West Midlands, UK
Distribution: Slackware 14 (Server),OpenSuse 13.2 (Laptop & Desktop),, OpenSuse 13.2 on the wifes lappy
Posts: 781

Original Poster
Rep: Reputation: 98
Hi Alien Bob,

OK, here are the steps I took.

Downloaded from owncloud.org

Uploaded to server (called blackpig on 192.168.1.200) via ftp to /home/ftp

chown -R -v apache:apache /home/ftp/owncloud

Create symlink to /var/www/htdocs/owncloud

Made new directory data and gave perms 0750

Ensure config directory perms 0777

go to http://192.168.1.200/owncloud and am faced with a blank page.

Tried setting up a virtual server at port 8080 just for owncloud on the off chance it might be some strange interaction with standard web services I have running, but still the same response.

So effectively, I think I have installed it correctly, but I am getting no setup wizard or anything else for that matter when browsing to it.

Just to let you know, I have other services running from the same server without problem, i.e. mediatomb, ampache and plex.

Any other suggestions?

Thanks
 
Old 12-16-2011, 01:20 PM   #4
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 4,663

Rep: Reputation: Disabled
I have it running too but under lighttpd with no particular configuration for it: just a folder under the web root and mod_webdav (the equivalent of mod_dav under apache).

have you try adding to your httpd.conf the lines Eric hints above?

Last edited by ponce; 12-16-2011 at 01:25 PM.
 
Old 12-16-2011, 01:46 PM   #5
vdemuth
Member
 
Registered: Oct 2003
Location: West Midlands, UK
Distribution: Slackware 14 (Server),OpenSuse 13.2 (Laptop & Desktop),, OpenSuse 13.2 on the wifes lappy
Posts: 781

Original Poster
Rep: Reputation: 98
Hi Ponce,

Have added the lines as suggested but to no avail. Just going off to download it again just in case it corrupted on the way here. Will then start the install again from scratch and let you know. Meanwhile can you see any errors in the steps I have outlined above?

Thanks
 
Old 12-16-2011, 01:54 PM   #6
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 4,663

Rep: Reputation: Disabled
maybe you can try without the symlink in the web root and with a real folder under it.
also the data folder already should be in the owncloud one.

but, better, you can also try from scratch following directly the procedure Eric listed above

Last edited by ponce; 12-16-2011 at 01:56 PM.
 
Old 12-16-2011, 02:11 PM   #7
vdemuth
Member
 
Registered: Oct 2003
Location: West Midlands, UK
Distribution: Slackware 14 (Server),OpenSuse 13.2 (Laptop & Desktop),, OpenSuse 13.2 on the wifes lappy
Posts: 781

Original Poster
Rep: Reputation: 98
OK, re-downloaded and put onto server directly under the /var/www/htdocs directory, so no symlink. Set the directive as specified by Eric, and still have the same.

Any more ideas?
 
Old 12-16-2011, 02:21 PM   #8
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 4,663

Rep: Reputation: Disabled
I suggest you to look at /var/log/httpd/error.log, /var/log/httpd/access.log and maybe also set in /etc/httpd/php.ini (then restart the webserver)
Code:
error_log = /tmp/php_errors.log
to spot some possible related php errors.

Last edited by ponce; 12-16-2011 at 02:34 PM. Reason: changed /var/log/apache to /var/log/httpd, deformation from working also with debian webservers ;P
 
Old 12-17-2011, 04:15 AM   #9
vdemuth
Member
 
Registered: Oct 2003
Location: West Midlands, UK
Distribution: Slackware 14 (Server),OpenSuse 13.2 (Laptop & Desktop),, OpenSuse 13.2 on the wifes lappy
Posts: 781

Original Poster
Rep: Reputation: 98
Well, it seems to be missing the dbase.so and mhash.so libs. Googled for Slackware versions, but found none. Nothing on slackbuilds.
I don't suppose you have them anywhere, or a slackbuild for them, or do I have to go down the route of using pecl to try and build them which I am having other problems with.
 
Old 12-17-2011, 04:24 AM   #10
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 7,439

Rep: Reputation: 5692Reputation: 5692Reputation: 5692Reputation: 5692Reputation: 5692Reputation: 5692Reputation: 5692Reputation: 5692Reputation: 5692Reputation: 5692Reputation: 5692
I have no dbase.so on my system but "/usr/lib64/libmhash.so" is part of Slackware's mhash package.

Eric
 
Old 12-17-2011, 04:40 AM   #11
vdemuth
Member
 
Registered: Oct 2003
Location: West Midlands, UK
Distribution: Slackware 14 (Server),OpenSuse 13.2 (Laptop & Desktop),, OpenSuse 13.2 on the wifes lappy
Posts: 781

Original Poster
Rep: Reputation: 98
Hi Eric,

Here's a snippet from the error log, it seems to be looking for dbase.so. along with OC_Util. Any suggestions?

Quote:
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php/extensions/dbase.so' - /usr/lib/php/extensions/dbase.so: cannot open shared object file: No such file or directory in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php/extensions/mhash.so' - /usr/lib/php/extensions/mhash.so: cannot open shared object file: No such file or directory in Unknown on line 0
[Sat Dec 17 09:15:48 2011] [notice] Apache/2.2.21 (Unix) DAV/2 PHP/5.3.8 configured -- resuming normal operations
[Sat Dec 17 09:16:49 2011] [error] [client 192.168.1.100] PHP Fatal error: Class 'OC_Util' not found in /var/www/htdocs/owncloud/lib/base.php on line 123
Thanks

Last edited by vdemuth; 12-17-2011 at 05:30 AM.
 
Old 12-17-2011, 06:58 AM   #12
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 7,439

Rep: Reputation: 5692Reputation: 5692Reputation: 5692Reputation: 5692Reputation: 5692Reputation: 5692Reputation: 5692Reputation: 5692Reputation: 5692Reputation: 5692Reputation: 5692
You may be suffering from an old php.ini file which tries to load these PHP extensions. In slackware 13.37 you will find this in /etc/httpd/php.ini :
Code:
; Moved to the PECL repository, no longer bundled with PHP as of PHP 5.3.0
;extension=dbase.so

...

; Obsoleted, now uses hash instead mhash:
;extension=mhash.so
As for the error about OC_Util, I have no idea, perhaps that will sort itself out. What version of OpenCloud did you download & install?

Eric
 
Old 12-17-2011, 07:25 AM   #13
Uzuki
LQ Newbie
 
Registered: Jun 2010
Location: Indonesia
Distribution: Slackware, RedHat
Posts: 27

Rep: Reputation: 4
Quote:
Originally Posted by vdemuth View Post
Well, it seems to be missing the dbase.so and mhash.so libs. Googled for Slackware versions, but found none. Nothing on slackbuilds.
I don't suppose you have them anywhere, or a slackbuild for them, or do I have to go down the route of using pecl to try and build them which I am having other problems with.
dbase.so and mhash.so are php extensions. You have to install it separately. To install dbase.so, do this:

Download dbase source :
svn co http://svn.php.net/repository/pecl/dbase/trunk dbase
cd dbase
phpize
./configure
make

you will have the dbase.so under dbase/modules directory. Copy dbase.so into your php extensions directory, edit your php.ini, add this line: extension=dbase.so and restart your webserver.

For mhash.so, just search the source from pecl repo and do the same.
 
Old 12-17-2011, 07:36 AM   #14
vdemuth
Member
 
Registered: Oct 2003
Location: West Midlands, UK
Distribution: Slackware 14 (Server),OpenSuse 13.2 (Laptop & Desktop),, OpenSuse 13.2 on the wifes lappy
Posts: 781

Original Poster
Rep: Reputation: 98
Re-installed php having first deleted the ini file. That got rid of the php lib not found errors. Thanks for that.
As for owncloud, I have tried all of the different versions from the website. The current state is as follows:

With v1.2 installed, having completely removed v2.0.1 first. Still getting the OC_util error

Uninstall v1.2 and install v 2.0.1 (or the latest from git) then the blank page and the OC_util error still there

Have you any more suggestions, or do you think this needs referring back to the devs?

Last edited by vdemuth; 12-17-2011 at 07:58 AM. Reason: better information
 
Old 12-17-2011, 08:14 AM   #15
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 4,663

Rep: Reputation: Disabled
I think it's a problem related to your host operating system installation/configuration: tried also 2.0.1 (got an older version before) and running smoothly here.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: openSuse 12.1 Released, Comes With OwnCloud LXer Syndicated Linux News 0 11-16-2011 04:11 PM
LXer: First ownCloud sprint LXer Syndicated Linux News 0 04-22-2011 03:10 AM
LXer: Ever wanted your ownCloud? LXer Syndicated Linux News 0 07-20-2010 07:20 PM
I managed to get Dataone running! savio_mit_glug LinuxQuestions.org Member Success Stories 1 10-28-2005 05:49 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 09:46 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration