Visit Jeremy's Blog.
Go Back > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Slackware This Forum is for the discussion of Slackware Linux.


  Search this Thread
Old 09-02-2003, 12:35 PM   #1
Registered: Jun 2003
Location: Calcutta, India
Distribution: Slackware 9.0
Posts: 34

Rep: Reputation: 15
Cool Antialiasing in 1.0.3

Hi! I recently installed OOO on my Slackware 9.0 system.
The problem is, even if the options dialog has the use of anti
aliased fonts enabled, the UI and the text fonts are not anti
aliased. I have changed the UI font to Bitstream Vera Sans
(which is a nice aa font on all my KDE apps), but that does
not help. Changing the look and feel (to MacOS etc dont help
either. Maybe you can

Thanks in advance.
Old 09-03-2003, 05:06 AM   #2
Registered: Jun 2003
Location: Warwick (
Distribution: Arch, Slackware 9.0, (knoppix standing by)
Posts: 256

Rep: Reputation: 30
hi rajorshi,
Do you have anti-aliasing in X normally, for other programs? Unfortunately it sounds a little like you still need to configure freetype for X, to add anti-aliasing support. If so i suggest google
here's a tutorial to get you started (i'm afraid i can't find the excellent "anti-aliased fonts in X" tutorial i used when i did it, maybe you'll have more luck.)
Old 09-03-2003, 12:55 PM   #3
Registered: Jun 2003
Location: Calcutta, India
Distribution: Slackware 9.0
Posts: 34

Original Poster
Rep: Reputation: 15
But I have aa in my KDE/GNOME environments. All other
apps have beautiful aa fonts (i installed Bitstream Vera)
and they look great. Only OoO looks ugly!! (Slack9 has
support for Xft, aa etc)
Old 09-03-2003, 02:14 PM   #4
Registered: Apr 2003
Location: uk
Distribution: slackware current
Posts: 756

Rep: Reputation: 53
Rajorshi, I cant remember now where this came from, but it may help you:

"If your TrueType fonts on OpenOffice/StarOffice suck ass, obtain a copy of FreeType2 and enable the bytecode interpreter (instructions are in the tarball) -- Debian's FreeType2 has this already enabled from what I hear.

in your soffice shell script, add

export LD_PRELOAD=/path/to/

(on my system it is in /usr/lib)

I added this just under the comment describing how to disable antialiasing altogether, but pretty much anywhere in the file will do. Now when you run SO/OO you will be overriding the grid-based hinting that OO's freetype library uses in favour of the bytecode interpreter that does FAR better at hinting and placement. has before and after shots. An added bonus is that it seems to better listen to your XftConfig file as well.

OpenOffice disabled the bytecode interpreter because of Adobe patent issues (go to the FreeType site and look at the patent link) -- I don't know why StarOffice doesn't pay the royalty and increase the price of the software by the same amount, the difference in font quality is stunning."
Old 09-04-2003, 08:15 PM   #5
Registered: Jun 2003
Location: Calcutta, India
Distribution: Slackware 9.0
Posts: 34

Original Poster
Rep: Reputation: 15
THANKS a lot tobyl. At long last, my fonts
in OOo look good. Thanks for your
excellent advice. One small question -
my default font is Bitstream Vera Sans
12, how can I increase my default font
size to something other than 12 ?
Old 09-05-2003, 12:28 AM   #6
Registered: May 2003
Location: Upstate NY, U.S.
Distribution: Slackware
Posts: 248

Rep: Reputation: 31
To change your default font you have to set it in a template and use that as the default template. To create a template with the setting you like:

1. Open a new document (or use a document that you already have, but remember everything in the document will become part of the template, including any text).
2. Go to the paragraph styles list (the dialog box that is always open by default and that most people just keep shaded). Right click on Default and pick Modify.
3. Go to the Font tab and change the size to what you want. Then hit OK.
4. Go to the File menu in and choose Templates->Save. Name your template, pick your category (there is only one category, named Default, to begin with) and hit OK.
5. Go to the File menu again and choose Templates->Organize. Double click on the Category (folder) you put your template in to find it. Select the template you created and click on the Commands button menu and pick Set as Default Template.

You can use this procedure to make other changes to your default settings as well of course.
Old 09-05-2003, 12:07 PM   #7
Registered: Jun 2003
Location: Calcutta, India
Distribution: Slackware 9.0
Posts: 34

Original Poster
Rep: Reputation: 15

thanks to you as well !! A personal question,
have anyone of you been using OOo or
KOffice for a long time ?
If so, what are the pros and cons
of OOo/KOffice (leave out startup speed )


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
merge in mark_alfred Linux - Software 4 02-06-2006 05:47 PM aznboi12321 Linux - Software 2 03-05-2005 08:34 PM and m$ formats darkleaf Linux - Software 4 12-03-2004 12:11 PM big_syner Linux - Software 3 10-20-2004 01:52 AM Jafar Linux - Software 8 05-27-2003 10:47 AM > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 06:23 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration