LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 05-29-2005, 09:40 AM   #1
kee
LQ Newbie
 
Registered: May 2005
Posts: 2

Rep: Reputation: 0
an installation problem


Hello,
Recently I tried to install a Slackware 10.1 in my pc. Before that my pc had a win2k and SUSE 8.1 installed. The "slackware book" advises that the lilo shouldn't be able to work since my win2k partition is quite large (24G), so I meant to use the win2k os loader. But the os loader had been overwritten by the grub installed by the previous SUSE. So here I've got, a grub on the MBR and a win2k on /dev/hda1. After I installed the Slackware and restarted my pc, it went to grub and wouldn't boot any of the system. My questions are:
1. If I want to use grub, do I have to install it in my slackware by booting up from other means first, e.g. floppy, then configure it? Any other way of doing it?
2. whether can I install the lilo on the MBR to boot my slackware and win2k? I don't know whether the current lilo distribution or my bios can deal with the problem of accessing beyond 1024th cylinder. How can I find out?

I am quite new to linux. If anyboday can give me some advice or a link, that would be highly appreciated.

Thanks

Kee
 
Old 05-29-2005, 09:42 AM   #2
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 261Reputation: 261Reputation: 261
The slackware book your most likely reading is a little outdated. The updated versions of Lilo can handle past the 1024 cylinder mark so installing Lilo on the MBR shouldn't be a problem.
If you wanted to use grub with Slackware, you'd have to install it after the initial installation.
You can also setup your NTLoader to boot to your Linux installs..
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
problem with RT installation robertngo Linux - Software 2 07-17-2005 10:08 PM
Installation Problem Ricky_Hew Linux - Newbie 5 07-17-2005 04:28 PM
Installation Problem Louis11 Slackware 4 09-06-2004 08:55 AM
Installation Problem ALBlackshire Linux - Software 0 01-03-2002 08:03 PM
LiLo Installation problem ?and (GNOME and KDE problem) hitesh_linux Linux - Software 1 01-01-2002 04:56 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 03:14 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration