-   Slackware (
-   -   Alt key combinations not working in mc, Slackware 10.2 (

jcdrywater 11-17-2005 07:14 PM

Alt key combinations not working in mc, Slackware 10.2
I am no longer able to use ALT key functions in midnight commander since installing Slackware 10.2. This was not a problem in Slackware 10.1 and I haven't had this problem before in other distros. I am using xterm and I have set TERM=xterm. Pressing ALT-T in mc should change the display but instead generates a funny "o" with an carrot on top at the command line. I've tried rerunning xorgconf with a few different keyboard settings, but all have the same result. Anyone have any ideas?


- Jeffrey Drywater

Woodsman 11-18-2005 06:43 PM

Just some wild guesses, do you have rc.keymap enabled and if so, which keymap is being used?

Second, as you are using mc in an xterm window, do you experience the same results if you use mc in a non-X/GUI environment?

jcdrywater 11-19-2005 11:31 AM

It appears that this has something to do with how xterm is compiled on Slackware 10.2. I've been using xterm as my terminal for years. I tried rxvt and the KDE "konsole" program and the problem doesn't exist. So, I'm just going to switch to rxvt, which has the features I like and it a little less bloated than xterm anyway, and my problem is solved. Thanks.

- Jeffrey Drywater

maginotjr 11-21-2005 05:28 AM

your .Xresources or .Xdefaults are the same of slack 10.1 ? I dont know if it right but I think to remember that there are a option in xterm to enable it as a rxvt ... or you may try setting you TERM variable to rxvt and see if the problem continues

[ ]'s

All times are GMT -5. The time now is 04:06 PM.