-   Slackware (
-   -   alsamixer fails but kde sound ok slackware 13 (

timsoft 02-24-2010 05:33 AM

alsamixer fails but kde sound ok slackware 13
on ecs gf8100vm-m5 motherboards (which have gf8200 chipset) hardware is detected ok. result from lspi|grep Audio gives

00:07.0 Audio device: nVidia Corporation MCP72XE/MCP72P/MCP78U/MCP78S High Definition Audio (rev a1)
and lsmod|grep snd gives

snd_seq_dummy      3172  0
snd_seq_oss        33536  0
snd_seq_midi_event  7264  1 snd_seq_oss
snd_seq            56320  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device      7188  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss        42976  0
snd_mixer_oss      16768  1 snd_pcm_oss
snd_hda_codec_via  32836  1
snd_hda_intel      27176  0
snd_hda_codec      60192  2 snd_hda_codec_via,snd_hda_intel
snd_hwdep          8456  1 snd_hda_codec
snd_pcm            80872  3 snd_pcm_oss,snd_hda_intel,snd_hda_codec
snd_timer          22256  2 snd_seq,snd_pcm
snd                65000  10 snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_timer
soundcore          7168  1 snd
snd_page_alloc      9616  2 snd_hda_intel,snd_pcm

running alsaconf detects the builtin sound card and makes no complaints,
but running alsamixer gives

alsamixer: function snd_mixer_load failed: Invalid argument
this is a clean install (on a multiboot system running slack12.2,13.0 and 64-13.0) and the same problem is in both 13.0 versions of slackware.
(12.2 doesn't load modules)
I do get sound in kde even though kmixer settings seem to be ignored - you can set everything to mute, and sounds still play in gxine
i've checked the forum and google and haven't found a problem quite like this reported. needless to say the hardware is new and i am running as root, although get the same problem running as regular user who is member of usual audio,plugdev... etc groups
I am guessing that alsaconf is generating an config file that doesn't match the hardware properly, but that's as far as i have got.

any assistance greatly appreciated, thanks

extra comment - the same problem is on knoppix 6.01 (dvd) although I can't test from xwindows - kde as it doesn't like the refresh mode on my monitor.

I have another earlier edition of the same make,model and version number of motherboard which works in slack12.2 but it's chip is slightly different. lspci|grep Audio reports

00:07.0 Audio device: nVidia Corporation MCP78S [GeForce 8200] High Definition Audio (rev a1)

cladisch 02-24-2010 09:33 AM

Please show the contents of /proc/asound/cards and /proc/asound/devices and the output of "ls -l /dev/snd/".

timsoft 02-24-2010 10:07 AM

running cat /proc/asound/cards gives

0 [NVidia    ]: HDA-Intel - HDA NVidia
                HDA NVidia at 0xfce78000 irq 21

and cat /proc/asound/devices gives

0: [ 0]  : control
 1:        : sequencer
 4: [ 0- 0]: hardware dependant
16: [ 0- 0]: digital audio playback
17: [ 0- 1]: digital audio playback
24: [ 0- 0]: digital audio capture
33:        : timer

and ls -l /dev/snd gives

crw-rw---- 1 root audio 116,  0 2010-02-24 10:34 controlC0
crw-rw---- 1 root audio 116,  4 2010-02-24 10:34 hwC0D0
crw-rw---- 1 root audio 116, 24 2010-02-24 10:34 pcmC0D0c
crw-rw---- 1 root audio 116, 16 2010-02-24 11:33 pcmC0D0p
crw-rw---- 1 root audio 116, 17 2010-02-24 10:34 pcmC0D1p
crw-rw---- 1 root audio 116,  1 2010-02-24 10:35 seq
crw-rw---- 1 root audio 116, 33 2010-02-24 10:34 timer

hope that helps..

cladisch 02-24-2010 10:10 AM

Everything looks OK.

Do the following commands succeed?
amixer -c 0 controls
amixer controls

timsoft 02-24-2010 10:55 AM

not entirely.
both options report the same - see below


numid=2,iface=MIXER,name='Master Front Playback Switch'
numid=1,iface=MIXER,name='Master Front Playback Volume'
numid=6,iface=MIXER,name='Headphone Playback Switch'
amixer: Control hw:0 snd_hctl_elem_info error: Invalid argument

as you can see, an error after the first two entries

cladisch 02-24-2010 11:14 AM

This looks like an ALSA bug.
Please try a newer version of the alsa-lib package (-current has 1.0.21a, latest release is 1.0.22).

timsoft 02-24-2010 12:52 PM

I've tried 1.0.21a from current and same problem. I've just downloaded 1.0.22 source from (well a mirror as the main site's ftp was not behaving). I've run a ./configure and then make install but it's complaining that make file is in future (must be time zone difference - about 15 minutes difference) so i'll post results of that test later this evening,
thanks for help so far.

still no joy with 1.0.22 (assuming I did it right)
I guess I'll post a bug on
if I get any joy i'll post the info here

timsoft 02-25-2010 12:26 PM

Well, i downloaded all sorts of alsa packages and tried to compile and install them. The one that seemed to do the trick was downloading

extracting it with

tar -xjf alsa-driver-
going into the directory

cd alsa-driver-

./configure --with-debug=full --enable-dynamic-minors --with-moddir=updates


make install
then reboot the computer.

all of a sudden, alsamixer works a treat, and the volume controls and mute in kmix work and all the different channels etc are available.

thanks again for your assistance cladisch

timsoft 03-03-2010 12:02 PM

alsa-driver slackware package where is it? or how to create?
There isn't a alsa-driver slackware package, but my hardware requires alsa-driver-1.0.22-1 to work. (on-board sound on new motherboard/s). I have downloaded and run



make install
to install it, which sorted the sound/alsamixer problems, (it installs ok on slackware 12.2/13.0/64-13.0 ) but I would prefer to install it as a slackware package.

Does anyone have any suggestions?
It isn't available on and as it requires the source for the currently installed kernel to be available and isn't available in slackware itself as a separate package, i'm a bit stuck. Obviously the package would have to be tied to the kernel version eg. alsa-driver- or whatever.
If i had the slackbuild script that pat/alien/etc uses that would work.

dugan 03-03-2010 01:01 PM

The ALSA driver is part of the kernel.

Here's a previous thread about upgrading ALSA:

Mentioning which motherboard you have, btw, would be helpful to people who have the same one, or are thinking of purchasing one.

timsoft 03-03-2010 03:20 PM

board info etc
for those out there wanting to get sound on these motherboards working...
the motherboard is an ECS GF8100VM-M5 motherboard which has a GF8200 chipset. the audio part is reported by

lspci -vv|grep Audio

nVidia Corporation MCP72XE/MCP72P/MCP78U/MCP78S High Definition Audio (rev a1)
this is not to be confused with earlier production runs of the same ECS GF8100VM-M5 motherboards which work fine in slackware13.0 and 64-13.0 whose audio is reported as

nVidia Corporation MCP78S [GeForce 8200] High Definition Audio (rev a1)
I checked the previous thread you listed (plus a load of other ones) but it didn't really solve my question.

As I can successfully install alsa-driver- on slack12.2/13/64-13 without recompiling the kernel, it should be possible to create a slack package or packages of alsa-driver- targeted at a particular kernel/s. A simple uname -r check in the install script could install the relevant binaries. I'm sure it's already done by the folks at slackware even if it is bundled into a single kernel package.

thanks for the input.

dugan 03-03-2010 03:25 PM


Originally Posted by timsoft (Post 3884392)
I'm sure it's already done by the folks at slackware even if it is bundled into a single kernel package.

You are mistaken on that. Slackware did not use an alsa-driver build script since it started including the 2.6 kernel.

The simplest answer to your question, btw, is "use src2pkg on the alsa-driver source tarball."

titopoquito 03-03-2010 03:59 PM


Originally Posted by timsoft (Post 3884392)
I'm sure it's already done by the folks at slackware even if it is bundled into a single kernel package.

Alsa driver is part of the kernel. If you want to see which version your kernel has (current should be 1.0.21 at the moment I think) you can take a look at /path-to-kernel-source/include/sound/version.h and at /proc/asound/version to see what you're actually running in case you have installed a newer version.

dugan 03-03-2010 06:32 PM

In case you're wondering, timsoft previously discussed his research in this thread:

timsoft 03-05-2010 08:52 AM

thanks for the info on src2pkg. I've created a package for slack64-13.0 so i'll reinstall on a new hard drive, and install the created package to see if it works... - i'll post the result here, and if it does - and there is a need for it, i'm open to suggestions as to where to put it so that others can download it. (if it works, i'll try slack-13.0 and slack-12.2 as well.)

- well the package wasn't there, i tried setting FHS_POLICY to none, as stuff gets installed into lib or lib64 but it created a tgz file containing just an install script but no files.

It looks like i'll have to manually create a slackware package (and script) myself, something I was hoping to avoid.

All times are GMT -5. The time now is 07:01 PM.