-   Slackware (
-   -   alsaconf fails in Slackware 10, worked in 9.1 (

MDesigner 06-25-2004 03:43 PM

alsaconf fails in Slackware 10, worked in 9.1
In 9.1, I ran alsaconf and it worked perfectly. Now, with 10.0 (and I'm running the 2.6.7 kernel), it fails to find the sound card at all.

Any ideas on this ? I'm stumped.

moux 06-25-2004 04:04 PM

Because alsaconf is not able to find any modules.
You' need to compile sound card modules for your kernel. Either download, compile and install alsa drivers from or get the apporpiate packages which are made for kernel 2.6.7 using swart.

MDesigner 06-25-2004 04:39 PM

Hm, I already have the latest alsa drivers..

alsa-driver-1.0.5a-i486-2 (1484 kB) [Status: INSTALLED]

marsques 06-25-2004 04:44 PM

try compiling your own... with a couple of slack packages... they didnt work properly until i compiled them from source....

MDesigner 06-25-2004 04:45 PM

Will do

wastelander42 06-25-2004 05:23 PM

I had this problem after installing the 2.6.7 kernel as well. I installed the alsa-drivers in /testing/packages/linux-2.6.7/ alsa-driver-1.0.5a_2.6.7-i486-1.tgz and after rebooting everything worked fine.

moux 06-25-2004 05:31 PM

He's right you need to get the kernel wich is compiled for 2.6.x series

MDesigner 06-25-2004 06:20 PM

Awesome..that worked! Simple as hell. Too bad it required a reboot though!

keefaz 06-25-2004 06:28 PM


Too bad it required a reboot though!
You can always fake boot for alsa by executing /etc/rc.d/rc.alsa so it loads without reboot

All times are GMT -5. The time now is 05:26 PM.